[SOLVED, kind of] Ubuntu Budgie fingerprint reader woes

I installed Ubuntu Budgie 21.10 yesterday and so far I’m pretty happy with it, however I can’t get the fingerprint reader to work.

What I’ve tried:

  • installing libfprint and fprintd (1.90 each) from the provided ppa (the official Ubuntu 21.10 guide says this should somehow work)
  • manually installing these packages (1.94.2) from launchpad.net

I tried rebooting and adding a user with fingerprint auth after each, but to no avail. Also TLPUI showed the Goodix reader device as having no driver every time.

What I did before that may be relevant:

  • I first installed Windows on this machine to update my SSD (couldn’t get the Ventoy solution to work in time). I wasn’t prompted for a fingerprint though and didn’t register one either. I did however install the driver bundle as that was needed in order to update the SSD.
  • After that I installed Kubuntu and tried the same solutions as outlined above, also to no avail and I switched because it wasn’t that nice of an experience.

Can anyone help/troubleshoot with me?

Nevermind, it seems Ubuntu Budgie (21.10 at least) does not yet support GUI fingerprint magic ootb, fprintd-enroll worked just fine. I will leave this up for anyone who has the same problem.

EDIT: After doing some digging, Ubuntu Budgie actually should support this… I will try a 22.04 build now.

UPDATE: Didn’t work there either…

UPDATE2: Using fprintd-enroll and sudo pam-auth-update has gotten me to an acceptable state, so I will not dig any further for now.

Works for me in Ubuntu Budgie 21.10 after installing gnome-tweaks (sudo apt-get install gnome-tweaks)

1 Like