[SOLVED] All but one expansion slot stopped working

One day I noticed the sd card expansion slot stopped working. I figured it was a kernel update and ignored it. A few weeks later, I couldn’t get a usb-a thumb drive to detect. I started testing and here’s the results:

  • Only the back left slot works for usb-c, usb-a, and microsd slot. In any of the other slots the expansion cards no longer work.

  • Using the usb-c expansion card, charging only occurs from the back-left slot.

  • I later found out that a usb keyboard would be detected using the usb-a expansion card in any slot.

This is a framework 13 amd 7840 laptop from batch 2. I get the same result in both Windows and Fedora Linux. Yes I am aware of the expansion slot limitations and how they don’t all have the same capabilities. No I have not caused any physical or liquid damage to my laptop. I have already tried 3.03b beta bios.

I contacted support, but they replied saying they’ll be awhile as they’re busy. In the meantime, I figured I would reach out to the community. Has anyone ever experienced this? Is there some sort of hidden reset process like the old macbook PRAM reset procedure?

Thanks for the thorough report. Makes troubleshooting a lot easier. :heart:

Since you’re getting the same results under both Linux and Windows, it has to be a hardware problem, rather than a software/driver one.

Unfortunately that’s about as far as my knowledge goes (still waiting for my Framework to be delivered, sorry). There is a motherboard-reset procedure, but it appears to be specifically for the 11th-Gen Intel motherboard.

If I were facing that issue, there are a couple more things I’d try:

  • Open the machine up and (carefully!) disconnect the battery. With the battery disconnected, press the power button. That should drain all power from the motherboard, resetting anything that hasn’t been written to persistent storage. Then reconnect the battery – again, carefully! – and try the cards again.
  • Go into the BIOS settings and see if there’s any kind of reset-everything option. If there is, use it, after noting any changes you’ve deliberately made to the settings so you can restore them afterwards.

I have no evidence that either of those will help, or that the second is even possible. Neither should cause any further damage though, other than requiring resetting your system’s clock (probably automatic once the system boots and has Internet access again).

3 Likes

Huzzah! That actually worked. I disconnected the battery, reconnected the cable for the keyboard and touchpad, held the power button for 10 seconds, then reconnected the battery. On first boot I just went into the BIOS and noticed my settng to only charge the battery to 90% was still present. I reset the BIOS to factory settings, saved, then quit. I booted into Fedora and all my expansion slots are working now!

Imagine that. Framework made an easy to repair laptop and now they don’t have to send me replacement parts under warranty or deal with my support case!

6 Likes

:man_dancing: :laughing: :+1:

1 Like