[RESOLVED] Mainboard Standalone w/o Framework Laptop (AMD 7040; 5 7640U)

Hey all the details requested are below. Basically I got the AMD mainboard for the sole purpose of putting it in the cooler master case and running it on its own, I do not have a framework laptop of any kind. I assumed this would be like anything else I’ve done before where I can power it on and install an OS. I assume in being new to the framework mainboard I am missing something but I can’t get it to post.

Pressing the power button does nothing. I have it connected to the framework power supply on one USB-C port and to a monitor via the other USB-C port (direct USB-C monitor). Once plugged into power the mainboard LEDs flash between red and blue on both sides and never stop.

I did follow the instructions for putting it into the cooler master case to the letter but have no need for audio or wifi so those aren’t present. I have the ddr5 provided by framework and an ssd installed (empty). Anyway any help would be appreciated I couldn’t find anything in the community related to this issue even on the intel side so sorry if something already exists.

Hopefully I’m just doing (or not doing) something simple and dumb and someone can enlighten me quickly. Either way thanks for reading all this!

  • Which OS (Operating System)? N/A yet as none setup
  • Which Framework laptop (11th, 12th or 13th generation Framework laptop) are you asking for support with? N/A, using AMD mainboard on its own

I don’t have that board, but I would expect you at least to get to the bios. You might check which port you have the display attached to:

Supporting USB4/DP for upper left and right slots, USB 3.2/DP for lower right slot and USB 3.2 only for lower left slot, along with USB-C power input on all four slots.

The only other thing that I can think of offhand is to attach a bootable USB stick, and to try the memory one stick at a time, one slot at a time.

Good luck!

Edit to add - some ideas in this thread as well: [RESOLVED] Power on, no display output

There’s something like a “standalone mode” setting in the BIOS.
I believe the default is OFF.

I wonder if it requires the battery connected to it to even get to BIOS when in normal mode. If true, there wouldn’t be a way to change it to standalone mode without having a battery, at least temporarily.

Sounds like a problematic issue.
Did you consult the official support yet?

Hey all wanted to say it looks like I figured it out, it was very odd, but does seem to be working. I wanted to say this now in case anyone else comes looking before I can update the post, don’t want anyone else to waste time troubleshooting.

@ATi I didn’t reach out to support as I didn’t want to trouble them (I know they are swamped right now) in case a community member knew what was going on. :slight_smile:

In case anyone happens upon this I promise I will not be DenverCoder9; I will update this with all the random steps I went through as soon as I can. If not tomorrow then sometime this weekend. Thanks everyone that tried to help!

Side note how do I mark an issue as solved here?


I updated it for you. All you have to do is scroll to the top of the thread and you’ll see there is a little edit button next to the title (looks like a little pencil). Click that and you can edit the thread title. Glad you found a solution! Cheers!

1 Like

For anyone coming here in the future looking for a way to get a standalone AMD Mainboard to work without ever touching a Framework laptop it is possible. I’ll break down the steps of getting it to work below. Few caveats and things to note… Most things I tried over and over again before completing the step to make sure it worked consistently so if I say something it happened multiple times for my setup. A big thing is that no matter what I tried I could not get it to display anything on the screen before standalone mode was enabled if I had an SSD installed. Another major caveat is that at least for the USB-C display (could be different if you have/use an HDMI/DP card) is that I tried every single port and the only one that worked for display prior to having the OS installed was the bottom right port. None of the below steps worked for me if I used any other port for display.

This was done with the AMD 5 7640U in the Framework/Coolermaster case with 16gb of DDR5 RAM and the boot drive removed.

  1. Ports Used:
  • Top Left: Keyboard
  • Bottom Left: Power (60w framework adapter)
  • Top Right: Ethernet expansion card, followed by USB-C drive for installer
  • Bottom Right: USB-C to Caldigit Element Thunderbolt dock to USB-C monitor, I did test it with USB-C straight to the monitor (non-thunderbolt USB-C monitor) and that seemed to work exactly the same, both provide power so to not confuse the initial boot do not plug in until the board is booting properly
  1. Getting it to boot
    It has been pointed out in the forum before that you need to wait for the red/blue “storm” of lights on both sides to finish before trying anything. Mine never ends (left for many hours) so I decided to try some things and from my testing it doesn’t matter how soon after you try to boot, plug it into AC for the first time and you can go through this process. The mainboard refused to boot consistently so with the monitor unplugged and only the keyboard and power plugged in you need to press the power button and see if it starts a proper boot sequence. The red/blue lights will have an irregular pattern at some point if it shuts itself back down and doesn’t work, the reason I left the ethernet expansion (no ethernet plugged in) in is that makes it easier to tell if it is working or not. The ethernet card will flash its lights only once if the boot process failed. If it worked properly the card will flash more than once (time between the flashes but it won’t happen ever again if the boot failed). You’ll need to wait 10-20 seconds between each attempt as it won’t try to boot again if you do it too early. At some point (seems to be 1 in every 5-10 attempts will be a proper boot) it the red/blue flashing will stop and it’ll go through the post LEDs and settle on the standard white/light green power LED on the side of the board providing power. This should be on the side you have your power adapter in, this does not work (confirmed for me at least) if the power is on the side of the monitor which is why you leave it unplugged.

  2. Display/Standalone Mode
    Get the display plugged in right away after the power LED comes in, also don’t try to hammer anything on the keyboard to get into the BIOS it doesn’t matter at this point. The first thing that will pop up (it will go away if you don’t get to it right away so make sure to do it now) is a screen saying it detects a the board might need to be in standalone mode and asks if you want to change it to that. Use your keyboard to accept the change to standalone mode (if you don’t do this you’ll have to start over). The board will look like it is rebooting at this point but the display never comes back up. You have now got standalone mode to work but it is still gonna hate being consistent, the only way I got it to work again was to disconnect from power and starting again from step 2. Remember to disconnect the display.

  3. BIOS
    I needed to get into BIOS before SSD/OS installation, if you don’t need to adjust secure boot you should be able to skip this but I didn’t try it so YMMV
    At this point you’ll have repeated step 2 to get it to do a proper boot again (still keep the SSD out at this point, I did try with it in and I never got anything on the display) but the difference this time is as soon as the red/blue is done and the power LED comes on you’ll connect the monitor and hammer F12 to get into the BIOS. If all went well you’ll be at a BIOS screen. In the advanced settings disable Secure Boot if you need to (I had to as I’m installing ProxMox) before saving and exiting though I’d change any other settings in the BIOS you want to as well. The only other thing I changed myself was the power on AC setting. At this point you can save and exit.

  4. SSD Install/Setup
    At this point disconnect power and your monitor. Install your SSD to the board and close the case back up. Plug your flash drive with your install media into the top right port (so remove the ethernet card if you had it in there) and keep your keyboard in place (top left port) but keep your monitor disconnected. Since you disconnected from AC you’ll get the red/blue LED storm again but we’ve all been here before so repeat step 2. If your USB has an LED you’ll get feedback from that (mine does) similar to the ethernet card the LED on the USB should go off pretty quickly if the boot is failed but will stay on if it is a going to be a good boot. Once the power LED comes on plug your monitor in and wait for something to show up on the screen. I tried this 5 times (yeah I know but I had to make sure it worked every time for peoples :slight_smile:) and it took anywhere from 1-5 minutes (just random I guess) for the screen to show the install screen from my flash drive. So just walk away at this point, hopefully you come back to an install screen.

  5. Working?
    At this point you’ll have finished installing your OS to your SSD and you’ll have a working mainboard without ever having touched a mainboard case. I no longer get the red/blue storm no matter what I do. I can unplug from power, leave unplugged, go back to it and it just boots like a normal computer. Annoyingly boot on AC power doesn’t seem to be working but as long as I press the power button it boots into the OS in seconds. Power directly from the dock or monitor works on its own now too and still shows on the display. So any inconsistent boot issues should no longer exist at this point for you too (hopefully).

I guess let me know if you have any questions, but I think this was a pretty thorough guide so I don’t know how much help I’ll be beyond this unless I just left something out. I’m not planning to wipe my own OS to troubleshoot anything else at this point. I did a lot of testing in between each step to get to a working system so I’m good with staying in this state :smiley:

Either way hope this helps someone!