[SOLVED] Constant Red Blinking Lights when Powered On

  • Which OS: Linux - Ubuntu 22.04
  • Kernel - 5.19.0-38-generic
  • 12th generation Framework laptop

Hi all,

The lights on the side of my Framework blink red constantly when the machine is on. It is as if I have the input cover off, but I have checked the cover several times and it seems well secured.

The machine continues to work fine, but the blinking lights are both a bit annoying and a bit concerning. I want to make sure nothing is actually wrong.

Any thoughts on things I should check, or try?


This is a safety feature that means that the chassis intrusion switch is tripped while the laptop is powered on. It’s supposed to warn you not to start disassembling the device because its not fully off.

I would double-check that the input cover is fully installed. If that doesn’t work, check that the black foam cube on the back of the input cover (circled in red on the below image - ignore the yellow arrows) is properly placed. There should be an outline engraved into the aluminum where it is supposed to go, and if it’s not properly seated, it will not engage with the intrusion switch.

1 Like

Thank you so much!

The cover was fully seated, but the black foam cube was very slightly off in its placement, maybe a millimeter or two. Moving that over slightly and putting the cover back on fixed it!


Happy to help! I had the same issue after I updated my RAM a few months back. I must have bumped the foam out of place. I’ve marked this thread as solved. Welcome to the forums!