[SOLVED] Fingerprint reader not working in KDE 5.24 beta

Hi all. Wondering if anyone else has tried the beta version of KDE 5.24 and run into this issue. Whenever I go into System Settings to set up a fingerprint, it lets me go through all of the steps to enroll a fingerprint, but on the very last scan of my fingerprint, it always ends up erroring out and saying “The device was disconnected”.

I’m running Garuda Linux.


Have you enrolled fingerprints with the reader on another OS before? The reader saves them locally, so you might have to delete the old ones first. There is a python script for that, I’ll update my reply when I found it.

UPDATE: script can be found here: https://github.com/lightrush/framework-laptop-formula/blob/main/framework-laptop/files/fingerprint-reader/libfprint_delete_device_prints.py
or here: Fingerprints not getting deleted from device? (#415) · Issues · libfprint / libfprint · GitLab

That worked! Thank you!


No problem, I updated the title, hope that’s okay