[SOLVED] Ubuntu 22.04.01: finger print reader not working

since I upgraded to the most recent Ubuntu version I can’t use the fingerprint reader anymore. Using the GUI I get an error message “problem reading device”. So I upgraded everything and used the “fprintd-enroll” command. The program freezes after reading the first finger. This is what I found in the syslog:

Nov 14 10:39:58 vanguard systemd[1]: Starting Fingerprint Authentication Daemon...
Nov 14 10:39:58 vanguard kernel: [  663.357249] usb 3-9: reset full-speed USB device number 4 using xhci_hcd
Nov 14 10:39:58 vanguard dbus-daemon[952]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 14 10:39:58 vanguard systemd[1]: Started Fingerprint Authentication Daemon.
Nov 14 10:39:58 vanguard fprintd[7236]: libusb: error [udev_hotplug_event] ignoring udev action change
Nov 14 10:39:58 vanguard kernel: [  663.649311] usb 3-9: reset full-speed USB device number 4 using xhci_hcd
Nov 14 10:39:58 vanguard fprintd[7236]: message repeated 3 times: [ libusb: error [udev_hotplug_event] ignoring udev action change]
Nov 14 10:40:04 vanguard gnome-shell[7251]: polkit-agent-helper-1: pam_authenticate failed: Authentication failure
Nov 14 10:40:15 vanguard fprintd[7236]: parse fingerlist error
Nov 14 10:40:15 vanguard kernel: [  680.889743] traps: fprintd[7236] trap int3 ip:7f26d9448ccf sp:7ffd49bc6400 error:0 in libglib-2.0.so.0.7200.1[7f26d9409000+8f000]
Nov 14 10:40:16 vanguard systemd[1]: fprintd.service: Main process exited, code=dumped, status=5/TRAP
Nov 14 10:40:16 vanguard systemd[1]: fprintd.service: Failed with result 'core-dump'.

What went wrong here?

I know this post is dated but I ran into the exact same scenario you’re experiencing, so I hope these steps help:

Use the AppImage to clear any previously stored fingerprints (optional)

^ might require libfuse2 if not already installed

Next, completely remove fprintd
sudo apt remove --purge fprintd
clean up anything left over
sudo apt autoremove --purge

Then, install the following package:
sudo apt install libpam-fprintd
this should automatically hit the fprintd meta package and install any dependencies.
Next make sure it’s started
sudo systemctl status fprintd.service
if it ain’t green (active) then restart it
sudo systemctl restart fprintd.service

Enroll your fingerprint:

after it shows completed run the following (DO NOT TEST IT OUT YET, PATIENCE!)
sudo pam-auth-update
select Fingerprint Authentication and Ok
Reboot your machine
Try and login with your fingerprint
Try “sudo” from terminal and see if it prompts/accepts your fingerprint
Try launching a GUI app that requires sudo and see if it works

I’m not an expert, your mileage may vary. I just recently picked up the Framework i7-1280P and have been tooling around with it for a few days. IMO is a solid rig and will be a well suited replacement.

I wrote the steps out specifically because I wasted half a day installing it how you expect to install it “sudo apt install fprintd” with no successful results (in fact I invoked a known bug where I couldn’t login through GDM) so please follow the steps as written.

PS: The result will show the stored fingerprint in the GUI
But I would strongly advise AGAINST using the GUI for this. There’s definitely something going on there

I’m sure there is a way to declare/name a fingerprint that you are enrolling, I am just too lazy to read the man for fprintd


In my testing the GUI works fine. unless something is off somewhere with a specific config.

Left side of the page, start with sudo with your fingerprints. This should provide anyone reading this with a working result.

For what it’s worth, I was on the stock LTS kernel during initial setup, I want to say that was 5.15ish?

I only later installed the linux-oem-22.04c package so that might be why I experienced a rough setup.
I have a bad habit of not reading directions/manuals :confused:

Follow Up: Enrolled a few other fingers from the GUI, works without issue on linux-oem-22.04c which is 6.1.0-1006-oem

No worries, I get it. We’ve tested it with linux-oem-22.04 (no c). So using this, follow the guide, all should be right with the world.

@wiggmpk Thanks a lot. Deleting the old fingerprints solved the issue for me. I previously tried different methods to delete the fingerprints, without success. The package you linked works for me.


When install Ubuntu 20.04 first time, fingerprint works; when installed second time “Problem Reading Device” even after restart, etc.

Conduct following, have not fixed it yet.

sudo apt remove --purge fprintd
sudo apt autoremove --purge
sudo apt install libpam-fprintd
sudo systemctl status fprintd.service
sudo systemctl restart fprintd.service

On Windows 11, fingerprint has no problem.

@Emory_Hellips unless you have a very specific reason to use 20.04, I recommend you upgrade to Ubuntu 22.04 and follow this guide Ubuntu 22.04 LTS Installation on the Framework Laptop 13 - Framework Guides

1 Like

This, yeah, do not use 20.04 LTS - we want folks on 22.04.3 LTS - we are not supporting this in tickets and honestly, a lot has evolved.