[SOLVED] Framework 12th gen with Plugable Thunderbolt 3 dock


I have the 12th gen (i7-1280) framework, and recently purchased a Plugable Thunderbolt 3 dock with loads of USB connections: Amazon.com. The dock works great on a macbook from work, but it keeps disconnecting from the Frame.work laptop – to the point where it is unusable. At seemingly random intervals, sometimes as short as 10 seconds apart, it will beep indicating the devices were disconnected, and then beep again indicating they have been reconnected. Are there thunderbolt drivers that need to be installed on windows 11?



1 Like

There is a driver package! I checked the controller revision and it seems recent so it might just be the drivers. Go ahead and update to the beta BIOS as well for 12th gen as that actually make it fully TB4 compliant.

@Matt_Jones1 this is almost definitely an issue caused by the BIOS. I had several Thunderbolt 3 docks give me flickering issues until I updated to the 3.06 beta. Mind you it is still not perfect, every thunderbolt 4 dock I have tested fails to discover displays on a cold boot, and if it does it drops them before login, requiring a power cycle/unplug.hotplug. Nice thing is they worked 100% of the time when hotplugged. Every thunderbolt 3 dock I have tested just works.

Docks tested: Dell WD19, Thinkpad Thunderbolt 3 Dock (40AC0135US), Anker Power Expand 5-in-1, Plugable TBT4-UDZ, OWC Thunderbolt Dock. I settled on the OWC model since it has downstream ports and worked reliably under the most conditions (still fails the cold boot test) while actually delivering close to the claimed power delivery.


Thank you @nadb and @GhostLegion for your quick help! I was able to install the new firmware today, and am just now trying it out. Sometimes it worked for a while before it broke, so I won’t know for sure until a few days have passed, but so far, this appears to be working! Thanks again!


As of now, I’d say that the new firmware worked great. The only caveat is that at least one USB accessory, which only needs power, the Targus Laptop Chiller – https://amzn.to/3GoBMd7, when it is plugged in to the dock while the thunderbolt dock is being plugged in to the computer, I get frequent disconnect issues, as evidenced by the following messages in Event Viewer:

A monitor attached to your hub or dock could not be enumerated by the USB4 Connection Manager. This may be expected if the dock or system does not have sufficient resources or bandwidth to support the monitor. ReasonCode1:0x1 ReasonCode2:0x0 Status:{Operation Failed}

The requested operation was unsuccessful.

USB device draining system power when system is idle.

USB Device: VID: 0xB0E PID: 0x420 REV: 0x225
Removal action failed: QueryRemovalInitiated

So, I’ve simply unplugged that, and if I plug it into the base station when I need to, it works just fine.


No sooner had I pressed submit on the last “it’s all good” post, and it disconnected. And it did it again while I’m writing this. The laptop chiller fan is unplugged. The only error I see in the event viewer is:

Error setting traits on Provider {8444a4fb-d8d3-4f38-84f8-89960a1ef12f}. Error: 0xC0000001

I can only suggest reaching out to support at this point. I’m interested in learning what they have to say or suggest.

Posting an update here for the next folks who run into this problem. For me, when I remove the expansion card, and plug directly into the interior USB-C port, the thunderbolt worked flawlessly. I’ve asked Frame.work to replace my expansion cards, but in the meantime, I think I have a solution.

1 Like