[SOLVED] Has anyone had problems with connecting to the internet on Fedora?

Started a few days ago for me on my Framework laptop 11th gen. It works on my Windows partition but not Fedora. It shows me connected to my Wifi but Chrome says “ERR_NAME_NOT_RESOLVED” and Firefox says it can’t connect to server. Any suggestions to fix it?


Hi I’m sure I saw something but couldn’t find it, there is a somewhat related issue that may provide some idea of what can be tried/tested

Is this is Fedora 37 or Fedora 38?
What was the last change made to the installation? Updates?

Are you connected to a VPN and can you ping your router?

Thanks for the reply. Turns out the (poorly designed) ProtonVPN sometimes has problems closing and allowing connections, even when you are not connected to the VPN and persists even after force closing with System Monitor. After ensuring it had been closed completely, my connection resumed. They are supposedly rewriting the application so I hope bugs like these disappear.

Thanks for the willingness to troubleshoot this issue.


From one perspective, the VPN is doing it’s job - connection stops being secure for some reason, kills the connection with fire. Unfortunately, it may be doing this when it’s not desired.

ExpressVPN is, kinda better in this space. Sorta, but that’s based on light usage. They do update their application often though.

Marking solved as we know the cause of the issue.