[RESPONDED] Can't connect to internet despite having a wifi connection

Hello everyone. I’m using a Framework laptop and just noticed that, after a recent update, I cannot access the internet via wired or wifi connections.


Web browsers(Firefox), redirects me to the “Cannot connect to the server” page.

sudo dnf check-up date gives me Curl Error 6, failed to download metadata.

And Ping google.com results in “Name or service not known”.

The weired thing is, whenever I connect to a wifi or wired connection, Gnome settings recognizes it perfectly fine. Visually, there shouldn’t be any issues with my internet connection.


Batch 4 gen 1 Framework Laptop with
Intel 11th gen i7 1165g7
And the wifi card is the Intel WiFi6 AX210

Does anyone know why this is happening?


This sounds like a DNS issue. Can you ping (one of google’s addresses)? If so, it’s definitely a DNS issue. You could try changing what you are using as your name server and see if that resolves it. Can you ping other machines in your network?

After a few hours of Timeshift backups, kernel removals etc.

I have determined there was a probably a bug with Kernel 6.3.6
reverting to 6.2.9 via timeshift, then updating to 6.3.8 seems to have solved issue.

1 Like

Hello everyone.

I am a long time Fedora user since Fedora 32. I have been using the same install with minimal issues this have little experience with fixing big issues.

I believe I started with Fedora 35 on my Framework.

Today, I share with you a very weird issue I am having.

After an update, my system cannot access the web in any kind. While the system blatantly says I am connected to my home wifi/Ethernet, I can’t do web searches or use the

Now, you may have seen a post from me, detailing a similar issue. I am sad to say that the issue miraculously returned and I no longer have access to my old backup.

ping www.google.com

Command or the dnf command.

I have tried different Wifi networks, and even different wired connections. Only my Fedora Laptop does not work.

As I have said, I have no clue where to even start with fixing this issue.

This is the hardware I am using

If you need me to tell you specific installed software versions, please let me know which command to use and I will comment below.

If anyone knows, please lend me a hand. Best regards, Paul Kim.

On your previous thread, you said it didn’t work with kernel 6.3.6, but did work with older and newer versions. Looking at the HW probe, you’re back to kernel 6.3.6. Do you just need help changing kernel versions without internet access, or is there more going on and your previous observations are no longer correct?

hi @Paul_Kim ,

have you tried temporarily adding google’s dns on resolve.conf and see if you it resolve what looks like a dns issue?

sudo nano /etc/resolve.conf

then just add google’s dns at the bottom


close and save and try to ping or open a website on the browser.

After two weeks of unresponsive internet, the system is now back up and running? I truly have no idea what happened during that time. Looking back, it may have had to do with a faulty OpenVPN setup.

I’ll continue to look into the issue since I have the problem setup in a timeshift backup but for now, case closed.

1 Like

Thanks for the update @Paul_Kim