[SOLVED] Help - Windows install via USB-C flash

SSD re-seated

Same results

Still says “A media driver your computer needs is missing”

1 Like

Media driver missing is usually not a hardware issue but an issue with the USB drive. I’d usually recommend Rufus or WoeUSB if you’re on Linux, but since you’re using a mac… Maybe there’s a different setting in UUByte you can try? Or you can get your hands on another computer to flash using Rufus

Could it be an issue with the SSD? I’m not seeing it in the BIOS.

What setting should I be looking for?

The only place I see my SSD mentioned is in the boot devices menu, it’s not mentioned anywhere else.

I would make sure to use Partition table MBR and type FAT32.

I know I used FAT32 but I’m not sure about MBR. Trying that now

EDIT: That did not help. Making a trip into Minneapolis to visit my son. He has a windows computer so :crossed_fingers: that will fix my issue.

SO frustrating!!!

Next step is reaching out to FW directly. What are your experiences with that?

1 Like

Drat. Hopefully formatted from a Windows computer will work, Windows installers can be finnicky in my experience.

Framework support is great, but they’ve got about a week’s backlog of support tickets at the moment, so it may take a bit for them to get back to you.

Given the question, there’s a distinction between USB-C and USB 3.

How old is that ISO? i.e. Not all Windows 11 ISO are the same.

Update: SUCCESS!

Arrived at my son’s apt & he had me up within 15 mins.

Answer to ALL the frustration was using a usb actually formatted on a windows machine.


Awesome! It’s surprising how Windows 11 seems to have gotten more difficult to install compared to Windows 8/10.

For the record, Windows 11 will not install on a system with an MBR partition table. You need to use GPT. I suspect that was the issue (which could explain why re-doing it from a Windows machine fixed it)

Hey glad you had success installing windows. Could you mark this topic as solved?

I hope you enjoy your Laptop.


1 Like

For the record I had originally tried using GPT & that was unsuccessful as well. Obviously Microsoft was being temperamental & did not like playing with Apple’s software no matter how I tried to bridge the distance between them.


I’ve only Linux Mint System76 laptop and on Framework Laptop 16 Ryzen DIY Edition got stuck at the same page/screen as @Eclectic in reply #6 to this thread. Couldn’t find Rufus via Linux Mint software manager, so could you (@kjhoerr) link the package and/or Linux install instructions for it here?

Otherwise, I’ve a date set with my spouse’s friend’s partner to use their Windows computer to create the bootable USB.

Rufus is a Windows only application. Try WoeUSB:

1 Like