[Solved] Windows install - blocked at "A media driver your computer needs is missing."

:frowning: Yeah nevermind, I just checked my bios and nothing except for the EFI entries. I wonder if it shows up under F12 (though again, think it maybe just EFI entries instead of actual devices)

My last thought is just run a live distro (Ubuntu 21.04, etc but something that supports new Intel) and confirming it sees the drive. Always the worst when you try every software trick just to find out its bad hardware!

My last thought is just run a live distro (Ubuntu 21.04, etc but something that supports new Intel) and confirming it sees the drive

Great idea! (I’m glad I’m helping my son do this – I think he’d have given up by now)

The perils of DIY :slight_smile: Getting windows installer to run was the slowest part for me as well. Good luck, let us know if Ubuntu see’s everything fine.

I have an external NVMe → USB C adapter, was able to verify the SN850 works, gave it a FAT32 format, and indeed it shows up when I try to “Browse” for drivers at this Windows install step. The odd thing is that it doesn’t say which device’s “Media drivers” it needs to allow the installation to finish.

I’m about to try the Ubuntu boot now - aand, it installed on the NVMe drive fine. So, it seems to be Windows-specific. I’m trying the Download Windows tool (I previously downloaded an ISO and used dd to get it on the thumb drive). We’ll see how that works.

OK - it’s working now, and the solution was to use an existing Windows machine and run the Download Windows // make USB tool. Microsoft’s website said the .ISO should be copyable to a thumb drive, and it got me as far as the screenshot above, but left me in this “Media driver needed” state. With the very same thumbdrive, written via the Windows tool, it’s now completing the installation. I don’t know what folks for whom this is their only available Windows machine are supposed to do. I’ll not forget to install the Framework Drivers as well. Thanks, @Davy_Bell and @jr123 (in another thread) for the help!

4 Likes

Glad to hear it! I only trust dd for .img files nowadays. The Windows media creator definitely creates a set of EFI style partitions so it probably has the installer on a pointer to the image in another partition, thus you lose parts of the installer?

Reminds me of custom EFI bootloader (coreboot) on Macbook Air, could have custom themes and easy other OS installs, but if a pointer got messed up, you had a few hours of trying to reorder partition GUIDs

Glad you were able to get it sorted! We definitely recommend using the Windows Media Creation tool to set up the thumb drive, since Windows has some pretty particular requirements about the boot/install media.

1 Like

We definitely recommend using the Windows Media Creation tool to set up the thumb drive, since Windows has some pretty particular requirements about the boot/install media.

Following the link in your Windows Install Guide on a machine that isn’t running windows was my mistake: Microsoft’s site auto-detects your browser / OS and redirects you to downloading the .ISO. I’ve burned so many EFI - bootable ISO’s (for macOS and Linuxes), I thought “no problem”. Worse, it gets shockingly far into the install, then throws what seems to be an unrelated error. This is definitely Microsoft’s problem, but it’s a problem for folks starting the process without a Windows machine handy. It added 5 hours to my “getting the Framework going” process (!)

5 Likes

Sorry for the pain and thanks for sharing the solution. I would’ve been burning the ISO on Linux so… you saved at least one soul.

2 Likes

Ah! Got it. I’ll update the guide to note that.

Edit: At some point, we’ll also need to write a guide on how to create a Windows installer from Linux or Mac.

3 Likes

A great tool that works on both linux and windows is Ventoy - additionally, it lets you copy over as many ISOs, WIMs, and even VM disk images can be booted. While there is no MacOS ventoy installer, once ventoy is installed on a USB drive, ISOs can be added from any OS that can mount exFAT partitions. It’s also FOSS.

5 Likes

Here is how to use ventoy to create a bootable usb from linux:

  1. Install Ventoy onto a USB drive
  2. Mount the first partition created by ventoy on the USB drive (e.g /dev/sdb1)
  3. Copy the Windows 10/11 iso file to the first partition (exfat)
  4. Unmount/sync/safely remove the USB drive
  5. Insert the USB drive in your Framework laptop and turn on
  6. Boot from the USB drive
  7. Follow the instructions at secure . Ventoy to enable secure boot (Maybe you could disable secure boot in the BIOS, not sure)
  8. You should then see the ISO you added to the USB drive as a selection when Ventoy boots

I’ve had this issue with some USB installers, oddly enough cancelling the installation, going to the main install screen, and switching the USB drive to a new port worked, like some black magic.

1 Like

It most certainly is!! My laptop has been collecting dust for a week while i try and find a windows machine to turn on my windows machine.

Many local libraries have machines that allow you to download a file, or will do it for you.

In case you do not have a Windows machine, here is a method for creating a usable win10 installation on a USB stick: How to make Windows 10 USB install media in Linux

I used my Framework laptop running Linux to do this. The compression of the win file does take some time, but it was successful whereas simply copying the ISO bytes to the USB stick resulted in the original symptom described at the top of this post.

4 Likes

The instructions in the above post worked for me as well. I didn’t have a USB stick handy, but it actually worked fine doing the entire thing off of a micro SD card using the micro SD card module.

Just to add an alternate solution to this issue, the woeusb library worked great for me to set up my win10 USB with my downloaded ISO, while manual set up did not.

Years later this is evidently still relevant for Microsoft’s latest installer ISO images. I followed d2r’s tip above and prepped install media manually and it did the trick.

I have just received my AMD laptop - and have hit the exact same issue. Sadly there is a driver bundle, but it’s a .exe so can’t be seen by the installer.

EDIT: rebuilding the USB with rufus, powering off the machine and back on again - it works. Bizarre!