[Solved] Help with forum (are the permissions broken?)


I think the getting started thing might be broken. Or I am not clever enough to work it.

ex. There’s a Getting Started post saying Introduce Yourself, but no reply button?

ex. Discobot tells me I should bookmark its message… but there is no bookmark button (only heart and link)

ex. It says I can reach out to mods but when I view one of their accounts there is no DM button or similar - only way to contact seems to be twitter?!

Hey there and welcome to the Framework community. It sounds like your account is still considered basic level, which disables a lot of functionality until you complete the getting started portion. (I believe) If you are having problems doing that, please consider disabling your ad block or script blocking for the forum site.

That is my best guess, but I admit, that I am not a discourse expert.

1 Like

Nope, I tried disabling U-block origin and Privacy badger, still the same

It looks like the permissions are broken.

To be clear, the thing I was trying to do was to follow the onboarding instructions…!

Ironically, I have been able to post including images, so something’s def wrong.

It is difficult to say what the issue might be. What browser are you using? Do you see the 3 dots next to posts?

I’m using Firefox on android.

As you can see from the screenshot above, no three dots.

Interesting. I can tell you that there are thousands of users on this forum, and none of them have reported the issues that you have. My humble suggestion based on experience is that the issue lies in the device or software you are using to access the forum.

If you are able to access the forum with another browser, for example, this would help us to see if a real issue exists or if the issue is external to the forum software.

Thanks! :+1:

1 Like

OK, on Android I have tried: Firefox and Chrome: both show the same.

On Ubunutu, I have tried Firefox and Edge and Chrome. All the same.

So that’s 5 browsers across 2 OSes.

You just don’t have the status yet from looking at your profile, you need to get to ‘trust’ level :blush:

1 Like

Haha, so I have trust enough to submit new posts and images but not enough trust to … do the on boarding exercises specifically aimed at new users…errm…!

I suppose. I think I never noticed. It must be a 24 hour thing. It is a means to stop spam, and believe me, it can be a problem.

At any rate, Discourse is used by thousands of companies and organizations. It is developed by Discourse. While settings can be tweaked when setting it up, the default settings are based on a lot of feedback and use cases.

All I am saying is that while Framework might have went with these settings they are by far not the only company to do so.

Anyway, please ping us again, if your trust level does not increase, and once again, welcome to the Framework community.


Yeah, I tried to go back and view where I did the onboarding thing but tbh, I skipped it when I first joined, I didn’t bother with it until I realized I needed to do it in order to gain trust levels. I seem to have lost the original onboarding messages

I hope you get the hang of it, I assume the bookmark is located somewhere on the page as the rest of us have managed to do it…somehow…even if I can’t myself remember :laughing:

Not sure if it is disabled for new users, but I also went back to check and found that while I also didn’t complete the onboarding, the bookmark button was a little further down as you bookmark the thread, not just the post

You can see down here there is a bookmark button below the “thread info” box.

edit: added a helpful circle to the image
also, I tried bookmarking the post, and it did not give me a :gift: yet, so it seems this is the only message in the onboarding anyway. To up your trust level, you just need to post, comment, and like on the forum!


Hello again, now on my mobile phone also running Firefox on Android! I have found that here, to save on screen real estate, the bookmark option is even more hidden! Now you need to go to the bottom, and use this fancy drop down menu to find the “bookmark” option!

I honestly didn’t even think about this at first as I mostly use the web version of the forum, but when I remembered that you were using the mobile browser to do all this, I thought I’d check to see if it was different there!


Ah, yes, thanks @Azure bookmark was in there.

There appear to be other bugs in discobot but as it says itself, it is poorly programmed, and it’s not interesting to framework. I may dig out their issue queue and post on there.

The 'getting started: introduce yourself ’ post is still un-replyable to but meh.

Thanks for your time everyone.


You know I forgot to check that out yesterday, but I also can’t reply to it. It’s possible that it’s been around so long that discourse or the mods disabled further replies. That would be something to check with @FrameworkBee on if it was intentionally closed.

We’re looking into this now given that the forum has had some recent updates itself!


@FrameworkBee Glad to see you’re already on the case! Keep up the great work!