[SOLVED] Macropad some keys not working

i was working on QMK to set up the keyboard first for per key RGB and layers and then the macropad to do the same. i did not have issue with the RGB once figured it out for the keyboard. but the actual key registering for certain keys was not happening. i found that starting at top row keys 1, 2 and 4; and then row 3 the fourth key; row 5 fourth key; and finally 6th row key 2 all do not work and i have tried to see if expanding the matrix would expose key location that are linked to those keys. looking at numpad files it looks like most of the keys were the ones unused due to the double size keys like plus sign, enter key, and zero key. i have deleted any versions of firmware that had been changed and tried using the default files but the keys still didnt work. Is anyone else having this issue with macropad? has anyone fixed this for themselves and can pass the info along?

just for clarification i used both VIA portal and QMK configurator to test the keys with each qmk change and before that i tried to change the keycodes for those keys with VIA but those keys never recorded a key press with them. the RGB works for every key.
also confirmed i was not using numpad files so those keys should be working

Does anyone have a macropad that could verify if its just me or others are seeing this too?

I also have the Macropad and everything works as it should.

only to get via working on fedora is a pain !

1 Like

Hey Cory, if you are experiencing an issue due to hardware (i.e. defective macropad) please contact the support team.

Do you mean that you compiled the default files, or that you flashed the official release .uf2? This file framework_macropad_default_v0.2.9.uf2

You would need to flash Framework’s file, then do an EEPROM reset, in order to rule out any firmware issues.

Resetting the keyboard to factory default / clearing persistent memory / EEPROM.

This will erase any changes you’ve made in Via (keyboard.frame.work). If this is your first time using the site, you’ll have to authorize connection to your keyboard first.

  1. Go to keyboard.frame.work.
  2. Select a key to remap by clicking on it, the key will start to slowly flash
  3. In the key selection area below, click on the Special section
  4. Select the Any keycode, found at the bottom
  5. Enter QK_CLEAR_EEPROM and press Confirm
  6. On the keyboard, press the key you just remapped
  7. Reload keyboard.frame.work for it to show the change

i compiled from a fresh copy of the github firmware fork and flashed that uf2 and then used the official uf2 for macropad and neither worked. i moved it to both sides with no change. i key tested with the VIA website and the QMK configurator with same results. i updated bios to 3.03. the numpad works just fine but not the macropad.

i have been working with Framework and it was decided that the macropad is bad so going to get a replacement. should i delete this post? if i should then how do you actually do that?

Deleting threads does not seem to be normally done here. Except for spam.

If you wish, you can mark the issue as solved by editing the thread title to add [SOLVED] in front. You should see a pencil icon next to your thread title which you can click to edit it.

thank you for your help. also i am still cleaning up the files for the keyboard and will have it linked soon in the other post.

for some reason it wont let me select the pencil when the popup for the first post is showing the html and raw option. can a mod help?

I’m able to do it. Just added [SOLVED] for you. Let me know if it’s not how you want it.

1 Like

that works for me. i was thinking they stopped allowing me to edit the original post so thanks for helping me out.