[SOLVED] Maybe a bug in the linux AMDGPU driver — request to help diagnostics

Hello, I have a very surprising bug when using webgl under linux (amd13).

This snipset reproduces the problem. On most computers, it displays two dots. https://jsfiddle.net/nx9djmtu/1/ (one black, one red).

On my computer, it only displays the red one. The problem is the same on Firefox and Chromium.
If I switch to software rendering (LIBGL_ALWAYS_SOFTWARE=1 firefox), then the problem disappears. That’s why I think it’s a problem with the AMDGPU driver.

I run archlinux, wayland (sway) and kernel linux 6.9.3.arch1-1 and 6.6.32-1-lts.
I will try to git bissect the kernel, but it will need some time.

I’m trying to get more hints when it happens.

If you have and AMD, I’d be glad to know if you see one ore two dots. Please tell me what kernel version you use if you are using X11 or wayland.

What makes you think kernel driver? IMO it’s more likely a mesa issue than a kernel driver issue.

Oh, thank you, a lot!

That was it indeed (I have no real idea of the layers involved).

On archlinux, 24.0.8-1 is ok, while 24.1.0-1 is buggy.

I know now where to file a bug :slight_smile: