[SOLVED] Please help! My Laptop won't connect to my Home Internet


I have a Framework 11th gen that I love. I am running Ubuntu 22.04 on it (no dual boot).
I am unable to connect to my Home internet anymore. It was working fine before today.
I have a USB-C to Ethernet dongle that won’t connect as well as my Wifi won’t connect.
My Laptop can still connect to my phone hotspot (?!).

I get errors like this in my journalctl:

eth0: Failed to read reg index 0x0004: -71
eth1: Failed to read reg index 0x000a: -71

I prefer to use the Ethernet dongle but that stopped working yesterday and I switched over to WiFi and now that has stopped working today. My phone and my desktop can still connect to home WiFi and Ethernet respectively.

I also followed some of the WiFi suggestions here:

I separated the 2.4/5GHz SSIDs and fixed the band and channels.

sudo dmesg gets errors like this relating to iwlwifi:

iwlwifi 0000:aa:00.0: Failed to synchronize multicast groups update
iwlwifi 0000:aa:00.0: mcast filter cmd error. ret=-5
iwlwifi 0000:aa:00.0: Failed to synchronize multicast groups update
iwlwifi 0000:aa:00.0: Scan failed! ret -5

lspci | grep Network and lsmod | grep iwlwifi return:

aa:00.0 Network controller: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)
iwlwifi               450560  1 iwlmvm
cfg80211              974848  3 iwlmvm,iwlwifi,mac80211

I located an old USB-A WiFi dongle and I’m able to connect to my home network using that. I am not surprised if my USB-C ethernet dongle is busted as it was always a bit temper-mental, but I am surprised that the Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz adapter that came with the FrameWork isn’t working anymore :pensive:

Did you change any network settings or modified the kernel recently?

What are the results of the 2 commands below on your environment?

$ rfkill list all
$ nmcli radio all

This page on my blog might be helpful for you for details.

1 Like

Gotta ask was there an automatic update on either Ubuntu or your router? This is the usual way this kind of stuff happens outside of a hardware failure/defect.

1 Like

@Jieren_Zheng I did not change kernal or network settings before getting this issue. Since getting it I have been changing lots of stuff to try and fix it. I even updated my BIOS:


rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy1: Wireless LAN
        Soft blocked: no
        Hard blocked: no
nmcli radio all
enabled  enabled  enabled  enabled 

@nadb I do sudo apt update on my Ubuntu most days I log in out of habit. My router there has been no update. I will say that I normally use my Ethernet dongle at home and that has always been tempermental. It stopped working and I switched to WiFi. I had basically had not been using my WiFi that much recently. The weird thing is that the Laptop WiFi card can still connect to my mobile hotspot without any issues but can’t connect to my home router.

Thanks for all the replies by the way. Since finding the old USB-A WiFi adapter my sense of urgency has faded but would love to try and figure out why the internal WiFi card won’t connect to my home network.

What are the security settings WPA2 or WPA3 on the router? Also have you tried rebooting the router. Over the years I moved away from combination router/wifi setups specifically because they would occassionally glitch out or freeze up.

@nadb Thanks for the quick reply.

The security settings are standard WPA2-PSK/AES. I followed the guide I linked and fixed the channel and set channel width to 20MHz. I rebooted the Router a few times too. My phone connects to router over WiFi without any issues.

I’m not sure what you mean by combination router/wifi. I have a single router which connects directly to the phone line and transmits WiFi.

What I mean is a consumer grade router/wifi no separate access point, or firewall appliance, i.e. an all in one solution.

As to the Ethernet log, looks similar to an issue I was having with two Realtek 8152/8153 NICs in my project. Is the driver in use for your NIC r8152 by chance? If so, try this for each NIC interface (i.e. eth0 and eth1 ):

sudo ethtool -K <nameofinterfacehere> tx off rx off scatter-gather off

That improved the stability of my Realtek NICs significantly. Need to add it to udev or custom systemd service that fires after network-online.target or the changes won’t survive a reboot.

After two weeks of using a USB WiFi dongle, now even my dongle won’t connect (though as always I can still connect to my phone hotspot). I’ve ordered this:

Which hopefully will put an end to my home internet problems. Though I’m disappointed that I will be without reliable WiFi on my Laptop. I may go out and a new USB-WiFi adapter (I don’t know how old the one I was using is).

Update: Ethernet Expansion card doesn’t work either.

Where is your router located in relation to your devices? Make sure there are no high energy items near it i.e. power supplies. Is this the only device with wifi connection issues? Your ethernet card could be a number of different issues, so introducing it to this thread is just going to lead to more confusion. I would recommedn setting up a separate thread for it.

The router is located on a table top. No obvious high energy items near it.

This is the only device that is having issues. I have five other devices that connect with no issue to the router (4 WiFi, 1 ethernet). I have created an official request with FrameWork for the ethernet card.

Couple of thoughts 1) if you have tlp installed USB autotsuspend, wifi power saving could be switching things off, but since they are then blocked, 2) check how your laptop is using dhcp, or 3) you have a hardware issue.

  1. I have messed around autosuspend and power saving settings, following some guides I found there it did not resolve the issue.
  2. I don’t know how to do that
  3. I have been in communication now with FrameWork to try and see if that is the issue. They don’t think it is hardware. But have gone through a few steps with me and are now suggesting I try a different linux distro.

I had an old desktop PC and I just installed a fresh Ubuntu 22.04 on it, so that I could use the internet while having these issues with my laptop. Now though after a few days of using the desktop, I’m getting the same types of issues with internet connectivity (over ethernet). I’m thinking now it has to be some problem with Ubuntu or maybe a problem with my router or some combination of the two.

To me and briefly reading through the thread here, your router / network is the issue. I apologize if you’ve already answered this, but are any other devices able to connect to your home network and have internet access?

Because if you are able to connect to the hotspot created by your phone it points to your framework hardware not being the issue.

1 Like

@2disbetter I have an iPhone and Android device that connect to the WiFi no problem. It feels like it might be some issue around my Router together with Linux. Though I am finding it difficult to debug.

if the Framework is able to connect with wifi over hotspot, but not the local wifi at home, then that would be a router thing.

As for the Ethernet expansion card, that is something I’ve been having mixed success with as of late. I am actively working to figure out why it’s not cooperating.

1 Like

A new router got my wifi working again. The Ethernet expansion card is still not working. My old USB-C Ethernet Dongle works though. I guess I’m having similar issues to you.

1 Like

I have an Ethernet expansion on the way, I hope it works for me!

With both Fedora 37 and Ubuntu 22.10, I have not yet had any Wi-Fi issues with my Framework laptop.

Thanks for sharing those commands and the link. Your blog has some really interesting articles.

If the articles mean the ones related to Linux, yeah, those articles include my logs when I tried to do something on Fedora on Framework Laptop. I am glad that you like those!

1 Like