Spacebar release delay


I have just recieved my Framework laptop, DIY edition, and appear to be having some issues with spacebar. When holding the spacebar down long enough for it to input more than a single whitespace character, upon releasing, it continues to input whitespace for about as long as it was originally held down for, in effect, doubling the input.

I have Arch Linux 5.17.4 installed, with KDE plasma, though this issue was present before I installed a desktop environment, and while I was running it from the usb boot drive.

When running showkey -s, the release event (0xb9) doesn’t fire upon releasing the key, it continues firing input events (0x39), untill the release event finally fires. I’ve also reseated the ribbon cable that connects the input cover to the motherboard, to no avail.

I can’t tell if this is a hardware issue or software, and was wondering if anyone else had run across this issue before and might be able to help.

Thanks in advance.

Well I have just tried but with my Win 11 all is fine

Hi @Nathan_Rath. I would recommend submitting a ticket to our support team here: Framework | Support so they can ensure your laptop is performing as intended!

Thank you and stay safe!

1 Like

Can you try with an alternate OS?

Not easily, but I did try another keyboard to achieve the same effect, and it worked fine. So I guess it’s hardware.

I will do, thank you.

1 Like

Huh, I just tried this (Debian sid) and didn’t have an issue. Does using X11 or Wayland make a difference?

There is this thread about function keys sticking (I do experience this but it doesn’t happen enough that I’m bothered enough to fix it as outlined there), which might be helpful?

1 Like

It doesn’t look like it’s anything software related, as using a different keyboard fixes the problem. Looks like it may just be a dodgey keyboard that I’ve received. I’m reaching out to support to hopefully remedy the problem.

Ah, got it. Good luck!

Chiming in here as I got a notification – I’m the creator of that thread.

@Nathan_Rath, using another keyboard would solve the issue because the issue only applies to the internal Framework keyboard (because that’s attached to the EC which has faulty code to be fixed in BIOS 3.08 AFAIK).

So if you’re on Linux with systemd, the fix could very well solve your issue. GLHF!

Edit: though I don’t think I ever saw the spacebar stick, and that specific key may need to be added in the config. Thinking through this further, the spacebar key doesn’t have a FN modifier that translates into a keycode that doesn’t release (the keyboard brightness changing doesn’t get picked up as a keypress AFAIK). I could be wrong, and it’s been a while.


Hey, thanks for that info, that’s good to know.
I did check that thread before I created this one, and tried the same fix with the scancode for the space bar, just in-case it was a similar issue. Sadly, it didn’t seem to solve the problem, even after a reboot.

I might give it another go, just to be sure.

1 Like