Spurious keystrokes (and I don't think it's the keyboard)

I logged a support ticket for this, but figured I throw it out to the community.

The laptop is a FW13 that I upgraded from 11th gen to AMD last month–it’s worked perfectly since the upgrade.

Saturday evening, my spacebar started acting oddly. I’d press it and get no response, or suddenly I’d get continuous spaces in what I was typing. When this happened, my trackpad would stop responding as well. All other keys seem fine. Here’s what I tried, none of which solved the problem.

  1. Rebooting the laptop (of course)

  2. Cleaning the keyboard with an air-sprayer.

  3. Gently removing the spacebar keycap to see if something was jammed under it.

  4. Removing the input cover, then unplugging and replugging the keyboard connector.

  5. Leaving the keyboard connector unplugged, replacing the input cover, and using an external USB keyboard.

  6. Booting to a linux liveCD.

None of these tests fixed the problem, but #5 indicates that the problem isn’t with the keyboard itself. Possibly the EC? I noticed my fingerprint reader stopped working at about the same time.

The one thing I haven’t tried that I’d like to is to replicate the input problem on the BIOS screen. I’m 99.9% this is hardware rather than OS related, and demonstrating the same failure while on the BIOS screen would confirm it.

Thoughts or ideas?

Stop eating chocolate while working on the internals of the machine?

More seriously, sorry to hear that you are running into issues. Hopefully you are able to get it sorted. The only things that I can think to try in addition to what you already have done are resetting the bios to the defaults and resetting the mainboard.

Good luck, I will be following to see where this goes. Happy holidays and early happy new year!

Yeah, well, eating chocolate’s a key part of my job :wink: Anyway, the laptop lives at home. The CoolerMaster 11th gen’s now my shop kitchen machine.

Resetting the bios and the mainboard. Both excellent ideas! I’ll try them when I get home.

Have an excellent holiday and New Year!

I was just giving you a hard time. How is the 11th gen in the CoolerMaster case? Did you do the RTC fix or do you still have an actual RTC battery in it? I still have the 11th gen in my machines. I splurged on the 16" and am holding tight with the setups in the 13" machines for now.

I don’t take offense anywhere near that easily. And just because I don’t work with chocolate around my laptop doesn’t mean I don’t nosh over the keyboard. (It was my first line of investigation).

The CoolerMaster case is great! I still have my RTC battery, and have added a large monitor and wireless trackpoint keyboard. I can conveniently push everything out of the way when we need the extra prep-table, though I won’t pretend that the monitor doesn’t get spattered with random stuff.

2 Likes

@lbkNhubert Resetting the bios appears to have done the job. Great suggestion.

2 Likes