[SOLVED] Spurious keystrokes (and I don't think it's the keyboard)

I logged a support ticket for this, but figured I throw it out to the community.

The laptop is a FW13 that I upgraded from 11th gen to AMD last month–it’s worked perfectly since the upgrade.

Saturday evening, my spacebar started acting oddly. I’d press it and get no response, or suddenly I’d get continuous spaces in what I was typing. When this happened, my trackpad would stop responding as well. All other keys seem fine. Here’s what I tried, none of which solved the problem.

  1. Rebooting the laptop (of course)

  2. Cleaning the keyboard with an air-sprayer.

  3. Gently removing the spacebar keycap to see if something was jammed under it.

  4. Removing the input cover, then unplugging and replugging the keyboard connector.

  5. Leaving the keyboard connector unplugged, replacing the input cover, and using an external USB keyboard.

  6. Booting to a linux liveCD.

None of these tests fixed the problem, but #5 indicates that the problem isn’t with the keyboard itself. Possibly the EC? I noticed my fingerprint reader stopped working at about the same time.

The one thing I haven’t tried that I’d like to is to replicate the input problem on the BIOS screen. I’m 99.9% this is hardware rather than OS related, and demonstrating the same failure while on the BIOS screen would confirm it.

Thoughts or ideas?

Stop eating chocolate while working on the internals of the machine?

More seriously, sorry to hear that you are running into issues. Hopefully you are able to get it sorted. The only things that I can think to try in addition to what you already have done are resetting the bios to the defaults and resetting the mainboard.

Good luck, I will be following to see where this goes. Happy holidays and early happy new year!

Yeah, well, eating chocolate’s a key part of my job :wink: Anyway, the laptop lives at home. The CoolerMaster 11th gen’s now my shop kitchen machine.

Resetting the bios and the mainboard. Both excellent ideas! I’ll try them when I get home.

Have an excellent holiday and New Year!

I was just giving you a hard time. How is the 11th gen in the CoolerMaster case? Did you do the RTC fix or do you still have an actual RTC battery in it? I still have the 11th gen in my machines. I splurged on the 16" and am holding tight with the setups in the 13" machines for now.

I don’t take offense anywhere near that easily. And just because I don’t work with chocolate around my laptop doesn’t mean I don’t nosh over the keyboard. (It was my first line of investigation).

The CoolerMaster case is great! I still have my RTC battery, and have added a large monitor and wireless trackpoint keyboard. I can conveniently push everything out of the way when we need the extra prep-table, though I won’t pretend that the monitor doesn’t get spattered with random stuff.

3 Likes

@lbkNhubert Resetting the bios appears to have done the job. Great suggestion.

3 Likes

@lbkNhubert Half a year later, this started happening on the same laptop, but this time with the AMD mainboard. Just reset the BIOS again (had to look at how to do that on AMD). Let’s see if it workd.

RESET THE BIOS ON AMD:

  1. Turn off laptop and open
  2. Carefully unplug the battery
  3. Plug in A/C, then watch the side lights flash red and blue

Should be it. I’ve typed this much without it flaking out, which might be a win.

2 Likes

Yeah, no. Still happening. Testing on Ubuntu 24.04.

Maybe try resetting the mainboard? On the newer machines it seems to involve pressing one of the internal buttons 10 times with a two second pause between each press. No eye of newt or toe of frog, though, as far as I can tell. I’ll update this post with the actual procedure if I find it.

Edit to add - I think that this is it: Reset forgotten BIOS password - #20 by pkunk - expand the collapsed section.

@Destroya - it might be useful to add guides for how to reset each mainboard. The only official one that I can find is for the 11th gen.

1 Like

Thanks for the feedback, this is on my radar, we definitely need that.

1 Like

Press the chassis open switch in the center of the Mainboard 10 times, you must press it slowly, so press for 2 seconds. Release, wait for the red blink on the Mainboard LEDs. repeat.

Stared at my mainboard for 2 solid minutes. What’s the chassis open switch look like? (Or where can I find a guide that tells me)

I don’t know if it’s pointed out in any guide.
But this is it (the black part is a lever which you push down) aka “chassis intrusion switch”.

1 Like

I’ve opened a ticket on this. I reset the BIOS using the above technique, but the problem is still occurring and getting more frequent.

FW support has requested that I replicate the problem using a Live CD with Fedora or Ubuntu, and that I also re-install the 3.05 BIOS. Given my original post in this thread, the Live CD isn’t likely to help, though I’ll give it a shot. Re-installing the BIOS is a bit more work, so it will have to wait until I have a little time to mess with it.

@Richard_Tango-Lowy
There is a similar thread for the FW16

can you post the output of:
lsusb
lsusb -tv

also
Something that might help a bit.
Disable key autorepeat:
xset r off
Enable key autorepeat
xset r on

By switching it off, it should stop the repeat aspect, but won’t help with the missed keys

The xset fix helped–thank you! It doesn’t address the cause, but it makes the laptop usable. Thank you!

1 Like

SOLVED.

First, I’d like to mention that the Framework support team has been incredibly responsive and helpful in assisting me with this issue.

After some solid debugging ideas over the past week or two, they escalated it today and the rep was fantastic.

We pinned the problem to an iGPU memory issue with the AMD mainboard. Increasing memory to the GPU by setting UMA_game_optimized in the BIOS resolved the problem. I’ll keep beating on my laptop for a few days to see if the problem returns, but it’s looking good since I made the change.

That also explains why the problem started just after I installed the new mainboard, went away for months (I’d turned on expanded memory), then came back recently (I turned off expanded memory).

1 Like

Added solved to the title. Glad you got things figured out!

@Morpheus636 Ah well. Not solved. Worked fine for three days after the change, then the problem returned just as bad. We’ve tried pretty much everything. At this point, I think it’s a defective AMD mainboard.