Reset forgotten BIOS password

How can I reset my forgotten BIOS password?

I think you may have to remove the BIOS battery, looking it up ???

Taken from this thread.

1 Like

feel like a noob here with a brand new framework 13 laptop (AMD) i tried to set the bios admin password and it had some complexity requirements, and now I dont remember the framework bios password any more as it differs from my other bios passwords i normally set :frowning:
how to remove the bios password on amd framework 13 laptop? thanks.

1 Like

i have still not disassembled my framework 13 laptop amd edition (DIY) yet again, but now I have found this thread about lacking of CMOS battery in framework laptops

and I am irritated. how would I clear the cmos/bios password then? simply detach the actual system battery of the laptop itself, the main battery?
thanks for any hints.

then again I find this guidue, which speaks about RTC and cmos battery etc

but I wonder if this applies for the AMD framework 13 laptop as well? can anyone really point out to the full guide of the amd mainboard for framework 13 laptop with all its details and aspecs and/or add the newer framework inventory and parts and components to all the guides where the informations fits and is applicable to? would be great and useful to everybody. thanks.

sigh then digging even deeper I find this article:

this article also lists the type of cell battery to make use of:

Ryzen™** 7040 Series:** Rechargeable 3V Lithium manganese dioxide battery with a Molex 51021-86022 compatible 2-pin connector.

that the AMD framework 13 ships without a rtc cmos battery in place for environmental reasons etc so yet another new info.

guess I only need to disconnect the actual main laptop battery then to flush the cmos storage.

another update on this matter but NO success :frowning:

reporting back, I have disassembled (opened) the framework 13 laptop AMD edition, and disconnected the main battery with that broad white connector. for a minute or so. putting back battery connector and reassembling the framework 13 laptop AMD edition, starts the RAM training and the bios/uefi main selection screen shows a default date and time reset to 2023/01/01 and 00:00 seconds counting up but the bios password itself is still present. i can not enter the bios/uefi this way.

what now? please anyone? i had thought this was the procedure to reset this laptop completely? thanks.

p.s. even more updates ;( if one reads the actual article about full mainboard reset, there is the hint that one need to plug in the AC power with the coin cell and the main laptop battery being disconnected and then the LEDs on left and right side of the laptops indicating the actual mainboard reset with a red blinking light. I obviously missed this very step. now did all these things again, and thie framework 13 laptop AMD edition blinks blue-red (not only red as given in the article). will wait some more now and then see if my bios password becomes deleted. thanks and sorry for the fuss.

pps. too bad still no luck, yet another powerup and the pre-bios screen when trying to enter the setup, asks still for the “current password”.

I am kind of frustrated and out of ideas now :frowning: any helpers? thanks.

1 Like

Have you opened a ticket with Support?

I have sent a support request yesterday after my trials, yes. will wait and see what to do next. thanks.

1 Like

Good luck, I hope that they are able to resolve it for you.

1 Like

will reply here for everybody to see how an actual bios password reset is supposed to work on the framework 13 laptop AMD edition.

1 Like

Maybe this will work

Method 1

or maybe

Method 3

Meanwhile I have heard back from the frame work support team and finally managed to re-set (remove) the bios password successfully.

The main problem in my situation was, as far as I understand in the mean time, that the AC external power was not actually charging and feeding power to the AMD laptop, this caused the faulty initial situation where I could not apply the steps needed to remove the password from the hardware.

Just today (even after I wrote my lengthy reply and thanks to the support team via email) I found in the AMD bios procedure knowledge base entry (3.03 bios update from inside linux via lvfs etc…) at:

and I quote here:

LVFS may not update if the battery is 100% charged. LVFS uses the battery status to determine if it is safe to apply updates. However if our battery is at 100% and the charger is off, we set the battery charging status to false. In this case you can discharge your battery a few percent, then plug in AC again and run fwupdmgr update.

my emphasis here. So I even had set the battery limit of charging to 80% in my situation and I was not managing and succeeding to bring this laptop into actual and factual charging state, thus the steps needed to re-set (remove) the battery password would not initiate and take place to begin with.

Additionally I found out today, that I actually have left the original frame work AC charger (european model) connected all the time to my AC socket/power grid. And this would somehow when the laptop not being connected to the USB-C side of this frame work AC power supply, would somehow put the AC power supply into sleep mode, that even when my laptop was way below the 80% of battery charge, it would still not light up the charging LED on the laptop side. Only when I fully unplugged the AC power supply (charger) from the AC power outlet / socket, and then re-plug it into AC socket power grid, and if then being attached to the USB-C extension module on the frame work laptop, the LED light would light up and it would charge to the percentage or max that one would set in the bios.

And this charging state IS necessary to take certain steps with this frame work laptop, such as that bios upgrading procedure up in the frame work knowledge base documentation above or the bios password removal procedure that was given to my by the frame work support folks.

Frame work support: please document these bios password removal steps publicly and openly on the website knowledge base articles etc

Thanks again for all the help with this situation.

1 Like

I find myself in the same situation as you, where I have to reset my BIOS password. Could you list the steps again? I read this thread a couple times but I am not sure if you actually posted the steps or if I have to contact support because this procedure is not to be publicly known.


1 Like


by now I think this issue has maybe been fixed with the current 13 laptop AMD edition bios update (bios version 3.03 AMD edition) which I only had applied after I sorted out this situation. maybe others could repro themselves, double check or add their experiences.

1 Like

Hi. Framework support gave me these instructions for resetting the BIOS on the 13 AMD:

Please perform a full mainboard reset. This will clear up any states that are saved. Kindly follow the instructions below and see how it goes.

  1. Plug in the system to AC.
  2. Remove the Input Cover.
  3. Press the chassis open switch in the center of the Mainboard 10 times, you must press it slowly, so press for 2 seconds. Release, wait for the red blink on the Mainboard LEDs. repeat.
  4. Press the power button to boot the system
  5. BIOS settings will be reset to defaults.

Are there any instructions about resetting the AMD mainboard?

Hi @Charlie_6,

One of the earlier posts here talked about the steps to reset the Mainboard on an AMD model. This is likely the FW13 AMD model.

Click below for the steps again…(with my added notes in italics)


Please perform a full mainboard reset. This will clear up any states that are saved, forgotten BIOS passwords, hard reset the mainboard, etc.. Kindly follow the instructions below and see how it goes.

  1. Unplug your AC adapter from the wall, count to ten and plug it back in again.
  2. Plug in the system to AC. (i.e. plug the USBC cable into the back left or back right port of the FW computer as you are looking at the machine)
  3. Remove the Input Cover.
  4. Press the chassis open switch in the center of the Mainboard 10 times, you must press it slowly, so press for 2 seconds. Release, wait for the red blink on the Mainboard LEDs. repeat.
    (I have not done this personally so let me detail what is being said:
    a. Press chassis intrusion switch, hold for 2 seconds, then release
    b. WAIT for the Mainboard LEDs to blink RED
    c. Repeat this NINE (9) more times for a total of ten (10)
    d. After the tenth (10) switch press and release WAIT for the Mainboard LEDs to blink RED before moving to step 4 [they will not blink different you just have to wait like you did in 3.b above]
  5. Press the power button to boot the system.
  6. BIOS settings will be reset to defaults.
  7. Change settings as needed.
  8. Power down the system and reinstall the Input Cover.
  9. Vow to never use a BIOS password again if you forgot it and had to go through this (This step is optional) :person_facepalming:
1 Like

Why can’t I find these BIOS reset instructions in the official guides? Framework Laptop 16 - Framework Guides