SteamVR/Valve Index not working Error 109

Hey everyone. Long time Linux user and been running Manjaro as my primary OS for work for years. I just got a new laptop and decided to make it closer to Arch by installing EndeavourOS. So far it looks great and feels great but I have not been able to get SteamVR running. Every time I run it, a few seconds into starting up I am provided error 109 and that the headset is not communicating with the laptop. When I look at KDE display manager, it is not detecting the headset no matter what I do. I tried to disable direct output in SteamVR developers menu and that isn’t working. Others on reddit and other forums say that if doing that step and it doesn’t work then there is a hardware issue on the headset or the cable is bad. However, the headset works perfectly on my old laptop running windows. I think it is a driver issue and I am not sure how to proceed.

When installing Steam, a prompt asked which driver to use and I used the default recommended for amdvlk - so not sure if I made a mistake here. Also, I have enabled proton support for my entire library but I am not seeing anything around that for error 109.

I have the framework 16 with the dedicated 7700s card. When looking down at it, I am using the left frontmost expansion slot for USB, the left middle slot for display port, and a Valve Index. According to the specs the middle slot supports DP out and the front slot supports USB speeds of 3.2 which should be fine for this. I have also tried using a DP to TB3 cable (what I have to use on my Windows laptop as it doesn’t have a DP out) in the furthest back left side slot which should support everything.

Steam VR shows communications with the headset just not as a display. I have also tried both X11 and Wayland, and get the same error on both.

Any help would be great and hopefully someone knows a quick fix for this.

If the laptop gets so hot with normal games. Will the RV hold up?

Have you tried oculus quest?

Im not sure if this will help, but have you tried plugging the headset display into the usb c port on the back of the gpu using an adapter?

The 7700s is only hooked up to the usb-c port on the back, so if the headset isn’t being recognized as a display at all this could be the issue.

1 Like

I don’t know what the RV is.

I did not know that, I thought it was routed to the the top two ports with display. But I guess that makes sense. I’ll try that and see if it was just me not knowing and that would make me feel way better

Those ports and one of the middle ports can do DP alt mode but that’s through the GPU in the CPU (or APU I believe is what AMD calls it). It doesn’t run through the 7700S.

I think it’s a typo ^^

I’ll try running VR on my Linux desktop today, where I had similar issues. Will report back when I know more.

Thanks, I haven’t seen too many people complain about it so I think it is me not using the correct port which I can test tomorrow.

Vr ……

Are the temperatures with RV good?

There are users who say that it gets very hot when playing. I wonder what the dissipation will be like playing aaa vr games

This was the fix for it. It now starts but now I have to figure out how to use it. I have the issue some others have where menu’s load but you can’t see anything, but that is outside of FW’s stuff.

@Lupin - I will need to check when I can get it fully working. It started up now but still unplayable because I think I am missing some libraries.

Okay, after a lot of trouble I got it running on my desktop with an RX 6800XT.
My takeaways:

  • You have to power cycle the headset if it’s stuck in extended mode (instead of DRM)
  • Don’t use steam native, use the runtime instead
  • Don’t give the setup the permissions - if you did, reinstall steamvr and then deny them
  • Current or beta version of steamvr is fine, I’m using the beta rn
  • Currently still having issues with stuttering, every second frame is weirdly delayed
  • Change proton version if Beat Saber has issues (only rendered on my left eye, don’t remember which config)
1 Like

Has no one tried the oculus quest in framework 16?

It would be good to know if the dissipation is capable of withstanding the heat generated by playing in virtual reality.

Apparently it already gets very hot with normal games, although I prefer to read impressions from more users

So I tackled this a few weeks ago and had some success! Goal was to get Outer Wilds running in VR and I managed to do that, but then life hit and I haven’t been able to play for more than 30 minutes. I imagine you’ll want to do different things, so think of the following more as a clue than guide.
Setup: Steam Index, Tumbleweed, KDE (doesn’t work in Gnome), USB-C (on dGPU) → 8K DisplayPort adapter

Same error 109, and after a fair amount of research I finally landed on SteamVR is a steaming pile. In fact, I never got it to run.

  • The SteamVR room setup/calibration worked well enough, so start there (I knew I was onto something when the lights inside the headset turned on).
  • Build GabMus / Envision · GitLab which is mostly tracking down and installing dependencies.
  • Run envision (under build/localprefix/bin/)
  • Copy/create a profile, then build
  • Start and copy the launch options
  • Configure Outer Wilds in Steam (under Properties) paste launch options, set Proton 7.0-6 (didn’t retry others after it was working)
  • Start game :slight_smile:
1 Like