Strange usb drive mount/unmount (disk disappearance/reappearance) when plugging cable into neighboring usb-c card

Hi, I’m not sure if this is the right way to go about posting a little bug I found, if not, please someone point me in the right direction. TIA.

Please note, I put this under “help” because the other tag-categories seemed incorrect. I am not actually looking for help, although if someone knows a fix I can implement, I’m happy to learn it. :slight_smile: But at the moment, this appears to me to be some kind of hardware bug, and I’m just making a report.

I have found that when I have a usb-c adapter in the right back slot, and a usb 1TB drive in the right front slot, plugging a specific usb-c cable into the usb-c adapter causes my OS (Zorin Linux) to repeatedly mount and unmount the drive.

The specific usb-c cable is an audio-jack-to-usb-c adapter cable that came with my Pixel 3. I actually have two, because I thought I lost the first one and got another and then found the first again, and both cause this to happen. I tried with other usb-c cables (I have a couple for power cords) and these did not cause the mount/unmount behavior. I didn’t need to have earphones connected to the usb-c cable adapter, the mount/unmount behavior happened even if I just plugged in the cable without anything connected to it.

If I take the usb-c cable out of the usb-c socket, the behavior stops, with the drive mounted. It appears to always do an unmount-remount action together – it does not stop in the middle if I pull it out after an unmount.

Sorry, must revise my language based on something else I only just found out: the drive is not repeatedly mounted/unmounted, but actually disappears from the disks utility and reappears. (It’s also mounting and unmounting to/from the filesystem.)

I have had one instance where I plugged in the cable and the drive unmounted (vanished from disks) and did not come back. To get the drive back in disks, I had to physically remove the expansion card and put it back in.

The above expansion card configuration is the only one where the mount/unmount behavior happens. All of the following configurations failed to produce the behavior:

  • swapped usb-a for usb-c card
  • swapped positions of usb-c card and usb 1T drive
  • swapped sides of usb-c card and usb 1T drive (from right side to left side, usb-c in back, usb drive in front)

The only card config “change” that also producedoesd the behavior was when I swapped my 2nd usb-c expansion card for the first in the original offending position. Iow, the weird drive mount/unmount behavior happens in the offending position for either of my usb-c expansion cards.

Again, the “trouble” config is: on right side, usb-c expansion card in back slot, usb 1T drive in front slot.

Again, sorry if this is not the right way to report something like this. I’m also happy to do any further tests I can if there is any request.

1 Like

Same thing happens here on my Framework, but on all ports. I haven’t had the energy to deal with it at the moment and just went back to using my old laptop.

It could be this:

I tried the above and it didn’t work for me, but it might for you.

1 Like

Thank you for the tip Fahad, I will try that.

Addition to the above: I found that there is actually an effect on the usb-c plugged-in earphones themselves, which I didn’t notice before. This is again in the right rear slot, and is regardless to what is in the neighboring slot. When listening to music, the sound cuts back and forth between the earphones and the main speakers. This is in time with a mount/unmount cycle for a drive in the neighboring slot, if any, so it seems to be the same issue.

Ever have any luck resolving this? I’m now facing something similar.