[IN TICKET] USB A sticks [and at times User Post USB drive] not mounting/showing up?

Am I missing something? SOMETIMES my User Port Removable Storage [from frame.work] isn’t displayed in the file browser [nor in /run/media/username/DRIVE], or it disappears at times, while still plugged in.
Or, like right now, I’m wanting to burn an .ISO to a removable USB stick… so I pop it into my user port USB-A port, and nothing happens. Not shown in lsblk, not mounted in /run/media/username/ and not anywhere on the system…

I have to burn .ISOs… I think I’ve also experienced having to remove the frame.work removable storage HDD in order for my system to see new USB Sticks put into the USB-A user port, but I can’t remember exactly…

I’m on Arch Linux running GNOME, FYI. Anyone have any ideas??? Cause right now the best I can muster is to boot up my Thinkpad, which obviously isn’t optimal. :stuck_out_tongue:

. . . . . . . . .

1 Like

I’ve had this problem with some USB-A drives which I’ve worked around by plugging them in partially (maybe a little less than halfway) until they show up as a drive, and then I plug them in all the way after that.

It’s very odd. If I plug the drive in all the way without doing the halfway trick, then it will get power but not show up in the list of drives. See: Quirky USB Port

As for disappearing drives, that’s another problem: 1TB expansion card disconnects randomly

I keep thinking they might be related problems. I’ve been experimenting with leaving my USB-A drive in all of the time, and I see that it disconnects occasionally as well. I’m currently talking to Framework support in order to give them more data so we can figure this out.

Do you have tlp installed? Are these USB ports explicitly exempted from auto suspend?

tlp is not on this install, and I’m not sure if they are exempted. Probably the stock setting, as I didn’t know to exempt them. :stuck_out_tongue: Any tips/help is appreciated. (Thanks!!)

Framework Support determined that I needed a replacement mainboard which they promptly sent to me. After installing it, my USB drives connect normally!

Many thanks to Framework Support! :slight_smile:

Interesting that they decided to replace the mainboard. I had this exact same issue and managed to fix it by powering off and unplugging the machine for a while. I think I might have triggered it by plugging my USB-C monitor into the wall while the laptop was connected to it, causing a surge and some kind of fuse to trip on the board. I’m still not exactly sure how it fixed itself by resting.

Unfortunately, I have just passed the one year warranty period so needless to say I am relieved that everything seems okay now.

They had me send pictures of the inside, focusing on the USB connections. They seemed to be looking for some “black insulation paper” underneath the gray emi shields. My board didn’t seem to come with this black insulation paper. It’s a batch 3 that I didn’t think had the EMI sticker problem, but maybe there was some extra layer of insulation that was later added?

I guess I could ask support for details on what they saw that made them think a new mainboard would help.

This is most similar to my issues - batch 3, etc.

Sadly, the new mainboard has not actually fixed my USB drive issues.

I currently have a theory that the problem has to do with USB 3.0 connections. For instance, when I connect my 1 TB expansion card using a USB-C 2.0 speed cable (+ male-to-female adapter), it works fine. Similarly when my 2 TB Seagate connects as USB 2.0 it has no disconnect problems. When it connects as USB 3.0, it’s pretty flaky if it shows up at all. It turns out that plugging in the drive halfway to begin with is what causes it to negotiate a USB 2.0 connection.

I have found that everything works great when plugged into this powered usb-c hub. Drives appear with no problems and operate at full USB 3.0 or 3.2 speed and stay solidly connected. My theory is that the issue is USB power related. This is based on USB 3 needing more power than USB 2.

Anyway, I’m still having a back and forth with support to see what to do next. I wonder if it’s just another mainboard problem.

1 Like

USB slots work fine on Linux, unless one of three things is happening:

  • Issue from user config.
  • Power issue from hardware.
  • Hub are involved, likely contributing to whatever is going on.

I’ll mark this as in ticket. Thanks for the update on this.

Does in ticket mean framework will contact me?
I still have this USB issue, and the microphone not working that I’ve had since day 1 - both of which I’d love to get fixed.

I do notice that if I move around the USB-A user port, sometimes USB drives will be seen ‘better’ - but at times I can’t even boot from a tails USB stick.

Yes, if you opened a ticket, you will be emailed for troubleshooting.

Please be sure to mention this in the ticket as well, this is critical information that will definitely help.