System clock changes 5h on dual boot Win10&Ubuntu

Hi!
I have rather strange and annoying issue - every time I boot into Windows (10) after I worked in Ubuntu (21.10) my clock goes up by 5 hours. I checked both system settings and both has correct time zone (as a first thought…). I have no idea what could do that… Any ideas?

This is because Ubuntu is setting your computer’s hardware clock to UTC, but Windows assumes that the hardware clock is local time.

You can set Ubuntu to use local time for the hardware clock by running the following:
timedatectl set-local-rtc 1

4 Likes

Thanks. That worked.

1 Like

There is also a windows registry setting that was findable with web search.

Probably best to only fix it in one place.