Too hot to handle and boot problems

  1. Installed a new WD Black SN850 2 TB.
  2. Tried to install from USB drive prepared by Rufus. This did not work. No media found.
  3. Read Windows 10 Installation on the Framework Laptop DIY Edition - Framework Guides It’s a good guide if you’re not using Rufus. My Framework community login did not work for adding a comment to this guide.
  4. Searched. Decided to start over after disabling secure boot. It was an educated guess, which turned out to be correct.
  5. Installed Windows 10.
  6. Installed all Windows 10 updates.
  7. Changed settings to display only on external monitor.
  8. Changed power setting to Do Nothing after closing the lid while plugged in.
  9. Shut lid.
  10. Came back 3 hours later and it wouldn’t come to life. Clicked keys, clicked mouse, nothing. Case was too hot to handle. Power switch light was blinking.
  11. Held power switch down until light went off.
  12. Started machine. Fan kicked in at high speed. Case cooled down and fan went quiet. I’m concerned I may have shortened the life of the unit.

There’s more. Sleep isn’t working properly.

  1. Remember, device is plugged in and set to not shut down when closing the lid. The lid is kept closed unless circumstances such as not booting force me to open the lid. It’s being used as a desktop replacement.
  2. When the Windows 10 power option to sleep is selected, unit appears to sleep. External monitor goes black.
  3. After me being asleep overnight, click mouse and hit keys to bring unit back to life. Nothing. Unit is slightly warm.
  4. Open lid.

  1. Hit Escape key.

  1. Held power button until unit shut off.
  2. Pressed power button. Unit booted quickly. Of course, the apps had to be restarted and brought back to where they were when sleep was initiated the night before.

I initiated a return request because the 30 days ends today or tomorrow.

1 Like

To eliminate potential issues with Windows 10 “Modern Standy” (which seems to be causing quite a few issues around here), can you try using a LiveCD of Fedora 35 or some other Linux distro (I personally use Debian sid)? It doesn’t matter if you don’t want to use it as your normal distro, but it might be helpful in separating hardware issues from software issues.

If you want to try out Debian testing (which should have decently up-to-date stuff, especially for testing this), you can use this ISO.

Thank you. I’ve downloaded it. What do I do with it? I don’t want problems booting like I had with the Rufus created bootable Windows 10 media.

Rufus should work fine for Linux. You can follow those instructions but use the ISO you downloaded.

1 Like

Left Framework unattended for about an hour. It should have put itself to sleep. It was unresponsive. Opened the lid and saw this.

Clicked Ok and got the same thing you see in the first picture posted. Power cycled and it booted quickly into Windows 10.


Does the same thing happen if you leave the lid open, in either Linux or Windows?

It feels like what’s happening is that the SSD is overheating and is shutting off for safety (hence the laptop can’t find any boot devices). The main way the Framework stays cool is by venting air up through the hinge (IIRC). If you’re leaving it closed and there’s signficant activity, that might bring the internal temperature up without any easy way to cool it back down.

@Framework Does that sound about right?

I left it alone for about an hour. It put itself to sleep without any intervention from me. Instead of finding it asleep, I found it at the empty Boot Manager. Power cycled it and logged in. Thanks to Word’s autosave, I didn’t lose anything.

What kind of surface are you leaving it on? Carpet or something like that where the ventilation might be messed up?

I’m having the same problem. Plugged in, unplugged, not good. I have the WD850 2tb, FYI.


Mine is on top of a metal case desktop that is turned off.

I had it on a table, and a desk. No carpets or blankets or stuff. At least one of those times, the fan was running, and the case was hot. Maybe it’s the hard drive?

My guess is you may be seeing something some other of us have: Laptop Overheating and Losing Connection to M.2 Drive

The WD Black SN850 2 TB specifically can get too hot for the laptop and cause it to d/c. At least from what we’ve seen.

I will say that one of the first things I did was install the WD tool for the SSD and update the firmware. I seem to have less issues than others.

Should I return the WD 2 TB? I wouldn’t have bought it if I had read this.

That’s really up to you. Have you tried updating the SSD firmware with the WD utility?
I figured worse case I could throw it into a TB4 enclosure and use it externally so I kept mine.

I will try that. Maybe. Today is the last day of the 30 day return period. I requested a return, but have not received a response.

1 Like

We believe we have root caused this to an SN850 firmware issue on some version of the firmware. Updating the SSD firmware has resolved the issue in each case we have come across: My system is rebooting to a “Default Boot Device Missing or Boot Failed” message


Win 10
driver bundle installed
brand new, couple days old.
If I close the lid, whether plugged in or not, for more than say 20 minutes?
I open the lid to it rebooted, and a message. Pic as soon as I figure out how. :slight_smile:

Default Boot Device Missing or Boot Failed. Insert Recovery Media and Hit any key
Then Select 'Boot Manager to choose a new Boot



Sounds like this and this.


@Chiraag_Nataraj I agree, thanks, I’ll go contribute over there. Appreciate it.