Too hot to handle and boot problems

We believe we have root caused this to an SN850 firmware issue on some version of the firmware. Updating the SSD firmware has resolved the issue in each case we have come across: My system is rebooting to a “Default Boot Device Missing or Boot Failed” message

3 Likes

I installed a new WD Black SN850 2 TB. Installed Windows 10. Installed all updates. Changed settings to display only on external monitor. Changed power setting to Do Nothing after closing the lid while plugged in. Shut lid. Came back 3 hours later and it wouldn’t come to life. Clicked keys, clicked mouse, nothing. Case was too hot to handle. Power switch light was blinking. Held power switch down until light went off. Started machine. Fan kicked in at high speed. Case cooled down and fan went quiet. I’m concerned I may have shortened the life of the unit.

1 Like

I just got the laptop today. I have windows 10 installed. I closed the lid and plugged it in and tossed it on the bed. I came back an hour later and the fan was spinning extremely fast and since the vent was facing the bed covers, it couldn’t breathe.

How do i just make it sleep/hibernate and not try to cool itself down? Or am i missing something. Thanks!

1 Like

Is Windows set to suspend if the lid is closed?

1 Like

This is what I have.

1 Like

I’ve seen this issue with other brands. Maybe some application was preventing sleep?

Try updating the firmware?

2 Likes

:point_up: New firmware is suppossed to address this

2 Likes

Gotcha, I am showing 3.06 bios version. Not sure what version i can upgrade to.

1 Like

On Windows if an audio player is open deep sleep will not be entered, and for some reason the system will just heat up. On Windows if you are suspending and charging make sure you always close any audio players before you suspend.

2 Likes

I’ve mentioned this issue in Unable to wake from sleep as well.

3 Likes

3.06 is current I believe. It must be a windows thing, as I have not had any issues like this with Fedora.

2 Likes

We believe we have root caused this to an SN850 firmware issue on some version of the firmware. Updating the SSD firmware has resolved the issue in each case we have come across: My system is rebooting to a “Default Boot Device Missing or Boot Failed” message

1 Like

Understood.

I am using a Sabrent Rocket Q 2TB (SB-RKTQ-2TB).

Does that change anything?

1 Like

I updated the firmware and my machine still isn’t going to sleep when told. I don’t yet know what will happen overnight. It would be nice if it would boot okay after this upgrade, but I really want the machine to sleep when it is told to.

1 Like

For the system not going into hibernate, this is more than likely the irritating default behavior in Windows 10, where it does more work than makes sense to in Modern Standby. Especially bad is that on a fresh Windows 10 install, it will run the search indexer while in Modern Standby for the first few days to build an initial index.

You can force Windows 10 to use hibernate instead of sleep, but that is not necessarily ideal either:
image

2 Likes

I did that right before your post. Hibernate is working as desired, except for the slower wake up time than sleep. Hibernate puts the machine to sleep. I will see if the case is cool in the morning.

Do you have a solution to fix sleep? My $280 HP Costco special has zero problems with sleep. If other laptops can properly sleep, this one should be able to as well.

1 Like

To be clear: If hibernation in fact was used, then your computer is off, as if you shut it down. This is how hibernation works. It physically saves your working session state to your hard drive, and then shuts down. This mean your power drain is nothing while off.

Standby, on the other hand, powers down everything except the RAM, which keeps your current session alive in memory. (At least this is how S2 works, S0 is a variation that tries to do other low power things in standby, and is essentially something no one asked for, but I digress.) The benefits are instant resuming, but you do have power drain. If power is lost, due to a drained battery, you loose your session.

As standby is working on Linux, I think this needs to be chucked up to MS and their handling of modern standby. Framework is doing what they can to improve firmware, but these things are complex and take time.

I’ve found that making sure you are using network disconnected S0 (on Windows) is one way to help power drain in standby. Also ensuring audio players are closed.

I was living with hibernation as the shutdown and restart times were under 10 seconds each. My issue, on Windows 11, was that I would restart from either standby or hibernation and my session was sometimes gone, and it would appear as though I just started up from a cold boot.

My suggestions then would be to stay on Windows 10, and not upgrade to 11. Seems still too buggy on Framework hardware. (before the issue I mentioned above, it seemed to run beautifully though.)

With Windows 10 receiving feature updates and support until 2025 there really is no reason, as of right now, to upgrade to 11 just yet.

2 Likes

Coming alive from hibernate takes about 9 seconds. On my other laptop, waking up from sleep takes 10 seconds. I can live with this. The case feels cooler after the WD SN850 2 TB firmware upgrade.

1 Like

I found this page on how to disable Modern Standby on recent W10/W11 machines: Wake on Touch - Windows IoT | Microsoft Docs

It’s for Windows IoT, but people on various sites says it works on W10/11.

2 Likes

I am using the Sabrent Rocket Q 2TB drive. The firmware is up to date, and I am using the current driver bundle and BIOS.

Is this just a windows thing with modern standby, or is this a framework bios/driver thing? Asking so that I can either stop troubleshooting and wait or keep looking around.

1 Like