Touchpad issues and my very poor experience with quality control

I got my framework laptop about two weeks ago and as much as I love it I’ve had nothing but hardware issues with various parts of the machine. I don’t mistreat my electronics and in fact I’m a bit overly gentle with them.

The first problem I had was with the hinges being very weak, I contacted support about the issue and they asked me to send a video and said that It was designed for one handed opening. I told them it was probably just me, shortly after I changed my mind and just out of pocket bought some new hinges. It wasn’t me, the new hinges are much stiffer and I can actually use it on my lap without it tipping over. It’s no big deal as the hinges where only 24 dollars.

The next issue I had was the screen, this happened after owning the laptop for probably 5 days, I was typing normally on it and suddenly a black and red line appeared on my screen with a bright red dot in the middle. I tried several trouble shooting steps on my own such as re seating the display cable, updating my drivers and bios but no, the screen was a lemon. Support was very helpful and sent me a new screen that fixed the issue.

Now the touch pad, the problem with my original touch pad is that it doesn’t register hard right clicks consistantly at all, only about 30% of the time. So like the other two issues I reached out to support and they asked me to send a video, after that they approved a new input cover, I was really excited as I though this would be the last part I would have to replace and I could finally get on with using my laptop normally, but that wasn’t the case.

I received the new input cover and was very careful with removing the old one and installing the new one, I went back over the guide on framework’s website just because I was paranoid of breaking anything. It went together very easily and worked mostly except for one issue, the touch pad.

right out of the box left clicks were not registering at all. so I went through all of the trouble shooting steps again outlined here: My touchpad isn't working and nothing.
I have re-seated and checked cable connections, readjusted screws and updated software and drivers just in case. and no, its a hardware failure as always.

I no longer know what to do with my two input covers, and I’m extremely annoyed because I currently can’t click and drag with my new cover, and I can’t hard right click with my old one.

support has not emailed me in a week and its been five days since I’ve emailed them about this issue.

I understood that there would probably be issues with it being a new product by a new company but hardware quality control seems to be anything but under control, my laptop has not been without a hardware issue caused by poor quality control for all of the barely two weeks I have had it and I am very frustrated with my experience so far.

The hardware issues I have experienced are not new and have be documented in the community forum for months by several individuals.

I would really appreciate replacement hardware at least being tested before heading out the door to me so I don’t have to deal with this. I don’t mind fixing electronics, and I’m not new to it so its okay, but framework seriously needs to do something about the quality control of their products.

Three separate hardware issues in two weeks, roughly $300 in replacement parts payed for by me and framework and I still have a defective touch-pad.

If anyone has a fix for my touch-pad I would be very interested in hearing it.

OS: Linux mint 20.3
Model: DIY edition equivalent to base model configuration with 16 Gb of ram.

Thanks for reading.

Are your driver’s installed and have you tried on Fedora 35 for example?

Thank you for the reply! :slight_smile:

Yes my drivers and bios are up to date, I have tried it on windows and Linux mint, as well as enabling/disabling the ps2 emulation in the bios. I am 100% certain its not a software issue.


In a meantime, you can use mouse instead of touchpad.

Thanks for the suggestion!

That thread unfortunately is a bit irrelevant to my issue though.

I’ve tested on windows and Linux both and the issue persists. Hardware clicks aren’t impossible but they only register about 20%-30% of the time and it depends on where exactly you click on the touch pad.

On the old unit the left click had a 30% success rate on the right click, while the left click worked almost flawlessly, the new unit won’t register left clicks unless I click extremely close to the middle of the touch pad, but in this case the machine will often register a middle click.

The problem seems to be that the dome switch is not actuating when pressed on the left side. This points to a faulty dome switch I think.
Again the opposite is true for the old unit.

Upon examining the old units dome switch it can be clearly seen that its misaligned to the upper right, this is what I believe to be the root cause for the OLD unit. I still don’t understand what is wrong with the new one.

Oh I see. It looks a hardware issue. But just in case, have you tried to disable “PS/2 Mouse Emulation” on BIOS?

Change “PS/2 Mouse Emulation” to Off, and then save and exit the BIOS.

If you can not use right click, how about emulate right click with 2 finger click on OS level, called “clickfinger” in a mean time?

Yes I have tried disabling and enabling ps2 emulation for both Linux and windows and the problem persists. Software clicks work just fine along with scroll, middle and right click. its only hardware clicks as described above.