Touchpad not functioning properly

A few days ago my touchpad has seemed to lost some of its functions. The physical left click is finicky, as I am no longer able to drag, and the right physical click does not work whatsoever. Any idea on what I can do?


Are you on windows? If so can you check if there are any devices in windows device manager that have a yellow :warning:
If so try disabling and reenabling the device.

1 Like

I found that disabling PS/2 mouse emulation in the bios fixed those issues for me. There is a support article about how to do it: My touchpad isn't working

Hey, I really appreciate your reply!
I checked if there were any devices that may have errors, I was not able to find any. I also tried to disable PS/2 mouse emulation like Richard suggested but to no avail. I’m going to assume there’s a physical issue with the touchpad?

There is only one physical button, and left/right click is performed in software.
If you push hard in the bottom center of the touchpad a few times does it start working again?

1 Like

That worked! I’m now able to right-click but my ability to drag-click is still pretty finicky

This is still the case for me. Pushing it hard in the bottom center restores functionality somewhat… but only for a second.
Is there a permanent way to fix this? Is this a physical issue?

I’ve had some success in gently tightening the screws that hold the bottom edge of the touchpad to the input cover.