Touchpad Not Registering Clicks

I am using Fedora 34 with the latest updates. I have an issue with the touchpad where the mouse click will only register for “tap to click”. But if I actually press down on the touch pad to use it as a button, no clicks are registered.

Is this a known issue, or do I have a faulty touchpad? Two finger scrolling and 3 finger swipes all work just fine. So it seems to indicate there is a hardware issue.

Thoughts welcomed.

… Alan


Try Windows and install the driver package. If it works fine then it’s a driver, compatibility, or configuration issue.

Failed on both Fedora and Windows 10, with all drivers installed. I guess I got a lemon trackpad. Going to email support now. :slightly_frowning_face:

At least Tap-to-click still works.

Hi Alan, could you try the instructions here: (SOLVED, sort of)Touchpad Not Working Fully - #8 by pricedspacefan

Added to the Knowledge Base here: My touchpad isn't working



I disabled the PS2 emulation mode and it did not fix the issue.

… Alan

I am not expert but you can Use wired mouse for check system setting. OR try dry and clean hand, clean touchpad.

Just an update. It works now and I am not sure what I did to fix it.

Based on my recollection, it is probably one of the three things

  • adding i915.enable_psr=0 to kernel parameter
  • disabling PS/2 emulation in the bios (I said it didn’t work, but maybe I wasn’t testing carefully)
  • enabling deep sleep instead of s2idle.
1 Like

FYI: Same issue here, with same symptoms. PS2 disable does not work for me. I don’t understand the other two suggested fixes, so have not tried. I can use a mouse for now until this gets properly sorted out.

Update: My touchpad is now working, after pressing firmly a few times, and PS2 disabled. Now, it works with normal pressure.

I had some back and forth email with the Framework team during the troubleshooting. Another thing I did was to unplug and reseat the Touchpad Cable from the Mainboard. When doing that, verify that the Touchpad side of the Touchpad Cable is fully inserted (white line is straight and almost touching the receptacle).

I had a similar issue when I first assembled my DIY edition.

In both Windows 10 and Fedora 34, I could tap to click, 2-finger scroll, etc.

Clicking on the bottom left or right of the touchpad didn’t work. They seemed like a regular click, with “normal” sound/physical feedback. But then if I clicked down further past that, making sure the touchpad was clicked down all the way, it registered the left or right click.

It was like the touchpad had two layers. Definitely a physical issue, as I undid the top, jostled the touchpad around, put it back together, and then it worked normally. Edit: may also have been disconnecting and reconnecting the touchpad cable has @Alan_Ning did, but that makes less sense in my case.

Sidenote, the touchpad seems to have some consistency issues (probably because the touchpad can jostle a bit in the housing, e.g. if angled ever so slightly to the left, then the right side is noticeably harder to click than the left, and vice versa.

Edit: I had to jostle the touchpad around several times for the left and right click to require an equal amount of force and feel the same.

I had a Matebook X Pro with the common touchpad rattle issue, where the fix was putting a piece of paper underneath the tabs, as seen here:

This seems like a very similar symptom, although there’s really no rattle with the Framework. Curious to see if anyone from Framework has any insight!

If you are feeling or hearing rubbing or resistance when clicking (beyond just a normal tactile click sound), that potentially points to Touchpad glass misalignment. Check the bottom edge of the Touchpad to see if it is rubbing against the aluminum as you click. We found that our manufacturer had not tuned the glass placement well enough on some of the early production, which we have since fixed. If it is rubbing:

  1. If you’re comfortable trying it, follow the steps in the Input Cover Replacement Guide to remove the Input Cover (Input Cover Replacement Guide - Framework Guides).
  2. Slightly loosen the two fasteners in the top left and top right corners of the back of the Touchpad.
  3. While putting a little pressure on to slide the Touchpad towards the Keyboard, re-tighten the fasteners, making sure not to overtighten, since these are tiny.
  4. Double check the Touchpad cable before reinstalling the Input Cover (Input Cover Replacement Guide - Framework Guides)

If that doesn’t work or sounds daunting, reach out to our support team with an image of the Touchpad and your order number.


Thanks for all of the reports on this, everyone. We believe there is a production issue on a subset of touchpads that is causing the dome switch to not make full contact until it gets cycled a few times with pressure. We’re working with both our touchpad module supplier and our final laptop manufacturer on resolving this. We’re also going to write up a blog post around how we do this kind of EFFA (Early Field Failure Analysis). Whenever something like this happens, we determine:

  1. The root cause of the issue
  2. The resolution of the root cause
  3. Why this wasn’t caught during module level testing at the touchpad supplier (which it should have)
  4. Why this wasn’t caught during system level testing at the laptop final assembly line (which it also should have!)

For anyone who was seeing touchpad click not registering at first or until applying some pressure to it, (edit) send the serial number along with your request to support? You can find it in the front left Expansion Card bay (front right when the system is upside down). We’re trying to trace back to whether there was an issue with a specific touchpad batch.


Thanks @nrp! I ran across the issue again around 2 days ago, so I disassembled the touchpad, and reassembled it, making sure everything was aligned and screwed in properly. I also noticed the tabs in the attached picture (in the yellow rectangles) and thought that might’ve messed with clicks registering.

I slightly pried the tabs up more, as I thought the dome switch click plus the combination of the touchpad contacting the left or right tab would, in turn, register a left or right click via an electrical current (am I totally wrong on this? haha)

If so, my theory was that prying them up would decrease the distance needed for a click to be registered. edit: turns out I was wrong, see @nrp’s post below!

Seems like my issues have been resolved, and left and right clicks are overall consistent…but would love to know the root cause, of course.


Also, I know that it’s been said a ton but I also want to reiterate:
The Framework team’s transparency/direct communication, speed, and willingness to work through issues with your customers, in my eyes, is simply amazing. Much appreciated.

Sending you my serial number as well as pics of the touchpad now!


Thanks for all the detail on this @Michael_Wu ! Note that those spring tabs are only for mechanical stability (and I think EMI/ESD). Electrically, it is just that dome in the center that registers the physical click. We generally don’t recommend bending the spring tabs since the angle is tuned for physical stability.

We’re still digging into the issue, but we’ve confirmed that we’re testing physical clicks on the production side in multiple spots. Failure analysis is always a fun puzzle.


Ah I see, thanks for the info @nrp – in that case, it seems I might’ve done the reverse of my intentions, and increased the distance needed to click the dome switch. Nonetheless I’ve edited my post so people like me don’t go bending the tabs (unless they really want to :smiley:)

Indeed, it’s been fun on my side as well. Hope y’all get to the bottom of this!

1 Like

Yeah it’s been happening to me again for the last couple days. I had already done the tape fix. I think I’m going to need to open it up and try to figure out what’s going on. It’s definitely difficult to use the laptop when the trackpad is not working.

Just a note for anyone running into touchpad issues. If everything else is working normally (touch to click, two finger scroll, two finger right click, etc), but only physical clicks are not registering, this is likely to be the hardware issue we are trying to root cause. If you see this, contact Support so that we can swap out your Input Cover and get the one you have back to debug.


While using Windows 10 OS, I followed this step and it worked perfectly:

  1. Using an external mouse please open Device Manager. Find Human Interface Devices. Right click on 12C HID Device to disable it, and then right click on it again to enable it. (it may look like “I2C” in Device Manager)

Might not work for all but it did it for me.