Touchpad Not Registering Clicks

What is the difference between “touch to click” and “physical clicks”? Do you mean the amount of pressure?

Mine was acting up again the other day. I went into gnome-tweaks and noticed that no choice for mouse click emulation was selected (not even disabled). I selected Area and so far it seems to be working again. Not sure yet if it is temporary.

Touch to click/tap to click - Tapping the touchpad to register a click without activating the physical switch on the touchpad.
Physical click - Pushing the touchpad to activate the physical click (and hearing the physical dome switch activation).

Ah, yes then it was definitely the physical click I had been doing. Repeatedly over and over before it would register. Seems fine again now though.

Just an update since I started this thread.

I got my replacement keyboard this past weekend and the touchpad physical click issue is now completely gone. I mailed my old keyboard to the Framework team for diagnosis. Hopefully this issue won’t happen in the future batches of laptops.


Same issue as @Alan_Ning here. Pushing down firmly on the bottom middle of the trackpad worked like a charm.

@nrp is the firm press a temporary solution? Should I get in touch with support if the issue returns? I prefer not to waste a perfectly good trackpad if I can resolve the issue myself.

1 Like

Same issue here. Firmly pushing down on the bottom middle does not work. Also opened up and verified connectivity. Everything on the touchpad works except for it registering clicks. Contacted support and awaiting a reply.

I see an error saying I cannot PM that user.

Well it appears the physical clicks are becoming easier over time.
At first I really had to hammer the touchpad for it to register a physical click, but as time has gone by the situation has improved.
Currently I think it’s behavior is acceptable.

This worked for me as well. Or at least, I just clicked a bunch of times in the middle of the trackpad which seems to have had the same effect. Very strange! Works like a charm now.

A day or two ago my touchpad (DIY batch 3) stopped registering clicks much of the time. Left click was more often not recognized than middle or right, I think. Pressing hard in the middle sometimes helped temporarily.

It seems a bit better today after I opened it up and slightly tightened one of the screws holding the bottom edge to the input cover. I wonder if it works loose. If it does again, I’ll probably see what support can do for me.

I miss the buttons on my Thinkpad T480. So much easier to reliably click the right button.

I feel really dumb now that after a day of tweaking with kernel settings and Wayland and whatnot I read this topic and made the Framework clickpad work just by clicking it hard a lot. Well at least now I have a community account! Super happy with my purchase, just got it hand delivered to the ship where I work, preparing for an expedition to Antarctica. Any other Frameworks down here?

1 Like

After using my Framework Laptop for roughly a month, I’ve found that hard presses work roughly half the time. Soft presses work consistently, but whether it’s the left or right click function, hard pressing the touchpad will be of little to no reliability. Does anyone else have this issue?

*Windows 10
*1TB WD Black
*16GB Ram

My BIOS is up to date, and I haven’t tampered with any software besides disabling DPST Control.

1 Like

Most likely a hardware issue, I’ve also experienced this problem and my replacement input cover is still in shipping to my country. Refer to this thread for more info.

1 Like

I’ve been messing around with this (on Ubuntu) and maybe someone else seeing this problem can verify if they see the same thing.

When the bottom-left corner physical clicks are not working, I pull up the Settings | Mouse & Touchpad | Test your settings… after multiple clicking and double clicking I think I am noticing something.

While I am expecting the click to be in the far left corner; what is working is clicking at about 25% towards the right (ie: half way between the left corner and the middle click).

This worked for me. My symptoms were that the click would register either on its own or with much less pressure than usual, but only when I was using the laptop in a manner where the middle portion was stressed more than the edges - for example, if it were centered on one leg and both hands were on the palm rests. This introduced enough chassis flex to activate the click because the touchpad glass was rubbing on its frame. Moving the touchpad after loosening the screws fixed this issue.


I would also like to say in my experience with fixes the only one that worked for me was pushing the track-pad down really hard not enough to break it lol then it started working no trouble with normal taps and clicks. I’m using windows 10 btw but may help with other distros.

Mine has had intermittent click problems (touch always seems to work).

Today it got really weird. It wasn’t responding to left or right clicks. The settings page didn’t see any clicks registering.

Opened it up to make sure there wasn’t any debris in it.

Now the “left/primary” button only registers in the middle horizontal section of the trackpad (even on the right side). IE above the middle or right button.

@malachid that happened to me as well. A month or two ago I got around to putting in up to an hour to re-align the touchpad. Whatever I did seems to work still, I’m happy with click feel, and I don’t seem to have any missed clicks.

I’ll try to explain what I did and hopefully it helps. It took a lot of fiddling and I did essentially what rjk explained here:

IIRC, I tried to position the touchpad towards the keyboard. And I don’t remember which direction it was, but I remember sliding the touchpad in some direction with some pressure to make sure it stayed in that spot when I screwed it back in. That might of been one of my failed attempts though – it’s been a while so my memory is hazy.

What I do know for sure is that the tolerances are pretty tight. A slight movement in any direction does a lot. So if left click isn’t working, try moving the touchpad to the right. Then the right click might not work. Or the directions might be reversed, etc. Keep adjusting until both clicks feel the same and everything is balanced.

Which leads back to essentially what nrp’s instructions were:

Warning: I don’t recommend the below for reasons explained. Just adding for transparency.

I also messed around with the spring tabs in the bracket. Basically pushing the tabs back inward instead of upward to undo what what I had done incorrectly previously:

I’m not sure if the readjusting the tabs contributed to the fix, or if I was just bringing them back to “normal”. So I can’t safely recommend this, even as a last resort. Contacting support is probably the better option. I was just lazy, wanted to DIY, and eventually got it to work well.

Good luck!


I appreciate the information. I’ll try that out and see if that fixes it for me.

I’ve had my Framework for just about 8 months and ran into the issue of the trackpad not registering clicks. As others suggested, I popped off the keyboard and slightly tightened the two screws that hold the bottom portion of the trackpad in place. Boom, I’m back in business!