[TRACKING] Can't set resolution to 1600x1024 (3:2)

I can’t seem to change the resolution from the default (2256x1504 (3:2)) to 1600x1024 (3:2) on Pop!_OS. The screen goes black. Other resolutions work fine, even those with an aspect ratio other than 3:2. Different fractional scaling and HiDPI settings do not seem to change this. Pop!_OS uses the X11 windowing system, and I am on the latest version of everything as of writing.

Is anyone able to set their resolution to 1600x1024 (3:2) without issues?

By the way, the main reason I wanted to try this is because I have screen tearing or broken VSync or something like that when fractional scaling is used, and the 100% and 200% scaling options in the 2256x1504 (3:2) resolution are too small and too big, respectively.

1600 x 1024 isn’t 3:2.

You can try:
1692 x 1128, or
1620 x 1080


Yeah, it’s not exactly 3:2, but that shouldn’t be an issue. There’s other resolutions also listed as 3:2 that aren’t exactly 3:2. These do work, but there’s small black bars at the top because they don’t meet the aspect radio exactly

Cool to find 3:2 resolutions [SOLVED]
Am using Manjaro
and there is juste one 3:2 resolution

I try this Add/Change/Set the custom resolution of your display using xrandr on Ubuntu 18.04 — {In a minute} | by Abhishek Raut | Medium

xrandr --output eDP-1 --mode 1504x1002_60.00
Do the job


Comme ceci (ça peut servir)

cvt 1620 1080
# > infos...
xrandr --newmode "1624x1080_60.00"  145.50  1624 1728 1896 2168  1080 1083 1093 1120 -hsync +vsync
xrandr --current
# > Screen profiles/resolutions
xrandr --addmode eDP-1 "1624x1080_60.00"
xrandr --output eDP-1 --mode "1624x1080_60.00"

Permanent :

sudo nano /etc/X11/xorg.conf.d/10-monitor.conf
Section "Monitor"
    Identifier "eDP-1"
    Modeline "1624x1080_60.00"  145.50  1624 1728 1896 2168  1080 1083 1093 1120 -hsync +vsync
    Option "PreferredMode" "1624x1080_60.00"

Section "Screen"
    Identifier "Screen0"
    Monitor "eDP-1"
    DefaultDepth 24
    SubSection "Display"
        Modes "1624x1080_60.00"

Section "Device"
    Identifier "Device0"
    Driver "intel"

I have a strange problem on some Electron Apps…
(when using this in permanent config…)
Blanks/empty interfaces

I wanted a 1080p like resolution and have it permanent on my system:
sudo nano /usr/share/X11/xorg.conf.d/10-monitor.conf and add this in:

Section "Monitor"
  Identifier "Monitor0"
  Modeline "1920x1280_60.00" 206.25  1920 2056 2256 2592  1280 1283 1293 1327 -hsync +vsync

Section "Screen"
  Identifier "Screen0"
  Device "eDP-1"
  Monitor "Monitor0"
  DefaultDepth 24
  SubSection "Display"
    Depth 24
    Modes "1920x1280_60.00"

After rebooting, I could select my resolution from Display Settings just like any other resolution.
@Bonnefille_Vincent’s conf path didn’t work for me, so I used this one.
I’ve had no issues with Electron apps on Pop!_OS 22.04 LTS with i7-1280P.

1 Like

@TermoZour you just creat the file ! Am using Manjaro (Xfce)
Cool if no issues…
Me, with permanent (in my file location or yours), I have Vscode/Ellectrons emptys

So, Am on 3 posts/threads here…
All arround the lacke of GPU :sad face:
( this post and :

  1. https://community.frame.work/t/12th-gen-not-sending-xf86monbrightnessup-down/
  2. https://community.frame.work/t/electron-apps-are-blank-empty-on-startup-solvable/


@TermoZour on my file I have…

Section "Device"
    Identifier "Device0"
    Driver "intel"

Mentionning Intel as GPU
So I installed drivers and co

If I install xf86-intel-driver… and configure the 10-monitor.conf like I said here, the brightness button works (1.) but I have issues with Electrons Apps (2.) andd need --no-gpu flag on apps like vscodium :sad sad:

Why do you need to install Intel drivers? I’m using whatever is shipped with the kernel and everything works fine for me. Even games.

EDIT: Here are all the *intel* packages I have installed on my system with sudo apt list --installed *intel*

intel-media-va-driver/jammy-updates,now 22.3.1+dfsg1-1ubuntu1 amd64 [installed,automatic]
intel-media-va-driver/jammy-updates,now 22.3.1+dfsg1-1ubuntu1 i386 [installed,automatic]
intel-microcode/jammy-security,jammy-updates,now 3.20220809.0ubuntu0.22.04.1 amd64 [installed,automatic]
libdrm-intel1/jammy,now 2.4.110-1pop0~1648761328~22.04~166056a amd64 [installed,automatic]
libdrm-intel1/jammy,now 2.4.110-1pop0~1648761328~22.04~166056a i386 [installed,automatic]
xserver-xorg-video-intel/jammy,now 2:2.99.917+git20210115-1 amd64 [installed,automatic]

And related to the brightness keys issue, right after I installed my OS, I added blacklist hid-sensor-hub to /etc/modprobe.d/framework-als-blacklist.conf and then ran sudo update-initramfs -u and a reboot fixed it.
Same thing when I wanted to add my own custom resolution in 10-monitor.conf. Just create the file, reboot, go to Settings and set my resolution like any other.

If there’s any other config file that I can share, let me know. Maybe Manjaro is setting something that breaks things, something that Pop!_OS doesn’t do.

1 Like

It was a solution Add/Change/Set the custom resolution of your display using xrandr on Ubuntu 18.04 — {In a minute} | by Abhishek Raut | Medium
but very laggy from now : I just upgrade to Linux kernel to 6.0+ (Manjaro and apps Up to date)

So am shitting for now using

Tracking. If it’s laggy, it’s worth running journalctl -f in a terminal and navigate to see if anything provides additional insights.

I have this journal error output…
i915 0000:00:02.0: [drm] *ERROR* Fault errors on pipe A: 0x00000080

Where am searching

adding ?
GRUB_CMDLINE_LINUX="i915.enable_psr=0 intel_idle.max_cstate=2"

check + reset ?
xrandr --verbose

Hum, I dont know why…
But, finaly… doing a xrandr --output "eDP-1" --mode "1624x1080_60.00"
stop the error, make my screen at the good resolution :
stop the pipe A error + laggy screen