[TRACKING] RE(X)ubuntu 22.04 - More 3:2 Resolutions?

Is there a way to get more 3:2 resolutions into the dropdown?

The native resolution is the only one in 3:2, but that is far too high resolution to be useful as a second screen on a desktop.

I run the scaler at 0.7x now to be useful, but the non-integer scaling causes issues (flickering mouse cursor)

1 Like


Xubuntu uses the XFCE desktop. I love XFCE, however, I do not love it’s scaling options.

The 3:2 resolution you see is what is best for that display and what is available. Scaling XFCE is painful on a good day.

I don’t recall (as I have not used XFCE in ages) if Xubuntu supports Wayland like Ubuntu does. Wayland is required for a usable scaling experience.

I dont know for xfce, but i added in my /etc/profile (you can use .profile in your home apparently)

xrandr --newmode "1920x1280_60.00"  206.25  1920 2056 2256 2592  1280 1283 1293 1327 -hsync +vsync
xrandr --addmode eDP-1  "1920x1280_60.00"

and it works on kde.


cvt x y 60

to generate the numbers (i took the infos from xrandr - How do I set a custom resolution? - Ask Ubuntu )


This is indeed one option to try, may help.


I’m experiencing the same problem… but before tweaking with configuration files, I’d like to understand why all (17!) resolutions that gnome-preferences (in Debian testing) proposes have some different ratio than 3:2. Can you confirm these are just the resolutions that the screen proposes to the OS (that is, not an issue with, say, graphic drivers)? Is this the same in Windows?

[BTW: I’m perfectly happy with the default resolution when I work on the laptop alone; but when it is on my desk, connected to my external monitor, it ends up being farther away from me, and I need something between the 100% and 200% scalings that GNOME proposes to me]

Hi, just booted up my new 13th Gen framework. Same issue, the fractionnal scaling is blurry on chrome and firefox, so pretty unusable for a daily laptop. I can zoom in for the browsers starting from a 100% scale, but all the other interfaces are going to be very small so I’d like to find a solution to make it somewhat 150%. I’m surprised this is not a major reported issue.

Update: I ran the script show by the framework team, and it’s still blurry :confused:

Update 2: by using x11 instead of wayland, fractional scaling is solved. I guess Wayland still has some work to do.

1 Like

Hi @Florent_Destremau welcome to the Framework community,

yes apparently fractional scaling is still a work on progress on wayland, glad that you’ve settled with x11 to solve this issue.

1 Like