[TRACKING] Hard freezing on Fedora 36 with the new 12th gen system

This issue in the tracker seems to be most related:

Adding my experience to the data.

  1. Fedora 36
  2. Linux 5.19.16-200.fc36.x86_64 #1 SMP PREEMPT_DYNAMIC Sun Oct 16 22:50:04 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
  3. module_blacklist=hid_sensor_hub
  4. 1TB SN850
  5. Happened when in gnome-settings

Update 2/11/22:
No freezes since the first time. The only thing I changed is I replaced the HDMI extension card with the 1TB instead.

Update 4/11/22: Added i915.enable_psr=0 to my kernel parameters, and I have not had anymore freezers. Running Xubuntu (5.15.0), Fedora (6.0.5) and Pop (6.0.3). HDMI extension card and Anker USB-C hub with HDMI both seem to work equally well.

Checking back in after a while. I have had zero lockups or freezes since I added options i915 enable_psr=0 to etc/modprobe.d/i915.conf. For the new folks chiming in, scroll back to my reply on 28 Sep for detailed instructions if you need them. I hope you guys get the same kind of positive results out of it that I have had.

6 Likes

Tried your fixe and I doesn t boot on Ubuntu mate 22.04 LTS with kernel 5.18.19

Wiered thing happened it triggered a lag in my blutooth mouse when I wouldn t use it for more than 3 seconds.
After disconnecting and reconnecting my mouse from the blutooth center it is back working.

For now I am keeping my system like it is , I have a freez once in a week…so I guess that s were we are now . Looking for BIOS update & next kernel.

As anyone tried ubuntu 22.10 ???

I don’t think that that error makes sense for that kernel module option.

I’m running KUbuntu 22.04 with that option and kernel 5.19.17-051917-generic. So far no freeze but I haven’t had my laptop very long.

It s just there in front of me :wink: Anyhow removed this option and back to almost normal (I still feel a tiny little lag in my mouse but I can live with it after a 3 second not using . It is now down to 1/4 th secondish).
Note : I had to install “dracut” with ssome dependencies from apt.
To put it in a nutshell I personaly, on my ubuntu mate 22.04 system, wished I had not tried this workaround. I have not gained any stability and got a new problem :wink:

I believe you, but I don’t understand. That appears to be an error related to mounting an overlayfs.

2 Likes

I don t understand either… Too wiered , that s why I am not messing anymore with it . I ll keep my mini micro lag on blutooth :wink:
Here is my history :

1 Like

Of note: I’m not an Ubuntu expert but I didn’t run dracut. I ran update-initramfs -u instead.

2 Likes
  • Guix SD
  • 5.19.11 (full version, from nonguix)
  • Not initially (see below). Notably, ALS has not been disabled.
  • Intel 670p Series M.2 2280 1TB PCIe NVMe 3.0 x4 QLC Internal Solid State Drive (SSD) SSDPEKNU010TZX1
  • No obvious pattern

After adding i915.enable_psr=0 to my kernel parameters, I’ve not had any more freezes.

Still, would be good if you can share the various / multiple circumstances even if you, at the individual level, can’t determine a pattern. i.e. a larger data set might allow for a pattern to be draw…but we still need the data points to begin with.

After adding i915.enable_psr=0 to my kernel parameters, I’ve not had any more freezes.

This seems to solve it for me as well. Before that, I had 20sec freezes up to Wayland/KDE crashes every hour(?). Now, already one day without any freeze.

Linux fedora 5.19.16-301.fc37.x86_64 #1 SMP PREEMPT_DYNAMIC Fri Oct 21 15:55:37 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
2 Likes

At first on 6.0.6-300.fc37.x86_64 kernel my machine was fine. Ran great for over an hour, no freezes, but it seems like it’s still not fixed as the freezing has returned. :frowning:

Yeah…an hour is too short…reporting too soon.

Strangely every time I tried to remove the kernel param before (5.19.x kernels) I got freezing within minutes of login :man_shrugging: but agreed, too soon. A little too eager for this issue to be resolved.

I would be, too. But at least the psr setting is a temporary workaround.

1 Like

That’s unrelated to the enable_psr setting. That’s bluetooth autosuspend. See Ubuntu Bug#1801642 (Add btusb.enable_autosuspend=0 to your kernel command line to fix)

I haven’t had a Gnome shell freeze in the 18 days since my post #161 with the upgrade to kernel-5.19.15-301.fc37.x86_64 and blacklisting hid_sensor_hub.

I have not disabled PSR via the kernel command line.

(though I’ll admit I haven’t been exercising potential problematic code paths as I’ve had my Framework docked the whole time as a desktop replacement rather than using it as a laptop)

Having similar hard freezes with Asus Zenbook Fedora 36 kernel 5.19.8-200.fc36.x86_64 halt - Ask Fedora
Haven’t had any significant halt after blacklisting hid_sensor_hub.

just to add my experiences on i5-12th gen; hid_sensor_hub blacklisted (purely for brightness cntl) had no effect on stablity. i required i915.enable_psr=0.

only been 2 days since i added psr=0 but i’ve had multiple resume from sleep’s without issue where as before i’d be getting the issue every resume. i’m reasonably confident its stable for me now, hence this post.

2 Likes