[TRACKING] Instant power loss

It does seem the square bracket the holds the wifi wires may have been partly under my RAM. Reseated it now and will report back

@Dale_Patch I’m sure I didn’t check the bracket itself, I’ll look at that closer tonight.
Mine happened after the 3.07 bios update and the windows firmware update, so I’m not sure if updates would help regarding Linux.
Not ideal, though hopefully it does end up being a minor fix with making sure nothing is disturbing the ram connection. Crossing fingers

I checked the ram - nothing underneath or of note. I removed and reseated while I was there.
I can definitely see how a WiFi wire or plastic clip could cause an issue. Unfortunately with the lack of anything under my ram, it doesn’t help the issue be any less complicated. I was kind of hoping something WAS under it, at least that would make more sense.
I just have to hope it was a one-off for my machine.
@Dale_Patch Good luck!

Well, the problem happened again. Reseating the RAM and fixing the route of the wifi cables didn’t fix the problem. At this point, I may just see if I can get some hardware replaced. Since this problem seems quite rare, it may just be faulty hardware. As a last resort, I tried reassembling the touchpad to the input cover, since I noticed that the power-offs usually happen while I’m using the touchpad. I’m not very confident that this will actually fix anything though, especially since I didn’t notice any apparent problems during the disassembly.

UPDATE: Yup, just happened again. I’m out of ideas. I’ll see if I can get in contact with Framework to try to get some of the hardware replaced.

@Sebastian Ugh! sorry to hear about that. Still no re-occurrence from mine, but at least you can point out this thread to them for some background on the issue.

Edit: about the touchpad, I am certain I was actively typing on keys when mine happened, and the touch pad doesn’t really make sense either. My theory is we were all putting pressure on a particular unknown area, I mean that area could certainly be near the touchpad. Coincidentally near the battery. But then again, I`m not sure about anything other than it’s happened to at least 3 people.

this may be related to Watching youtube…sudden shutdown

1 Like

I’ve had my laptop since September, and have had the same thing happen to me twice this past week.

Once in Windows while playing a video game, and once in Linux while compiling some code.

In both cases, there was higher power load.

The battery was fully charged, and I was connected to power.

After the power loss, pressing the power button didn’t really work, and I had to hold it to clear some weird state.

Hmm. Complete outsider, but I wonder if it’s a power supply state configuration in the BIOS that’s changed something so that it isn’t supplying quite enough for peak demand on the rare occasions it’s necessary :thinking:


Could this be similar to OVP (over voltage protection) on newer 30 series cards with them spiking way higher than meant to and the battery and power circuit resets.

As good of a theory as any :man_shrugging:

I’m curious if having only one ram stick is a factor, as it’s been mentioned as a theory for the behavior (read so much here and elsewhere I forget where lol) and I only had one installed when mine occurred. I’m not informed enough to rehash why the MB could have issues with only one stick, even enough to cause this issue. But my simpleton brain dumbed it down to “1 stick bad, 2 stick good” :joy:

I’m not totally sure how it could be the RAM because usually a memory fault would be a blue screen fault, not a total loss fault :thinking: unless the RAM was taking more power than it’s allowed to!

1 Like

Glad to see I’m not alone in this experience, but it’s too bad that we still don’t have a clear idea of what’s causing this. Hopefully nobody ends up losing work to this issue.

For what it’s worth, I just got my device (edit: DIY so maybe I should have posted in the DIY thread…) running yesterday and experienced two unexpected power losses. One was just as I was starting to go through the Windows 11 installer, so I don’t believe I have any event logs from that one. I experienced another shortly after I began customizing settings in Windows (and I think before I started installing stuff), so it shouldn’t have been under particularly high load in either of these poweroff cases. I haven’t had any reoccurrences since. Like @cybojanek shared, I too had to hold the power button to get the system to noticeably do anything.

In the Event Viewer, I see a Critical Kernel-Power event stating that a reboot (the second one happened around that time) was unexpected. I have my event logs saved in case someone from Framework looks into this issue and is curious. BIOS appears to be 3.06 from the factory (11/15/2021 batch) – I haven’t updated yet. I see a mention of one vs two RAM sticks by @mjnz – I had/have 2x16GB Crucial DDR4-3200 sticks installed. I have the 1135g7 CPU, so I don’t think power draw should have gotten too high for the system to handle. And as far as peripherals go, the most power-hungry peripheral my Framework has powered so far is a USB-A thumb drive for the Windows install. I’ve taken pretty good care to maintain reasonable ventilation, so I don’t think any sort of overheat issue explains this. I believe that power was connected during both power losses, which made this behavior particularly befuddling to me.

1 Like

@jsh the list is unfortunately growing. I guess your experience blows the “1 stick” theory. Mine was not plugged in, light duty just typing, I had already updated to 3.07 the night before.
Just trying to muddle through and taking stabs in the dark what’s causing this.
The good news, at least for me, only happened once.

This just made me realise another obvious benefit that companies get from NOT offering more user freedom: support/troubleshooting is much easier when there is only a small set of possible configurations, both on the hardware and on the software side. Of course Framework tries to counter the software side of this effect by advising to only use officially supported OSs, but I still bet the support resources allocated to their prebuilt models are minimal compared to those allocated to us strongly willed DIY/Unix enthusiasts (although this particular bug seems to affect both). Kudos to the Framework team for putting up with that challenge, I’m sure that even with all their experience, they underestimated how diverse support requests for (essentially) one product and its parts could be.


+1 on instant power-loss under load

Started from full battery ~98%
Laptop Batch : October 2021 DIY
CPU: Intel® Core™ i7-1165G7
OS: Fedora 35
BIOS-Version :" sudo dmidecode -s bios-version" → 03.02
factory default

Under load whilst unplugged on dolphin emulator resulted in sudden power loss.
Turned it back on with 80% battery left (didn’t have to hold power button long in-order to reset anything).
Fan made a weird noise just before power shutoff.

Try doing the ram shuffle, told to by support.

Still occurring. I saw on another thread someone mentioned being related to their hard drive. Believe they replaced it and stopped reporting back.

This did seem to get worse around the time I added my SN750 to the laptop, but I have yet to try removing it again.

Given this thread I’m wondering if the issue is actually caused by SN850 rather than memory or the mainboard itself.

Could someone with a spare SDD try swapping it out to see if it makes any difference? I have another SDD but I’ve experienced power loss only once, so it would not be very informative in my case.


As Korvin mentioned, i had a buch of weird BSOD and freezes/crashes while I was running a Wester Digital SN850 (with updated firmware) with Windows 11. The Framework support person was convinced it was a DRAM issues. I tried 3 different set of DRAM before trying a different SSD. I tested my laptop on an old SK Hynix SSD then a newer and larger Crucial P2 and all the bugs disappeared.

1 Like

It can probably explain my case as well. When I connected a USB memory stick that caused some sudden SDD activity as it usually does. SSD consumes much more power when writing data, so that could result in a sharp spike of power consumption. If power regulators are faulty or not powerful enough it theoretically could cause brownout and similar issues.

We can probably stress test the system by crafting various power management scenarios to see if it makes any difference.