Trackpad disabling while typing?

Apologies if this has been discussed before, but I couldn’t find anything. My Framework is running Arch (dualbooted with Windows 10 via an expansion card).

My trackpad works beautifully. It’s really smooth, gestures work with GNOME the same way they do with macOS. There’s one small issue though. While keys are being pressed, the trackpad is disabled (except for full clicks). I can’t move at all. This is a problem, because I like to play less graphically-intensive games pretty often. When I’m moving with WASD, I can’t move the mouse cursor at all. I have to completely stop moving, then move the cursor.

Not sure if the issue is Linux-specific, it seems to also happen in Windows. I’m posting it with the linux tag in the hopes there might be a linux specific driver tweak or something.

I know that this is commonly done to help with avoiding false movements during typing. Still, I would rather disable it if it’s possible. Hoping it’s not built into the hardware.

Do sudo apt install gnome-tweak-tool and start the Tweaks application. In the “Keyboard & Mouse” section there should be an option called “Disable while Typing” just under the “Touchpad” subsection. See if disabling this option helps!


@zmk5 Thanks!!! That fixed it. Works beautifully now. Such a minor thing, but it was really bugging me.

Thanks again.

(although, a note for others, since I’m using arch it’s

sudo pacman -S gnome-tweaks

I already happened to have it installed, for changing themes)

1 Like

Trust me, I was annoyed with it too, but then found when I was typing some stuff that the trackpad was a real pain in the butt if I happened to graze it. I think I’m going to set a custom keyboard shortcut to toggle that. Need to dig into how I could do that.

Edit (FIXED): As is often the case, posting the problem inspired me to double check the obvious, and the obvious solution worked. KDE → System Settings → Hardware → Input Devices → Trackpad → (Uncheck) Disable while Typing.

A similar issue I’ve experienced with my install is that the trackpad disables while spacebar is held with no preceding modifier. It works fine when a modifier is used. This becomes an issue with GIMP, as space+mouse movement is used to move the canvas around the screen.

OS: Garuda Linux
Host: Laptop A8
Kernel: 5.13.13-zen1-1-zen
Uptime: 22 mins
Packages: 2556 (pacman)
Shell: fish
DE: Plasma 5.22.5
WM: KWin
Terminal: konsole
CPU: 11th Gen Intel i7-1185G7 (8) @ 4.8GHz
GPU: Intel TigerLake-LP  [Iris Xe Graphics]
Memory: 3.75GiB / 31.14B

Right now I’m working around the issue by using the super+space+mouse movement in GIMP. I’ve been able to replicate the behavior outside of GIMP as well as KWin/Plasma (inside a Kodi session). I’m fine with this workaround, personally, but it would be nice to figure out a root cause and solve it. Is this hardware/firmware level behavior?

under windows there is a similar setting called “touchpad sensitivity” that adjust the timeout of locking the touchpad after you press a key. If you set it to “most sensitive” then the touchpad will not lock.

However if you noticed is that if you start with using the trackpad and then begin typing, the trackpad will not be locked until you stop using trackpad. then the stuff will kick in.

This also shows that … hm. My PC have a precision touchpad. I thought lenovo is stupid and stuck with a ELAN … oh, that’s the trackpoint. Anyhow.

Precision Touchpad driver. Well done.

1 Like