Unable to "disable touchpad while typing" (Linux)

Just received my new Framework 16. Beautiful machine, and the DIY assembly was super simple. Love the display. However…

After installing Debian 12.5 with Xfce, I found that the touchpad is not disabled when I type. With the huge touchpad (the one on my old laptop is much smaller) I’m constantly touching it with my palms, which relocates the cursor. Makes it very difficult to type. I checked the xinput settings, and the “disable touchpad while typing” option is turned on, i.e. set to “1”. I set it “0”, back to “1”, doesn’t matter, the touchpad won’t ignore inputs while I type.

Is there a way to fix this?

I wish i had that problem, i can’t get it to not disable in Windows when playing at least 1 game that uses mouse and keyboard.

There is a fix on the forums already at [RESPONDED] Fedora KDE - "Disable while typing" for touchpad doesn't work. The Linux newbie I am can’t make heads or tails out of what to do on Linux Mint Edge though to fix the issue based on what they have said.

Tried that, did not work. Still within the 30 day return window, so I have a little time to see if I can fix this or swap it out for a ThinkPad.

If you are thinking that way already, might as well return it and save the trouble. This is a software problem that has already been fixed in more up-to-date libinput. You bought a bleeding-edge laptop, you need a bleeding edge OS to avoid problems. Debian is usually pretty far behind on updates.

That said, you should be able to fix it by adding this file:

[Framework Laptop 16 Keyboard Module]
MatchName=Framework Laptop 16 Keyboard Module*

Also, check out this wiki for Arch here. It has the above quirks for the touchpad (which is no longer needed on Arch) and a few other suggestions you might find useful:

1 Like

Yes, well. “Quit now” is not quite the type of advice I was looking for. I have 3 weeks before the return window closes, and I would prefer to fix the problem if I can.

I did add/modify the *.quirks files, and that did not help. The Arch wiki has the same advice about the quirks files.

I was skeptical that the problem is caused by “bleeding edge” hardware, because even though the CPU and GPU are kinda high-end, I really doubt the keyboard and touchpad are. Still, just to make sure, I installed Fedora, ran the upgrade, checked the quirks, and still no dice. Touchpad still not disabled when typing.

Any other suggestions?

I was having this issue on arch and the quirks adjustment resolved it. With no disrespect intended, are you sure that the quirks file is being applied? I moved from a framework 13" to a 16" and this absolutely was happening to me until I applied that adjustment.

Well that’s the fix to get it working. Don’t really know what else to tell ya if it’s not working for you. Maybe try a different desktop environment.

No disrespect taken, I’m by no means an expert on Linux, more in the noob camp (therefore hesitant to dive into Arch). Didn’t know about quirks until now. Can you tell me how exactly did you solve it? Do you have the quirks file at /etc/libinput/local-overrides.quirks or /usr/share/libinput/50-system-framework.quirks? Or both?

Also, what’s in the quirks file? I’ve seen 2 different suggestions, this (which is what I have):

[Framework Laptop 16 Keyboard Module]
MatchName=Framework Laptop 16 Keyboard Module*

Or is there also a section for the touchpad - I’ve seen that somewhere, but don’t remember now where I saw it.

And how do you know if the quirks are being applied? Make changes as root, then reboot, right? Is there a way to check?

Tried Debian with KDE, that did not work. Haven’t tried a different DE with Fedora, I’ll do that next. However, I really do like Xfce, and I don’t want a machine that is limited to just one particular OS/DE combo.

Thanks to both of you for taking the time to help

Is your keyboard module possibly called differently? What do you see in “lsusb”? Mine, for example, looks like this:
Bus 001 Device 010: ID 32ac:0012 Framework Laptop 16 Keyboard Module - ANSI
Which matches the name in that quirks file.

Not sure, but check your logs, probably X or wayland. In my case I created the file, rebooted, and noted that my touchpad was now disabling when typing. I didn’t look any further.

Yup, that’s what mine says. OK, I’ve got a request into Framework support, I can try re-installing an OS and redoing the quirks files while I wait for them to respond.

1 Like

Apologies for the delayed reply. I looked and found that I had it in both files (hanging head in shame), because I am an idiot. I have commented it out now as the version of libinput on my system no longer needs it. According to Matt H in this thread [RESPONDED] Fedora KDE - "Disable while typing" for touchpad doesn't work - #18 by Matt_Hartley it should go in the local-overrides file. The other file you mention with the touchpad entries is mentioned by Mario in the second.

I didn’t know how to see what was active, but this page had helpful instructions: Device quirks — libinput 1.26.1 documentation, and I could see when I uncommented the entries in the local-overrides file that they were noted. Then when I removed that file and uncommented the entries in the 50-system… file they were noted as well.

So that leads me to believe that if you have the file in place you should be able to see a result when checking. I found three entries in /dev/input/by-id and saw the quirk “active” for each of them. Edit to add: sudo libinput list-devices will do better than my directory spelunking. It also showed me that the touchpad is disabled when typing.

Hopefully this is a little bit useful and helps you to track down what is going on. Thanks for the question, I learned something new (but I’m still an idiot)!

No need to apologize, I’m doing this in my spare time between work and family, so I don’t expect anyone else to respond immediately. I really do appreciate all your help.

1 Like

Fedora 39 here. for reference my libinput list-devices output:

Device:           PIXA3854:00 093A:0274 Touchpad
Kernel:           /dev/input/event4
Group:            6
Seat:             seat0, default
Size:             124x77mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Disable-w-trackpointing: enabled
Accel profiles:   flat *adaptive custom
Rotation:         n/a

the Device and disable-w-typing lines are likely the ones you care about, but figured give it all for ref. I did have the same sort of issue until I applied the path (and now I’ve dropped the patch since it made it into F39)