Trackpad skipping during games

I decided to mess around with some games and opened up Portal and noticed the trackpad would not work when moving around using WSAD. I thought maybe it was just the game and tried it on a few others and it did the same thing. I’ve been playing games with no issue using a gamepad and I am just now encountering this.

I was actually able to recreate this after posting by pressing W and A and trying to move my cursor and it won’t move. So it appears to happen in or out of the game. Looks like if I push any key on the board and then try to move my cursor, the trackpad won’t move it.

Wondering if I am doing something wrong or if this is actually a bug?

I7 DIY
32GB Ram
2 TB Storage
Windows 10
10.29 Drivers

I can recreate this on https://krunker.io/. It most consistently happens when you press and hold any number of keys and then immediately touch the trackpad.

I’m wondering if this is related to the small bug that I’ve experienced where if you press one key, then immediately press and hold another key while holding the first key, the held second key will not repeat as expected.

1 Like

I also noticed this constantly when using the trackpad. When I move and then click immediately the cursor shifts. Quite annoying when you are trying to click a link, button, or a specific spot on a word document.

1 Like

@Ryan_Blakeney I’ve also been experiencing this as well but I can’t consistently repeat it like that, but it does happen often enough where it gets really annoying.

I even made a post about it. Mouse Pointer Slightly Jumps/Moves when I Click on the Touchpad

Yeah seems similar. Did you manage to fix it? I lowered my sensitivity and its still repeatable like you see in the video.

1 Like

Nope. I also tried setting mine to the lowest sensitivity but doesn’t exactly work either. I do not know if this is just the trackpad experience for everyone who owns a Framework laptop or a defect. I’m resorting to just tapping on the trackpad rather than clicking on it in the meantime.

1 Like

The description in the OP sounds like it’s an OS-level “disable trackpad while typing” setting. People who tend to accidentally touch the touchpad while typing like that behavior. I don’t know about Windows or Wayland, but in X11 the libinput driver has a “DisableWhileTyping” option that defaults to on.

The key repeat thing is probably also an OS issue. The keyboard just reports key presses and releases, the repeat stuff is in the OS.

The cursor shift on click may be that you’re sliding your finger over the touchpad while clicking, and the OS isn’t filtering out the motion as you expect.

2 Likes

I understand. I haven’t used a windows laptop in 10 years so I haven’t experienced this until now. Previously I was using a MacBook Pro and it didn’t do this so I think Im used to that and switching has been a new experience for me.

I’m able to easily move the trackpad while typing, so I don’t this is intentional behavior.

Unless Framework is configuring Windows weirdly, I also don’t think this is the case, since the key repeats fine on every other Windows machine I use.

1 Like

My thought, too. And, by the way, this would be my recommended setting if you’re having problems with precisely setting the cursor when using the trackpad. An example would be when selecting a rectangular area for a screen grab.

The standard problem here is that having drawn the rectangle, from the top left to bottom right, say, you find on removing the finger that the bottom right corner of the rectangle has shifted. In fact, it’s almost impossible with any regular track pad for this point not to shift when you lift your finger.

The solution is to use the “disable trackpad while typing” setting. Instead of lifting the finger, simply hit a key, thus switching off the trackpad. The cursor will stay glued to the exact point you left it at


Chris

1 Like