Trouble resuming - win11 and manjaro - Crucial P5

Basically I have trouble resuming from sleep on both Windows and Linux. In both cases the SSD seems to have disappeared, that’s why I think these are the same issue.
I’ve searched here and didn’t find a definite solution.

My config:

  • Framework Laptop DIY edition, i5-1135G7
  • Intel AX210 no vPro
  • 32GB DDR4-3200 kit from SiliconPower
  • Crucial P5 1TB CT1000P5SSD8
  • Windows 11 and Manjaro KDE dual boot
    • Windows 11 with Bitlocker and fingerprint login enabled
    • Manjaro KDE on LUKS-encrypted btrfs root partition, no swap, no separate boot partition

Windows 11 behavior

I closed the lid and left for half an hour, came back and was greeted with this:

After pressing OK it reboots, but the OS entries are gone. Turning off and on from the power button brings the boot entries back.

Manjaro behavior

After closing the lid and opening it after time passes, it goes to the unlock screen, as it is supposed to.
After I type my login pass, it just locks up.
When I short-press the power button, I see this:

Long-pressing the power button gives back a bootable system again.

Swapped the Crucial P5 with an Addlink S70 that I was using as a game drive in my desktop.

No problem waking up so far.

I guess we should put the Crucial P5 into an unsupported hardware list as I’ve seen it mentioned with a similar problem elsewhere in this forum.

Just wanted to say, I came across this post while looking into the same problem with the same SSD lol! I definitely can echo this with Ubuntu 21.10 , after hitting suspend, the power button light stays on and the screen stays black. No matter what I do, unless I power it off and on, it will not wake up.

Crucial does have an FAQ on this: , but their solution is catered to Windows, along with the tool to update the firmware of the SSD itself. Not sure if you had originally tried that as well with your Win11 testing.

Nirav posted this in another thread: My system is rebooting to a “Default Boot Device Missing or Boot Failed” message

Thanks for the notes!

@Ivan_Diaz I remember checking for the firmware update back then and I think there was nothing. However now the SSD is on my desktop and something shows up:

As for the Windows fix, I have not tried that. Anyways, Windows is not the primary OS on my Framework laptop, so the first cross-platform fix that worked was swapping the drive. I think I will not move the data back and forth again to check other fixes for now.