Ubuntu 21.04 on the Framework Laptop


The default option for WiFi on Linux is to be on power saver mode. Try disabling that using this guide and try the speed test again. Be warned, however, that this does have a significant effect on battery life.

1 Like

@zmk5 Ok, I’ve checked, but this is definitely not my case. First of all, I test it with power plug connected. Also, in battery settings I set the top performance mode for both AC and battery scenarios.
But today it’s another miracle – the download speed is almost the same as via Win10 ( 110-155MBps for Ubunty vs 160-177MBps for Win10). But the upload speed is surprisingly low today for Ubunty – 10MBps vs yesterday’s 20MBps( and today Win10 shows 20 MBps as well). So it looks like the new driver is better than the one included with Ubuntu 21.04, but it’s not that stable as Win10 driver from the performance perspective.

Update: Yes, I have created tiny automation that runs multiple speedtests sequentially. And I can confirm the Win 10 running this automation shows pretty stable performance for the download and upload( within 5% difference between runs), whilst Ubuntu 21.04 has strange speed fluctuations for both download and upload( some runs have ~50% difference). I’m using the same conditions for both Win10 and Ubuntu runs. Just to conclude – newest Intel driver for Linux is better than stock one, but it’s not that stable as Intel’s driver for Win10 from the performance perspective. All Ubunty tests done with the stock kernel: 5.11.0-34. The last thing to try is to update to the 5.12 kernel – maybe it’s more stable and compatible with the Intel’s WiFi driver.

P.S. Just for the record – I’m using Meshed routers infrastructure in my house. But both Windows and Ubuntu tests done from the same table and as far as I see in both cases they connect to the same Mesh Pod

Having the battery plugged in or setting the battery setting to performance does not change the power setting of the WiFi chip. In fact, it is just an integer variable that needs to be manually changed. I’m fairly certain the link I provided would solve your issue.

1 Like

@zmk5 ,
Even considering the fact I had some doubts, but I gave a try and set it to 2. And the result is really interesting!
Now, the Ubuntu fluctuations are gone!!! I’m getting stable 120-130MBPs for download and 20-21MBPs for upload. At the same time Win10 scores 155-170MBPs for download and 20-21MBPs for upload.
So the outcome is:

  1. New version of the Intel Linux driver is a must if you want to have more or less real speeds.
  2. The /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf file has to be updated and wifi.powersave = 2 (disabled) should be stored there instead of the default 3. This will save you from the download/upload speed fluctuations on Linux. @nrp Maybe it’s important info to add to the guide for Ubuntu 21.04( and another Linuxes)?
  3. The Intel Linux driver/firmware is still behind comparing to the Win10 version in terms of the performance. Maybe the newer kernel( 5.12) will close this gap??? Who knows… :joy:

@zmk5 Although, I should admit that My HP Omen 15 2020 has significantly better download speed than either Win10 driver or Ubuntu 21.04 newest Intel driver on Frame.Work:

(this is my HP Omen sequential speed test with the stable result). As you can see the download speed is almost twice faster than Win10 on Frame.Work. It’s almost the same as a maximum download speed of my Rogers Internet plan( 300MBps). My HP Omen has Intel WiFi 6 AX201 160 Mhz WiFi card. I believe it’s more stable and the drivers are more polished even for Win10 than for the AX210 used by Frame.Work team. I hope at some point Intel and Frame.Work teams will fix this issue and improve drivers capabilities for AX210.

1 Like

Ok, small update. I’ve tried newer kernel 5.12. Unfortunately, no improvements, the WiFi performance is the same as 5.11. But I’ve got some strange issue with BT and headset with 5.12 kernel. Every minute the sound in BT headset disapears for few seconds. With 5.11 everything was working fine.
So I’m rolling back to my 5.11 kernel.
I have acceptable and stable results with Ubunty and 5.11 kernel, AX210 and Intel firmware and power saving turned off:

P.S. Also I have successfully configured fingerprint authentication in Ubuntu – both on Login screen and terminal sessions. Works like a charm, the same experience as under Win10. :slight_smile:

1 Like

@Simon_Pratt @Atul_Ingle the codec does not support mic input on the headphone jack on linux.

Do you mean driver? Codecs have nothing to do with the hardware itself. It’s just about what algorithm is used to convert raw audio into a more compact form.

@Simon_Pratt @Kieran_Levin I was able to get my mic input to work:

1 Like

@Atul_Ingle Thank you so much! I’ve added your extra step to the setup instructions.

After enabling the deep sleep my trackpad is not working after wakeup. I have updated the grub settings given in the above post. After laptop is wake up then mouse is not working. I had to restart laptop to make mouse working again.

I am using Ubuntu 21.04 with kernel version 5.11.0-34-generic,

Appreciate some help on this issue.


Hi All,
Just an update from my side. Today all my Win10 Pro Laptops got new Windows10 updates.
And WiFi performance immediately increased to the maximum available via my ISP data plan:

I have the same stats under all my Win10 laptops, regardless of AX201( used by HP Omen) or AX210 used by Frame.Work! I don’t know if it’s Windows update that improves WiFi performance or Windows has also downloaded a better( newer???) WiFi driver from Intel.
Initially after the shock I thought that my provider has improved something. So I have rebooted to Ubuntu 21.04. Unfortunately, under Ubuntu the performance is the same as it used to be. So now Ubuntu download speed is 2 times slower than under the recent version of Win10 Pro. :sob:


@Kesav_Kumar_Kolla turning off PS2 emulation in the BIOS helps with this issue you are facing.

Hello all, Just got my framework up and running. Had some difficulties with Ubuntu version at first but now on 21.04. Does anyone know fix for speed issues. getting less than 1MB/s up and down. Its a device issue not my network. There is some image quality issues, but that may get resolved with this.

Edit – disabled power saver wifi mode, and got up to 20, but should be close to 100mb/s

Edit 2 – tried upgrading kernel to 5.12, but it failed. Failed to boot, so had to select version of 5.11. Used this guide: Linux Kernel 5.12 Released! How to Install it in Ubuntu | UbuntuHandbook

@Orrin_Frazier If this is a diy version I would double check if the WiFi module antenna wires are properly connected.

@Orrin_Frazier did you try installing the latest Intel firmware WiFi driver? (See the “Install the latest WiFi driver” section in the first post in this topic).

@Atul_Ingle They are per the Wifi module install, and I am getting semi-decent speeds, so its not disconnected. Cap is over module.

@Andrew_Wilcox Yeah newest drivers installed per that post.

Thanks for the help guys

IDK if this helps anyone, but if you’re comfortable manually loading drivers in linux, you don’t have to reboot to pick this up once it’s copied into /lib/firmware.

  • Download the firmware
  • Put the firmware in /lib/firmware, and verify the checksum
  • Disable wifi in NetworkManager (or whatever connection manager you’re using)
  • open a shell and run:
    sudo modprobe -r iwlwifi && sudo modprobe iwlwifi

This should prompt you for your password in order to unload/load the proper iwlwifi firmware. I’ve just done this on my framework and it was successful.

After this, if you want to verify,

  • sudo lshw -C network

and double-check the version that the wifi adapter shows as loaded.


For me, I lose all my trackpad settings when waking from sleep.

  • cursor speed changed
  • tap to click is enabled (I disable it, because I can’t stand that feature on any touchpad as I always accidentally activate it… like my hands are super capacitive or something)
  • I can’t scroll with the touchpad in any direction

A reboot fixes the touchpad, but I’d prefer not to have to do that :slight_smile:


I just had this issue as well. It took having to reboot and/or turn off and turn on the laptop for the settings to save and for the changes in the Mouse and trackpads settings menu to take effect.

@NullVoxPopuli The touchpad seems extremely sensitive, which, depending on preferences, can be a good or a bad thing. Since I also don’t like t2c on, I agree it does hinder me.