Ubuntu 21.04 on the Framework Laptop

@NullVoxPopuli This is the exact same issue I had when deep sleep was enabled.

Do you have it enabled, or not?


cat /sys/power/mem_sleep
#  [s2idle] deep

That output says you don’t have deep sleep enabled. The part in the brackets is the enabled sleep mode, s2idle.

@NullVoxPopuli Oh hmm… No, that’s just standard S2. If deep were enabled, there’d be brackets around it like:


I wonder if there was a weird, unrelated bug causing this and it’s now fixed. I’ll re-enable deep sleep and report back (the issue went away completely for me when I reverted back to S2, and it’s been consistently fixed for two months or so).

I’ll definitely appreciate the battery life :slight_smile:

I initially installed Kubuntu 21.04, just to try it out, but I knew 21.10 was coming soon, which I assumed would have better compatibility. I upgraded today and the experience has not been good. I’m wondering if anyone has any experience or tips here.

I get significant jank, in both the trackpad freezing momentarily every little while, as well as significant graphical artifacting while scrolling or switching apps. I am wondering if this is a Wayland issue, I got the sense (but never checked) that Kubuntu 21.04 was still using XOrg.

1 Like

My installation of 21.04 allows you choose between Wayland and xorg, at startup / login.


There is a discussion in this thread here with an updated fix.

Edit: Probably helpful if I include the link:

Thank you for your help with these steps and links. I was able to get through it with your help, except installation fails. It keeps telling me I don’t have sufficient disk space, it’s like it can only see the flash drive and not my hard drive. I’ve opened the laptop back up and removed and reinserted the SSD several times and it doesn’t help. This is the SSD I got from framework, the WD_BLACK SN750 NVMe. Not sure what to do from this point. I’ve ordered a usb adapter so that I can test the drive to see if there is anything wrong with it. I’ve also contacted framework support. Anyone else have ideas?

Does the BIOS show the SDD? (i.e. is it a linux problem or a hardware problem)?

@Carlos_Fernandez_San where in the BIOS would I find the HD? I’m looking through and I don’t see anything that says 500 gb or refers to Western Digital or anything. But I’m not sure if I’m looking in the right place.

Oh, the “Set Storage Password” line I don’t have in my BIOS. I think the HD is not detected.

@Carlos_Fernandez_San no the SSD wasn’t good. I got a new one and it works fine. I’ll return the bad one to framework hopefully.

I did a fresh install of Ubuntu 21.10. You still need to upgrade the wifi and turn off the power saver for WiFi to get decent speed. Battery life is still disappointing.

Disable power saving for WiFi:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
change wifi.powersave to 2

I don’t see any difference in speed with that power save change.
(just tried, hoping it would fix my Wifi 6E not working correctly on kernel 5.12)

I went from 7mb/s to 30mb/s (expected speed) on download, but still slow on upload.
I’m using kernal 5.13.0-20-generic.
I’m assuming you rebooted?

I am using the default iwlwifi driver and upgraded to 5.13.0-20. My wifi.powersave is currently set to 3.

My speedtest results are currently showing 210Mb/432Mb.

I still can’t get deep sleep working right. I’d say around… half the time, upon resume, it just flat out won’t work. I can log into the desktop but nothing will launch, I can’t switch TTYs, systemd complains about read only disks, and I have to hard power it off (no terminal to issue a poweroff command).

I’m quite well settled on Ubuntu at this point in my life, but I wonder… is this a distro issue, or is this some weird firmware bug that doesn’t like my SSD?

I was having disk I/O issues with deep sleep as well and I think there may be some merit to the idea that it’s an SSD firmware issue.

I’m running Arch with kernel 5.14.15 with luks+btrfs for / and /home. Whenever I tried enabling deep sleep with the mem_sleep_default=deep kernel option, I would be unable to log in or do anything on a tty after wake. Each time, btrfs would be throwing errors and get automatically remounted read-only. The only way out of it was a hard shutdown.

I decided to order a new Samsung 980 Pro gen 4 SSD to replace the Sabrent Rocket 1TB gen 3 SSD I had in the machine. I cloned my system from the Sabrent to the Samsung, and after booting to the new drive and enabling deep sleep, I’m no longer having issues. It comes back from sleep just fine.

I guess I’ll be using this new Samsung drive as my main one moving forward, but I’ll keep the copy of my system on the old Sabrent one until I can get it into a Windows machine to update the drive’s firmware to see if that allows it to enter deep sleep properly.

1 Like

I ran into this as well with a Firecuda 520 - it tested just fine via Seagate’s tool on another machine (and has been happily storing my PS5 games) but swapping for the WD Black Gen3 fixed all of my deep sleep filesystem issues.

Diagnosing it further, booting from a USB drive and running a quick deep sleep cycle would show the drive just drop off the bus entirely - I couldn’t figure out beyond that but it seemed to be some odd interplay between everything.


Has anyone gotten an eGPU to work with 21.04? I have almost everything working just fine in 21.04, but I just got a used Sonnets Breakaway Box and tossed a spare 1060 in there. The box shows up in dmesg and I installed the nvidia driver, but nothing seems to be working beyond that. Anyone get something similar up and running? I don’t have a windows machine with TB to test it out on right now.

I also have a Firecuda 520 in my machine. That seems like a plausible root cause.

Unfortunately, I’m far beyond my return window and don’t have a suitable replacement to pop in there. Might have to just stick with shutting the system off entirely instead of sleep.

1 Like