Ubuntu 21.04 on the Framework Laptop

Hello, everyone! Can somebody sum up what needs to be done in order for WiFi to work?

It’s currently unusable for me, with download speeds like 1.6 Mbps - this is when the speed test even loads (most of the time it doesn’t).

Check your cable connections. A visit to www.speedtest.net on my Framework, from the second floor of my home which is more than 50 feet from the Wifi 6 base station, gives me 670 Mbps download (on a 1 Gbps external connection). Further, an iperf3 test on the local lan to my home server provides 748 Mbps on a local 1 Gbps connection.

It’s you, not the laptop. Check and recheck connections.

I haven’t installed any secondary wifi drivers. Stock Ubuntu.

Do you mean the two cables that go to the WiFi card may be loose? I tried double-checking them but they seem to be connected quite well. Not sure what else to check.

Wait, you have working Wi-Fi 6? And no disconnects ever?
What exact kernel version are you running?

It’s running Ubuntu 21.10 with

Hi! With the new (non-Realtec) codec, the

options snd-hda-intel model=dell-headset-multi 

line doesn’t seem to work to get the mic on a TRRS headset working. This is kind of a showstopper for me, since I need to be able to do Zoom calls (with exacting audio-quality requirements, e.g., for performances) on my laptop. (I mean, I could buy a USB headset, but I’d rather not have to since I already have headsets I like.)

Anybody know how to fix this? cat /proc/asound/card0/codec* | grep Codec says those of us with newer Frameworks have an “IDT 92HD95” codec, and I poked around the kernel audio docs, which is where a previous poster found the solution for Realtec codecs, and I found a card with “92HD95” in its name but no relevant options.

In the “Input Devices” tab of the Xubuntu mixer, I see “Internal Microphone” (which works when I have it switched on) and “Microphone (unplugged)” which always shows as unplugged despite having a TRRS headset plugged in. I can select it, but I’m still getting audio from the internal microphone, not the headset

1 Like

I wanted to report that I am also experiencing intermittent trackpad/touchpad issues on resume from sleep in Ubuntu 21.04, regardless of deep sleep being on. I can usually resolve the issue but putting the laptop back to sleep (e.g. closing the lid) and bringing it up again. I can’t discern from this thread if the cause of this issue has been identified… I think not?

It has been identified. Either disable PS2 emulation in the BIOS, or apply the i2c_hid unload/load workaround on suspend/resume.

You could do the latter using this thing I wrote or do it yourself. If you opt for disabling PS2 emulation, you’d lose any touchpad functionality in OSes which do not understand HID. That may not be an issue if you’re already setup and won’t be using/installing non-Ununtu.

The cause is the BIOS being unable to activate HID within some allotted time during resume and activating PS2 emulation mode instead. It was mentioned in the BIOS 3.06 thread. Personally, I have the workaround installed even though I have PS2 emulation disabled.

I just succeeded installing Ubuntu Studio 21.04 (based on Kubuntu) from a USB stick.

The install failed until I disabled “Enforce Secure Boot” in the UEFI (new type of BIOS). I made that change on a wild lucky guess. I had different UEFI secure boot issues when I installed Ubuntu 21.10 on a Lenovo Ideapad 1, and made somewhat different changes.

If someone could post (or link to) good general instructions on setting up UEFI on the Framework, that would be very helpful. Haven’t found any so far, and I find current UEFI interfaces complex and unclear.

What is the best keyboard to select when configuring Ubuntu (and presumably other OS) on Framework? I’m going with “Generic 101-key PC” for now, but the actual keyboard has only 78 keys, so I may have set up a future problem. The blog entry (The Keyboard) mentions “Lite-On” as the manufacturer, but that’s not an option listed in the Ubuntu (Ubuntu Studio, derived from Kubuntu with KDE Plasma) configuration.

I’m also having this issue with a batch 5 laptop and and have yet to find a workaround. I think that it might be able to be solved with reassigning pins using hdajackretask but I have yet to be able to get it working.

1 Like

I just saw the notice from Ubuntu that 21.04 will not be supported after January 20. I would welcome any observations regarding how and when best to move on, presumably to 21.10.

1 Like

I noticed that my new 21.04 installation defaulted to X11 with no Wayland installation. I added Wayland, and had some problems, so I reverted. If anyone knows how the X11 vs. Wayland question should affect 21.04 and the update to 21.10, please post.

21.10 with this exact kernel: 5.14.21-051421-generic

Works perfectly (Wi-fi 6, bluetooth, etc)

I have ignored the prompts to update 21.04 to 21.10.
My system is working for me, and I don’t want it to break.
With the report above, how do you choose which kernel will be installed or used?

Well, if it’s working :slight_smile:
I’ve been tinkering a lot because it wasn’t working well, now that it is I might chill.

In any case, you can install the new kernel and check it out.

You can fetch it here:

Download all the files from the amd64 block that DON’T have lowlatency in the name. Move them to an empty folder and from it run:

dpkg -i *.deb

Which will do the actually install.

Then reboot, and from the grub menu select the new kernel.
If everything works, then you can make it the default.

Thank you for the information.
Linux does allow a wealth of choice, but also a world of hurt, if you don’t have the familiarity with the choices.

The information is available, but finding it is not always easy.

Can anything be done to the grub menu to make the text bigger?

The font size is miniscule on my system.

It’s not the most intuitive process, but I did it with mine using steps similar to what’s here:

1 Like

Thank you, eyes are older everyday.

An easier if less pretty way (vs. generating a larger grub font as described at Viet’s Blog is just to change the screen resolution in grub. I added


in /etc/default/grub and re-ran update-grub, which got me adequately large text for my eyes.

(info -f grub -n 'Simple configuration' told me that “Supported modes can be listed by ‘videoinfo’ command in GRUB,” but if I’m remembering correctly the first one I tried didn’t work and seemed to be ignored.)