Ubuntu 21.10 on the Framework Laptop

MAJOR: One line fix in your grub file.

You can leave the kernel, you can leave secure boot and you can leave ps/2 enabled.

Same, see above link, fixed as well.

No idea about HDMI audio or zoom quality.

I hope this helps you out.


Just reporting my experience with Ubuntu 21.10 - clean install (batch 4 DIY, 32gB, TN850 WD Black, latest 3.07 BIOS/SSD firmware, 5.13.0-25-generic kernel after upgrades).

  • I am using a plain GNOME desktop (installed via the vanilla-gnome-session package, then login choosing “GNOME” in the bottom right corner (gear) of login screen. This is closer to the Debian desktop I am used to.
  • Fingerprint reader just works
  • Deep sleep is already enabled by default (no GRUP editing needed)
  • No mouse lag after i915.enable_psr fix in GRUB
  • No trackpad problems - edit right click is not configured by default, fix in GNOME tweaks.
  • Good HiDPI default settings, I’ve adjusted scaling on external monitor and fonts (with Tweaks).
  • < 24h battery drain in suspend, I haven’t tackled this
  • No issues with Wifi/BT, but I am using an older card which I knew worked (Intel Dual Band Wireless-AC 3168NGW)
1 Like

I just updated from 21.04 to 21.10 with no problem detected.

I am running Ubuntu Studio, which is based on Kubuntu, so I have KDE Plasma instead of Gnome and Xorg instead of Wayland. Kernel is 5.13.0-23-lowlatency (the studio functions prefer lowlatency). I do not use Bluetooth nor the fingerprint reader, and I haven’t tested sound yet. Touchpad response is totally good so far.

What kernel are you using?

I’m enjoying 21.10 on my Batch 6 DIY, but I have a question that, hopefully, this group can answer. Bluetooth is working well. I have a Bluetooth trackball that works great, and a Sonos Move speaker that also working like a champ. When I try to use my Sony WF-1000XM3 ear buds, they connect via Bluetooth but aren’t recognized as an audio device. Is there a library or something that I’m missing? How can I figure that out?

What kernel are you using @Dave_Olson? I think there’s a regression in kernel 5.13 for Bluetooth

Thanks for the reply.

I’m on 5.13.0-23 generic. That’s a recent update from 5.13.0-22 generic. I’m not seeing the Bluetooth controller failing to start from a warm boot bug described in the thread you linked. Both wifi and Bluetooth are working well with my AX210. It’s leading me to think that my problem is more likely a missing codec or library or something like that, but I’m a complete novice with Ubuntu Bluetooth audio.

1 Like

I’ve turned the first post into a wiki post. Feel free to add issues and workarounds directly there.

Also, somewhat unexpectedly, the fingerprint reader does seem to work in Ubuntu 21.10 after updating all packages.

Has anyone successfully upgraded the 21.10 install to another kernel? When I try to do this, I get the following error on reboot:
Error: can’t find command ‘hwmatch’
Error: file /boot/vmlinuz-5.15.6-051506-generic has invalid signature
I’ve tried both 5.15.6 and 5.14.21, signatures verified.
I know some people have these kernels installed, but I believe they were installed in 21.04 and then upgraded to 21.10.
Note: I had this problem with a previous 21.10 install. I wanted to repartition anyway, so I repartitioned and then reinstalled. I originally thought it was an issue with the boot sector but apparently not – or at least rewriting the boot sector didn’t fix it.

The problem was with secure boot; disabling it boots fine. Now to figure out how to upgrade the kernel with secure boot enabled.

One could sign the new kernel modules as described here.

However, shouldn’t the kernel modules already be signed by Canonical?

I can’t comment on the published article because it won’t let me login through google. Can this be fixed? It doesn’t recognize my login otherwise.

I saw someone here has already mentioned it here but since it hasn’t been added to the main article and it could affect the experience of future novice Linux users here’s the comment I wanted to add:
As a Linux novice, I had a bit of trouble following Step 4 as it’s missing details that would have saved me some hours. I tried #sudo edit /etc/default/grub# but that didn’t give the same workable window as pictured and the keys were not typing normally. I do think this needs specified to enter the commands #sudo nano /etc/default/grub# to make any changes and save it under a new name as grub2 (I assume based on the statement “Then as root run ‘update-grub2’” that it wanted me to change the name to grub2) then #sudo update-grub2# before #sudo reboot#.
Thanks for putting this article up, it was really helpful.

I gave Ubuntu 21.10 a shot over the weekend and it was a fairly painless setup, but ended up going back to Windows 11. My issues were mostly with Wayland/Xorg being weird with display scaling. VS Code under Wayland was blurry due to some older version of Electron. Xorg had some screen tearing issues. I also had some issues with video decode in web browsers not using the GPU. Youtube would use AV1 on Chrome for example. Firefox I could get VP9.

There are likely workarounds for all of that I just couldn’t be bothered to find them at the time.

Oh yes, I don’t use secure boot. I think that’s one of those things meant for the Microsoft people …

This is probably a Ubuntu 21.10 issue but I’m having trouble with my 3.5mm audio mic/track control button not working with my batch 6 laptop even though I’ve checked after reboot to make sure that the “options snd-hda-intel model=dell-headset-multi” was saved to the end of the “/etc/modprobe.d/alas-base.conf” file.

The control button on these earbuds works fine on other devices. It plays audio fine when connected to the laptop and I can use the keyboard to control the sound but it would be nice to mute the mic without disconnecting it (especially since the in-line mic still picks up sound even though the mic hardware toggle on my laptop is turned off). Any advice?

@M_Mothersole I suspect the mic in your headset isn’t even working. If you go to Settings/Sound, then click the dropdown arrow for Input, do you see anything other than Internal Microphone - Built-in Audio?

If you check the Output dropdown, you will see it lists both the build-in audio and your headset. The absense from the Input dropdown means it isn’t being recognized.

I have this problem because my headphones have a 92HD95 Tempo Semiconductor device, not the dell compatible type. I haven’t found or seen a fix for it yet.

I may be wrong on all that… seems like the switch should be turning the built-in mic off in that case.

@Gary_Aitken I can’t find what kind of semiconductor my headphones have but it’s not a Dell. But when the headphones are plugged in it changes from “Internal Microphone - Built-in Audio” to just “Microphone - Built-in Audio” and while the laptop hardware mic switch off I do still see the mic detecting my voice (I thought it dampered it at first but it’s the same and I checked the mic and button on another laptop and it works as intended). When the headphones aren’t plugged in, the hardware mic mutes the internal mic just fine. I guess it just picks it up in the external mic but I was a bit surprised by that.

Also although it changes from “Internal Microphone” to the external “Microphone” and back when I put in and remove the headphones as it should, it doesn’t give me a drop down option to switch between the internal and external mic. Nor does the output even though it recognizes it as an external “Headphones - Built-in Audio”.

For me, this problem was solved when I upgraded from 21.04 to 21.10; the mic in my TRRS headset just started working. (I don’t have a mute button on my headset, but the microphone boom rotates up out of the way and electrically disconnects when it does so.)

@Jay_Sekora Thanks, mine appears to be working too.

@M_Mothersole My mistake – when I plug in my headphones, the audio source and output both change, but the dropdown doesn’t work for either. I don’t know if that’s a bug or not; seems like it’s a bug. If the mic hardware switch at the top of the display doesn’t mute the mic when no headset is plugged in, I would say the switch isn’t functioning properly and you probably should contact framework support.

@Gary_Aitken Thanks btw for your input on this. Yeah, I think the dropdown menu might be a bug. So for the external mic being picked up when the hardware mic toggle is muted (when the mic tab on the display toggled to show the window in red), I don’t think it’s a hardware issue since the hardware toggle does mute the internal computer mic as it should. It’s just when an external headset with mic is connected, I guess it bypasses the hardware mute toggle?

I figure the headset button just needs to be enabled, it’s a standard headset/mic device which should be programmable… I just have no idea how to do it on Ubuntu 21.10. The headset manufacturer’s site doesn’t give a lot of details but the specs matches with this: 3.5毫米耳機:附件規格  |  Android Open Source Project
The multifunctional button should be programmable if the jack meets the specifications described here, which I suspect it does:
Giắc cắm tai nghe 3,5 mm: Đặc điểm kỹ thuật của thiết bị  |  Android Open Source Project