Ubuntu 21.10 on the Framework Laptop

Oh yes, I don’t use secure boot. I think that’s one of those things meant for the Microsoft people …

This is probably a Ubuntu 21.10 issue but I’m having trouble with my 3.5mm audio mic/track control button not working with my batch 6 laptop even though I’ve checked after reboot to make sure that the “options snd-hda-intel model=dell-headset-multi” was saved to the end of the “/etc/modprobe.d/alas-base.conf” file.

The control button on these earbuds works fine on other devices. It plays audio fine when connected to the laptop and I can use the keyboard to control the sound but it would be nice to mute the mic without disconnecting it (especially since the in-line mic still picks up sound even though the mic hardware toggle on my laptop is turned off). Any advice?

@M_Mothersole I suspect the mic in your headset isn’t even working. If you go to Settings/Sound, then click the dropdown arrow for Input, do you see anything other than Internal Microphone - Built-in Audio?

If you check the Output dropdown, you will see it lists both the build-in audio and your headset. The absense from the Input dropdown means it isn’t being recognized.

I have this problem because my headphones have a 92HD95 Tempo Semiconductor device, not the dell compatible type. I haven’t found or seen a fix for it yet.

I may be wrong on all that… seems like the switch should be turning the built-in mic off in that case.

@Gary_Aitken I can’t find what kind of semiconductor my headphones have but it’s not a Dell. But when the headphones are plugged in it changes from “Internal Microphone - Built-in Audio” to just “Microphone - Built-in Audio” and while the laptop hardware mic switch off I do still see the mic detecting my voice (I thought it dampered it at first but it’s the same and I checked the mic and button on another laptop and it works as intended). When the headphones aren’t plugged in, the hardware mic mutes the internal mic just fine. I guess it just picks it up in the external mic but I was a bit surprised by that.

Also although it changes from “Internal Microphone” to the external “Microphone” and back when I put in and remove the headphones as it should, it doesn’t give me a drop down option to switch between the internal and external mic. Nor does the output even though it recognizes it as an external “Headphones - Built-in Audio”.

For me, this problem was solved when I upgraded from 21.04 to 21.10; the mic in my TRRS headset just started working. (I don’t have a mute button on my headset, but the microphone boom rotates up out of the way and electrically disconnects when it does so.)

@Jay_Sekora Thanks, mine appears to be working too.

@M_Mothersole My mistake – when I plug in my headphones, the audio source and output both change, but the dropdown doesn’t work for either. I don’t know if that’s a bug or not; seems like it’s a bug. If the mic hardware switch at the top of the display doesn’t mute the mic when no headset is plugged in, I would say the switch isn’t functioning properly and you probably should contact framework support.

@Gary_Aitken Thanks btw for your input on this. Yeah, I think the dropdown menu might be a bug. So for the external mic being picked up when the hardware mic toggle is muted (when the mic tab on the display toggled to show the window in red), I don’t think it’s a hardware issue since the hardware toggle does mute the internal computer mic as it should. It’s just when an external headset with mic is connected, I guess it bypasses the hardware mute toggle?

I figure the headset button just needs to be enabled, it’s a standard headset/mic device which should be programmable… I just have no idea how to do it on Ubuntu 21.10. The headset manufacturer’s site doesn’t give a lot of details but the specs matches with this: 3.5毫米耳機:附件規格  |  Android Open Source Project
The multifunctional button should be programmable if the jack meets the specifications described here, which I suspect it does:
Giắc cắm tai nghe 3,5 mm: Đặc điểm kỹ thuật của thiết bị  |  Android Open Source Project

Fingerprint reader works for unlocking the desktop, however to authenticate for sudo, for software install/update etc it still requests password. On Fedora 35, you can use fpr for those things too.
Is there any way to replicate this behavior from Fedora on Ubuntu?

Has anyone recently started getting frequent logouts (>2-3 times per day)? Since late last week or Monday I’ve been getting logged out (computer does not restart, but I get booted back to the login screen and everything I had open is gone) several times a day. One or two times it locked up entirely. I’ve had 21.10 installed since December and it was working great prior to this, so my guess is maybe an update broke things? Hoping someone else has some clues

On Debian it was a matter of running sudo pam-auth-update --enable fprintd.


Thanks @Brett_Kosinski your suggestion works on Ubuntu 21.10 too:
sudo pam-auth-update --enable fprintd

5.13.0-25-generic at the moment.

1 Like

Got 21.10 setup after running almost perfectly on 21.04 until support ran out. Things seemed fine to start off minus the trackpad (thanks for the tip above) but now my bluetooth headset will connect but immediately disconnect. Any ideas of how to sort that out? I think it has something to do with the switch in audio systems, but I am not sure.

Oh and I am running 5.15 because I thought that might fix it.

For the Linux beginners and the visual learners.


The visual tutorial especially to set up the hibernation is really great. I assume you took time and practiced the steps to record this videos. The video is helpful for Ubuntu users to improve their user experience.

I’m sorry if I missed something, but how does one edit the file to change that line?

@Raph try the following:
sudo nano /etc/default/grub
Explanation (if needed):
sudo means the command will be executed with root privileges (so you might be prompted for a password) and nano is the command line text editor I find the most beginner friendly.


I received the laptop last week, and finally got around installing Ubuntu 20.10.

The first thing I noticed after the installation was the stuttering of the system/trackpad. It didn’t really feel like the problem was the trackpad though, because the performance monitor would freeze as well.

I then left he machine be for a couple of days, and started using it again today. I set it up so that I could work on it, and I used it for the whole afternoon,without any issue. It was so smooth that to be honest I even forgot about the stuttering altogether.
I was working with an external monitor connected via USB-C (HDMI on the other side, though, so no USB-C-to-USB-C connection) and and a USB-A hub for mouse and keyboard.

Here is where the fun starts: my battery reached 10%, so I disconnected the external monitor and plugged in the charger. Lo and behold, the stuttering is back. And it is clearly not the trackpad, as he interface freezes when using my external mouse.

I tried some combinations:

  • No charge, and no external screen > It still stutters, but possibly less than before
  • No charge, and back with the external monitor > It appears to be as smooth as it was the whole afternoon

Conclusion: the machine works better if I am not charging and/or if I am using the external monitor.

I have now just changed the psr setting in grub (by the way, I am not sure what psr stands for, but I assume it has to do with power management). I will reboot, and keep testing tomorrow. I thought I would write this down before I forget or get too lazy (very likely if the grub change fixes the issue :stuck_out_tongue: )


Have you tried disabling PSR? That may help with the stuttering you are experiencing.

This is how to disable PSR

1 Like

Yes I did, and it works perfectly now. :slight_smile: