Ubuntu 22.04 on the Framework Laptop 13


The installation guide is available here: Ubuntu 22.04 LTS Installation on the Framework Laptop 13 - Framework Guides


22.04 pretty much works out of the box. You can improve suspend battery life by following: [TRACKING] Linux battery life tuning - #156 by technical27


Ubuntu 22.04 LTS Released: Ubuntu 22.04 LTS (Jammy Jellyfish)
Release Note: Jammy Jellyfish Release Notes - Release - Ubuntu Community Hub

See also


Hibernation doesn’t work out of the box for MOST Linux distributions. However you can enable it but I wouldn’t really call it a trivial process either, especially if you are using LUKS (disk encryption).

You may find this thread interesting regarding hibernation and Linux:



Aligning other threads on the Linux category, I renamed the thread title “Ubuntu 22.04 (Jammy Jellyfish) Seems OK” to “Ubuntu 22.04 on the Framework Laptop”. People can also find this thread by searching the content with the version code name “jammy”. I also changed the category “discuss” to “Linux”.


I’m using LUKS and would like to dive in. Is it really possible to have an encrypted swap partition or a swapfile to store hibernation state? For me unencrypted memory dump is not an option.

I do understand that it would not be able to quickly restore without unlocking LUKS first.

@Korvin - I’m running Pop!_OS with an encrypted swap partition and hibernation. It was a bit of work to set up, but has been working well. I do need to enter my encryption password upon resume from hibernation.


Evening all, first post here. My new Framework laptop is due to arrive in the next week, and I’m considering what OS to install. Has anyone got a recent update for how the current build of Ubuntu 22.04 is performing? Any workarounds required (other than the existing ones for 21.10)?

Hi, @Phillip_Elvey everything seems to be working out of the box with 22.04 and I assume you’re gonna receive the laptop with 3.07 BIOS so there’s only the power drain when sleep issue that does not hurt too much.

1 Like

just a note that I am tracking some stuff on fan control - this fork of ectool is working well, but I hestitate to recommend to non developers.
Note this also gives some pretty good low level access into other things like charge capacities and led control

@Mike_Prorock are you building yourself a tool to react to temperature changes from sensors and applying a set fan percentage? Or can the ectool apply some form of automatic fan curve?

Ubuntu 22.04 LTS is currently available as an upgrade but not yet released.
It works out of the box once upgrade is complete.

*** Proceed at your own risk as this is pre-release ***
I will update this post once the release is officially out.

I have noticed significant battery and HW support improvements, especially on Panel Self Refresh (PSR) support


You can follow the guide to get a base 20.04 install (or 21.x), then run:

$ do-release-upgrade -d

NB: I would recommend doing the do-release-upgrade from a console directly so you do not loose graphics - if you run it from gnome terminal or an xterm and your user interface disappears open a VT via ctrl+alt+F3, then run:

$ sudo -i         # interactive sudo as root
$ screen -ls    # dumps screen session list, you will see the release upgrade session
$ screen -d -r [SESSION_FROM_ABOVE]  # will reconnect you to the upgrade process 


:white_check_mark: Wifi works
:white_check_mark: Bluetooth works
:white_check_mark: Fingerprint Scanner works (see hw issue with old fingerprint scans fixed here )
:white_check_mark: PSR works
:white_check_mark: Deep Sleep works
:white_check_mark: Sensors works (lm-sensors for cpu and board temps)
:ballot_box_with_check: Headset works with the following command after setup:

$ echo "options snd-hda-intel model=dell-headset-multi" | sudo tee -a /etc/modprobe.d/alsa-base.conf


Still no great insight to fan speeds. i8kutils and similar chipset utils related to dell do NOT work with the fans on this board.

nbfc-linux appears to work with config LENOVO 20U9S19X00 but is lying - it will report the same fan speed consistently regardless of throttling and targets speeds are ignored

Outstanding Issues

  • Still seeing relatively high interrupt counts on idma64.2 and tick_sched_timer - the latter is not likely an issue and is probably tied to cpu frequency scaling. The former appears to be touchpad related, but I am not 100% on this yet, that may be a red herring


Running powertop --auto-tune on boot via rc.local or similar really helps with battery life - In my case (i7-1165G7 with 32GB Ram) I went from 5-6hrs of battery life on 20.04 to 8-10hrs on 22.04 and base powertop auto-tune applied. Normal usage for me is a reasonable amount of programming, and a lot of time in gmail / doc editing - not much media usage. Still seeing some drain during web conference calls, esp on teams but I believe that is browser related

some kernel flags to experiment with

  • nvme.noacpi=1 sets some better ssd behavior for sleep and power states
  • i915.enable_psr=1 will force PSR on
  • mem_sleep_default=deep explicitly states what sleep mode you want
  • intel_pstate=disable turns off processor level p-states and will let you more comfortably scale cpu freq to ~400mHz or so
  • acpi_enforce_resources=lax lightens up a few things to get better access under the hood - do NOT do this unless you know what you are doing

@RandomUser added some notes to clarify - thanks for the questions

Sounds really exciting. Thanks for trying it and letting everyone know. Might jump on it as well in the next few weeks.

I experienced around 5-6 hours without any tuning on a mixed workload. Some writing, some compiling. Same as Mike.

I do still experience some major issues with the AX210 wifi card though, I had to disable the ax spec and now run it with just ac. That at least is working just fine.

Do you have the vPro Wi-Fi module? I am running the no vPro card and have had no observed issues with the Wi-Fi on 22.04. Any kind of insight or how you may have disabled the ax spec would be great for others if they are having the issues you ran into.

The non-Pro version. I observed frequent disconnects especially after a warm startup. I checked on my AP and it was using the full spectrum of AX features which is good aside from the disconnects.
There is a whole thread discussing the issues with the adapter on the forums and on the red hat but tracker but the specific workaround was this one [SOLVED] Using the AX210 with Linux on the Framework Laptop - #92 by Andrew_Marshall

I will try to occasionally enable the feature but for now I am fine with disabling ax.

Seeing some errors related to this on mine as well - nothing causing actual problems such as disconnects, just cluttering syslog for me. Also non-vPro module.

For fans, using the latest EC Tool works, for example

Set Fan to 40%:

$ ectool --interface=fwk fanduty 40

Set fan back to auto:

$ ectool --interface=fwk autofanctrl

Hopefully this makes it back upstream over time
Don’t necessarilly recommend non developers to tinker too much with ectool as you can do some damage unintentionally

Alright. Got it. Would be a good option to have some form of fan curve control in bios but that works too.

Ok have installed the lasted ISO of Ubuntu 22.04, posted on the weekend! So far installation was very smooth (very fast!). Now I’ve been using Ubuntu for a long-time, but I wouldn’t call myself a power user at all. Still need help with lots of things. Since install on Saturday I haven’t done a thing and everything basic is simply working (incl WiFi). However I will do a few of the essential tweaks (headset port, deep sleep & powertop). If I need help will try to find existing answers, but if stuck I may come back here for a few pointers…! :slight_smile:

OK first two above done fine, but with Powertop the output of “sudo powertop --auto-tune” leaves me unsure if it’s done anything. See below - does this look correct, or is something wrong?

modprobe cpufreq_stats failedLoaded 29 prior measurements
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask d
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask d
Devfreq not enabled
glob returned GLOB_ABORTED
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only
To show power estimates do 346 measurement(s) connected to battery only
Leaving PowerTOP