Ubuntu 22.10 Issues (does not boot with 5.19 kernel)

I just got my frame.work 12th gen with alder lake.
I switched over my ssd form my old machine which was running Ubuntu 22.04 and decided to upgrade to 22.10 because of the better support for the cpu…

After upgrading the display just got stuck at some boot messages “RP IO log size 0 is invalid”… tried rebooting, nothing worked.

I was able too boot using the previous 5.15.0 kernel from ubuntu 20.04… everytime I tried 5.19 (the new default) → it gets stuck again.

I finally was able to boot fine again by installing the 6.0.0 kernel ( https://9to5linux.com/how-to-install-linux-kernel-6-0-on-ubuntu-22-10 ) and thought to share with others who might have the same issue.

First thing: Before upgrading make sure to enable the grub boot menu.
Edit /etc/default/grub and make sure it contains the lines:


then save and run “sudo update-grub”, reboot once and make sure you can reach the boot menu (it wasnt enabled for me, so I had to do this using a live-cd and chroot…)

Then coninue upgrading:

After doing the release-upgrade DO NOT REBOOT, but install mainline and the 6.0 kernel first:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install -y mainline

then just run the “mainline” graphical utility and select/install the 6.0.0 kernel. Reboot and everything should work fine :slight_smile:

I didn’t have time to check if my dock and display work fine, but I will update you if everything is working…


Probably unrelated to the problem, it happens normally on both 11th gen and 12th gen and it still boots:

Wonder if your problem is related to the troublesome 5.19.12?

1 Like

@Fraoch Yea After doing research it really looks like this issue.

I did not want to extend that thread (since the issue is fixed with a 6.0 kernel), but instead wanted to provide a solution for other k/ubuntu users our there before the final release this month… since they announced to ship with a 5.19 kernel

1 Like

Looks like they are aware of the issue and will be releasing a fix for it: Bug #1991704 “Kinetic kernels 5.19.0-18/19-generic won't boot on...” : Bugs : linux package : Ubuntu

Only an issue with 5.19.0-18 & -19 apparently - works for me with 5.19.0-15 from the beta release for example.

I only came across this as well, as I just received mine today.

Took me a while to debug, and found that 6.0 mainline just worked, so stuck with it most of the day.

I found a new update this evening and now running 5.19.0-21-generic kernel without any problems, so should all work now :wink:


The new kernel they deployed today works fine again (5.19.0-21-generic)


Thanks a lot for sharing. I think the general rule of thumbs with intel 12th gen and Linux is : "If it works don t touch it " :smiley:
I have a Ubuntu mate 5.15 and it works OK. I have a freeze once in a week. I deactivated the E-cores.
Tried various kernels without any luck, tried iGPU fixes no luck too.

Hi @Iann_C,

You indicated it is freezing once per week. Is this random or does anything interesting show up in dmesg?