Ubuntu 23.10 on AMD 7040 Framework?

Anyone running Ubuntu 23.10 on the AMD Framework? How well does it work compared to other distros?

My motherboard upgrade should arrive tomorrow and I’m pondering which Ubuntu version to install.

1 Like

I have tried it, and it doesn’t boot to the login screen, and I am not the only one:


The 23.10 installer didn’t boot for me, just black screen. If you boot with “Safe Graphics” it does work. I think it has to do with an older kernel (6.5.0-9 vs 6.5.6 currently on Fedora 39). Will probably work in the future with BIOS update and / or if Ubuntu includes a newer kernel.

1 Like

Ubuntu 23.10 is working fine for me (well about as well as 22.04 LTS did). However to get to this point I first installed the 22.04 LTS and the 6.1.0-1023-oem kernel, then performed distribution upgrades to get to 23.10, except I’m still using the oem kernel.

The only major issue so far (besides needing to use the oem kernel) is no video when using a thunderbolt docking station, but that was a problem on 22.04 as well.

1 Like

I wonder then if 23.10 could be installed directly under safe graphics mode, then have the oem kernel installed.

I tried this method, you can install, but I couldn’t find a way to get the OEM kernel installed after. Even safe graphics mode failed to launch the installed OS.

This says oem kernel is only available on LTS.

1 Like

I also had the boot issue, but after updating the BIOS to 3.03, Ubuntu 23.10 with the 6.5.0 kernel works just perfectly! This includes the installer. I’m very happy with it!

1 Like

I’ve updated BIOS to 3.03 and was able to boot 23.10 from USB drive. Graphics didn’t seem as snappy as 22.04 which I currently have installed with 6.5 kernel, so I decided to stay on that for the time being.

But BIOS 3.03 definitely fixes the graphics issue with non-6.1 kernels

1 Like

I now do see white flashes (after not having seen those since the bios update in october) after the screen has been locked for a while. Logging-out and in makes them go away again.

Update: Until now all kernel updates gave me white flashing screen. I have to boot into the older 6.5.0-15-generic to not have the issue.