Undetected SSD while attempting Ubuntu LTS 20.04 instalation

Hi everyone,
I’m trying to install Ubuntu LTS 20.04 from a bootable USB drive but comming to the proper instalation it only detects the usb drive as /sda it doesn’t detect my WD_BLACK SN850.
I’ve tried several times to fit the SSD snug in it slot and it seems ok but doesn’t solve the issue.
When I run ubuntu live I cannot detect the SSD with G-Parted (partition editing software) either.
any hints as how to solve this?

Turn off Secure Boot. Also in the BIOS set “New Boot Device Priority” to either First or Last, not Auto.

I believe Auto sets the first device detected as the only boot device and may stop looking once it finds your USB. First/Last looks for all of them and sets the first one it detected as first (or the last if Last was selected) but should list them all at least.

After this you should be able to see it in the F12 boot device menu and if you can see it there, your OS should be able to see it.

I think you missunderstood.
I boot alright and I can start the installation process but I get stuck middle of it
See the picture:
G-parted detects both external USB drive but not my internal SN850

But is the SSD seen in the BIOS? See my comments about First/Last.

Also if Secure Boot is on, the installer may still run but it will be trying to install secure boot keys to a special EFI partition on the drive. If the drive has previously had an MBR, this new all-UEFI system without CSM may not even see the drive. If it can’t see the drive, it can’t create a GPT in order to create an EFI partition and the install will crash. Kind of a chicken-and-egg thing, it can’t see the drive to make modifications necessary for it to see the drive at all and install an OS on it.

It’s worth a try?

I get to access the boot manager but → no sign of my internal SSD

I don’t find the BIOS but the EFI doesn’t show sign of the internal SSD either

logically the same happens on the EFI boot order

and I don’t find any “secure boot” option

I did finally find the secure boot option and disabled it but problem remains
my SSD isn’t detected…

thanks for your help so far and for any new input…

Trying a different approach - can you see if Windows can access it and update the firmware while you’re at it?

Older SN850 firmware caused problems, including not being detected at boot. If Windows can see it, it’s an indication that there’s nothing wrong with the port or the drive, and you can get in and update the firmware at the same time.

Ok I will look it up though it could take me a few days. So no worries if I’m absent I’ll keep you posted when ever I get a chance to work on the subject

You should probably contact Support, they probably have better troubleshooting ideas than I do!

Problem solved : SSD wasn’t properly inserted.

That’s the SSD uncorrectly inserted


that’s how the SSD is now inserted and working.
hoping my two pictures might help someone in the future.


Glad you found the cause!

Very interesting. You would think the misalignment would prevent the securing screw on the left from going in straight and not crossthreading, but it looks to go in just fine.

There’s been a lot of reports on the forum lately of SSDs not being detected, I wonder how many of these are where this is the case.

You have to shove M.2s in quite firmly, maybe harder than one would expect.

1 Like

exactly I too thought the screw would prevent a faulty insertion but obviously it isn’t so !

1 Like