Boot Device not detected [Partialy Solved]

My new(!) FW16 won’t detect any (i tested 3 different) USB-A (Port 2 & 5) with my Kubuntu 24 LTS / Ubuntu 24 LTS. (i used the recommanded balenaEtcher)
Both USB and SD are detected but i cant boot via boot manager on the FW16.

Further Information:

  • I also tried the the Ubuntu startup disk creator but it creates the same ISO9600 partition.
  • Secure boot is disabled.
  • My old PC has no problem booting the ISO from the USB stick.
  • Picture of the ISO is shown below. The EFI is included.
  • I tried multiple USB-Sticks (fully erased them) and flashed them again.
  • I tried using a SD card (slot 3) but that didn’t work either.

Any suggestions ?

P.s.: Tails boots without problem, so at least the FW16 is booting a different live OS and has no obvious problems, but i still have no idea why (k)Ubuntu 24 LTS won’t boot. And i don’t really want to use as main OS :sweat_smile:

P.p.s.: I will try 22 LTS and upgrading from there, when i downloaded the ISOs in … 1d8h5m… (#Neuland)
→ UPDATE: kubuntu 22 LTS boots (only PORT 5; not PORT 2)
thx @lbkNhubert @Fraoch @Jorg_Mertin

P.p.s.: Apparently 10 replys on my own thread is to much on the first day … I will update my latest post.
“An error occurred: We appreciate your enthusiasm, keep it up! That said, for the safety of our community, you’ve reached the maximum number of replies a new user can create on their first day. Please wait 20 hours and you’ll be able to create more replies.”

1 Like

Make sure that secure boot is turned off in the bios.

its disabled. i checked again.
but thx for the suggestion.

SB DB: Installed & locked
SB State: Disabled
User Cstm. Sec. NO

Enforce SB: Disabled
Erase all SB Set.: Disabled
Restore SB Fac. Set: Disabled

Do you see the device in the BIOS? (USB Drive?)

Bummer that it wasn’t a simple thing. Assuming that the drives are uefi bootable, as opposed to legacy/bios (sorry, I don’t know what the official proper terminology is for that), then I’m at a loss. They should show up in the bios or when booting and spamming f-whatever (10. 11. or 12, again, I can’t recall.) Apologies that I am not more helpful, but I’ll be following this to see how you get it resolved. Best of luck.

yes. they all get detected.
to ensure that’s it not a problem with the USB i but TAILS on one and it bootetd.
so it should not be a problem with the USB,

are you also using he right boot device then?

i think may other PC is also using UEFI but i can’t check as im downloading …
but as of my knowlage balenaEtcher creates UESFI butable ones

the (k)ubuntu ones are not detected by the boot manager.
i only have one USB-A so there is no mistaking the usb devices.

or did i miss understand your question?

If they show up in tails then can you compare how the tails usb drive is setup up to the ones that are not working? Partition table, partition types, et cetera?

As ther is no OS on the SSDs it trys to boot the USB first anyway and brings me to the BIOS if that fails.

Is it booting as msdos legacy device, or as a EFI device? (That was my question).
It will make a difference.

1 Like

TAILS is doing stuff different to the balenaEtcher ones.

TAILS is limited to FAT8.
Flags: boot, hidden, legacy_boot, esp
But TAILS is a bit ‘wierd’ and has a persistance area included.

the balenaEtcher created iao9600 on the full size (e.g. 15 GB).
But as it works on my other PC. and is the recomeded why it shoud be fine?
i also checked that i used the correct amd64 version of (k)ubuntu

Tails shows up in the EFI boot order so i would gess EFI.
or do i have to check that some where else?

for (k)ubuntu vie balenaEtcher it does not show up in the boot order as it is not recognized.
i cant check how it boots on my other PC as it is done loading 22LTS (for the next 1d12h)

maybe i should try a different tool then balenaEtcher?
i will check if the ubuntu integrated tool does some thing different. → (Update) it creates the same patition table.

Looking at the directions it seems like that should work. If you want to try something else you might try ventoy: GitHub - ventoy/Ventoy: A new bootable USB solution.. It doesn’t work for all distros but it is handy for those that do work.

1 Like

As it works with my other PC i dont whink there is a problem with the iso9600 partition but i will try ventoy. (kubuntu & ubunutu are supported)

If you don’t have an EFI partition on some drive internal or attached to the system, then I don’t think that the USB if all it has is an iso9600 will be recognized, but I am not an expert in that area.

TAILS does not have an EFI partition (as far as I know), but boots.
so i could try installing (k)ubuntu on the SD card and than may be able to boot from the ISO9600? worth trying. But i will wait untill my download of 22 LTS is finished

otherwise i may have to try installing the OS on my old PC and than putting the SSD back in the FW16. (i like to avoid that as is had driver issues in the past doing exactly that with Ubuntu)

It looks like tails does not have a separate EFI partition but the main/only partition is also EFI:

So I suspect that the lack of that on your other USB drives is why they are not booting. I don’t know if they are not included by default in the distros that you are trying. Hopefully ventoy allows you to work around that. Otherwise you may need to create the efi partition on the usb manually, or someone smarter than I can give you better guidance on how to achieve your ends.

1 Like

i will try ventoy (didn’t) help, using my second usb-A with the tails stick (didn’t help), and installing ubuntu on the SD.
so thx so far (for now) @Jorg_Mertin @lbkNhubert @Fraoch
i will give an update as soon as i tryed the three ideas.

(i cant post more replies as a “new user” (on my own thread) so im stuck with editing this one…)

P.s. The kUbuntu iso includes the EFI, and uses the GPT.
The following images show the desired USB-A device with the kUbuntu 24 LTS flashed with balenaEtcher pluged into the FW16 from the Disk tool of Tails.

@Fraoch i tryed 3 diffrent USB and reformated (full erase before) the one shown above at least 4 times with kubuntu and ubuntu. and i have no problem booting on a diffrent PC.
SB, quick boot and quiet boot are all disabled

@lbkNhubert I just flashed a knew USB, it looks the same.
yes, the "possibly encrypted is wierd, but may be a tails thing. i will check it in ventoy tomorrow. but i verified the ISO so it should not be corrupted.

@lbkNhubert @Fraoch i now tried it with kubuntu 22 LTS (i found one on a old disk) using the ubuntu SDC and the EFI does NOT show up as “possible encrypted”. First it did not boot (port 2) but it did BOOT in PORT 5. :ghost:
i verifyed the kubuntu 24LTS and tested it on both ports … did not work.
i verifyed the ubuntu 24LTS and but only tested it on PORT 2.
i have no idea how a sha256 verified iso can result in a corrupted EFI section.
i will re download the 24LTS and verify it again. if it still does not work i will just upgrade from 22LTS. But the fact that it only works in PORT 5 not PORT 2 is wierd, and that the 24 LTS booted on a different PC is wierd as well.