FW 13 AMD Ryzen 7 can't detect SSD anymore

Hey there,
I’m having some trouble getting my FW to work.

I got the DIY version, assembled it and installed Ubuntu 22.04.03-MATE on it. After rebooting I got the login screen, was able to move the cursor for a few seconds until everything froze and the screen went black. This was reproducible for the next reboots, as well. At this point I was not able to switch to another TTY.

As I was not sure if the MATE environment would introduce some issues, I wanted to install the normal Ubuntu 22.04.03 on it. As this whole behaviour seemed familiar, I also took the SSD out and screwed it back in again.
When I wanted to install Ubuntu, I noticed that the SSD could not be found anymore. So I removed and reinserted the SSD again and tried the installation again, with the same result.

The SSD is also not visible in BIOS anymore. Just as a test I unplugged the battery and waited for a few minutes before plugging it in again, but that didn’t change anything.

Did I screw up here or did I get a faulty SSD? Or maybe something completely different?

Just some stats so you know what I’m working with:

  • AMD Ryzen™ 7 7840U
  • DDR5-5600 - 32GB (2 x 16GB)
  • WD_BLACK™ SN850X NVMe™- M.2 2280 - 1TB
  • BIOS version: 3.02

I hope someone has an idea, I really want to start using this laptop. :slight_smile:

Do you have another pc/laptop that you can plug your SSD into? If it isn’t detected then, the SSD may be defective.

Sadly, I just have a Lenovo x220 which isn’t compatible with an NVMe SSD.

You can pick up a nvme to usb adapter to plug it into that. Although, did you buy your SSD separately or through Framework? If you bought it separately, might just be easier to exchange it. If you bought it through Framework, probably should get the adapter and if doesn’t work, then to make a support ticket.

Great, thank you for the hint, I just ordered an adapter. :slight_smile:
I bought the SSD from Framework and didn’t want to go for a support ticket right away.

Yep, looks like the SSD is dead. I plugged it into two other PCs and it can’t be detected.

That’s unfortunate, looks like you’ll need to open a ticket.