Unresponsive System when plugged into AC adapter while external I/O is enabled in the BIOS

Moved this post to Community Support. I Think I posted it in the wrong section.

Just got a I5 12 gen DIY. It is having issues when plugged in.

Did the following

  • Confirmed system works fine in battery
  • Tried another AC Adapter
  • Reseated all memory. Ruled out memory by memory shuffle.
  • Reseated HDD
  • Duplicated hard freeze in live boot environment.
  • Confirmed is hard freeze by using external keyboard and mouse.
  • Found reproducible at windows login screen.
  • Confirmed hard freeze as fingerprint reader also does not trigger login.

Am I missing a troubleshooting step?
Does this sound like hardware?


Same thing for me. Multiple freezes and had a kernel panic :frowning:

@Grant_Morrow Does it only happen when you plug in the AC adapter with no USB devices plugged in?

As you are getting a Kernel Panic you are likely running into something different. As I am in windows and am not getting a Kernel Panic as signified by the fact I am not getting a BSOD.

I am starting to think my issue is External I/O related. So I have disabled External I/O in the BIOS. Currently running tests.

Tests concluded. When running the system with External I/O disabled I do not have a issue with the system freezing when plugged in.

Seems to be a issue with the external I/O (USB) subsystem.

Hi @anzen I’d be happy to help however I can.

You indicated that it took disabling External I/O to get your laptop to stop freezing. This could very well be hardware, but I’d like to fully rule out OS first.

  • Which distro and version are you running?
  • Which kernel are you using?
  • Is this is a new thing, say, after a BIOS update? Trying to determine the course that led to this issue. New peripherals, new distro, etc.
  • Does the hard freeze happen regardless if anything peripherals are attached or not?
  • This is without any external monitor attached?

Thanks, I’ll circle back to this once I have a better idea as to what is happening.

@Matt_Hartley Thank you for your reply.

  • This is Windows 11. To rule out OS I tried to install Ubuntu 22.04.1 but it failed with same symptoms on the Live Boot environment. I was ruling out the OS as the fact that the system worked in safe mode. Even with no other software except drivers and the OS installed. Turns out Safe Mode on Windows disables USB and uses Legacy USB.
  • This is not a new thing. While I was installing windows for the first time it locked up during the setup process. Had to attempt a reinstall of OS a few times to get it to install. I believe I disconnected it from AC power and that was what allowed it to install. I can not remember. The system is recently received this week.
  • The freeze happens when the USB-C Power adapter(two separate ones to rule out adapter) is plugged in. This is also with just the USB-C module and power adapter plugged into that. I did not attempt with any other other USB Devices. Mostly as I have very few USB-C Devices.
  • This is without external monitor attached.

I did not mean to take up two of Framework’s Employees time here I apologize. I already opened a support case. Currently waiting on their response with the most recent development with the I/O being disabled in the BIOS. My goal with this post was to ask the community if they had any other ideas in case I forgot to do a troubleshooting step.

@anzen No apologies needed, this is literally what I am here for - you amazing folks. :slight_smile:

I’m the Linux Support Lead for the company and I live for this stuff.

Glad to hear you’ve opened a support case, you’re in excellent hands. You did solid troubleshooting. Might be a power pull going sideways. But the support team in your ticket will get you squared away.

Appreciate the update,


Using rubber duck troubleshooting and soundboards. I came to the same conclusion. Looks like I am just waiting for support to due their due diligence and confirm.

1 Like

Keep me posted. Feel free to reply here if I can help at all smooth things along.

Small update for those following also documenting to so others know what to try.

I was prompted to reset the BIOS settings back to default. With that step the issue fails with something that makes more sense.

  • I tested the power plug straight into the USB-C Ports that are for the modules I determined the Upper left is the only one that fails. It also fails without the USB-C Modules.
  • I tested with the USB-C module. It passes in all except the upper left.

What I concluded from that is there is something wrong with the upper left USB-C port. Now I am waiting for support to conclude and confirm it is a hardware issue so I can get a RMA.

What was interesting is before the BIOS reset and the battery drain last night it was failing on all ports.

1 Like

Update. My ticket was escalated for a RMA of the mainboard.

Looks like I lost the part lottery this time around. For those reading that would blame QA don’t. If you do I would argue you do not understand QA and how it is done in mass/batch manufacturing.

I am now waiting for the escalation of the ticket to be addressed so the part can be shipped.

Support at the lower levels seems well staffed. Allowing the support representatives to respond to updates in a timely matter.

It looks like Framework follows the case ownership model. Knowing this helps me set expectations in case I need to contact them in the future.

This is correct. And thanks for keeping me updated so I can advocate for you if this needs any extra help.


Mainboard was replaced. That solved my problems in the test that I have done. I can now use my system with all ports plugged in.


Yay! Delighted to hear this latest update!