USB-C/Thunderbolt Dock Megathread

@apol1o - In my research I did not see a good dock supporting 120 Hz.

Based on your post, I went back to Intel’s website for the processor:

This is the processor in my laptop (Batch 6). If I am reading the specifications correctly, the chip only supports 60 Hz via HDMI and DisplayPort.

Hope this detail helps you
Cheers

1 Like

@Patrick_Corey
The page clearly states:

Max Resolution (DP): 7680x4320@60Hz

@apol1o
I have a similar requirement for a 1440p UW at 120 Hz+. Is it because your monitor doesn’t have HDMI 2.0? The DP 1.2 standard itself supports enough bandwidth for 4K60 which is close to UWQHD at 120 Hz; if you’re having trouble with a device it might be lax adherence to standards, who knows.

There are a couple docks by Cable Matters that support even up to DP 1.4, but the USB A ports are 2.0 and the ethernet is only 480 MBps. Everything else I’ve found is backordered or is too pricey (I thought $100 USD would suffice for charging, two USB 3.0 and one DP 1.2)

1 Like

@iaredavid - I am aware of the resolution clock speed and I posted to link to share the detail.

I do not understand your comment. As I read it again, it confirms what I posted.

Regarding the 120 Hz configuration that is being asked:
I have always understood that all items connected from a computer to a monitor have to support the resolution speed. In other words, computer, docking station, cables, and monitor have to support 120 Hz.

With the Intel Iris Chip supporting 60 Hz as its max, then I do not see any possible configuration to yield any monitor resolution at 120 Hz.

@iaredavid

Yes, the monitor is an Alienware AW3420. Unfortunately it has HDMI 1.4, so it does only 50Hz. It has just a single DP 1.2 which is already a bit of a pain but you’re right, 4K@60Hz is almost the same bandwidth. During my (probably limited) research I found that many docks don’t do UWQHD@120Hz even though they do 4K@60Hz. I’m not sure if that’s due to DisplayLink or some other weird firmware limitations.
I was also trying to avoid getting one of those >$250 docks. At that point I might just get a monitor with HDMI 2.0 :roll_eyes:

@Patrick_Corey

I’m not entirely sure if that’s the case. What Intel lists here is the DP 1.4 spec, which also does 4K@120Hz. I think it’s not the specific clockrate at max resolution that matters here, rather the total bandwidth. 4K@120Hz is ~28.5Gbit/s, whereas UWQHD@120Hz is just ~17Gbit/s.

Anyway, I just pre-ordered the 12th gen so I can’t test any docks until it arrives in july.

1 Like

That’s not accurate in the slightest, it lists 4k60 as an example of maximum bandwidth. For ease of math you can equate 4k60 to 1080p240 that should be equivalent in bandwidth. I’m using a Surface Go right now and its displaying 1080p120 on an external monitor, and thats using a much weaker iGPU

This is correct

1 Like

Thank you for sharing additional information regarding the resolution bandwidth.


Max Resolution (HDMI)‡  4096 x 2304 @ 60Hz
Max Resolution (DP)‡  7680 x 4320 @ 60Hz
Max Resolution (eDP - Integrated Flat Panel)‡  4096 x 2304 @ 120Hz

Yes the new motherboard has a higher clock speed.

I had the unfortunate experience of having a 120 Hz TV/Monitor fail late last year. The manufacturer could not fix or repair it due to the chip shortage. Luckily I was reimbursed the original purchase price. Given this experience and that my framework is only 6 months old, I might wait and upgrade after the unit is 1 year old.

Thank you again

Like @Michael_Fox, I have a Corsair TBT100 dock. This dock does not work with the Framework Laptop. Only one external monitor can be used at any time. The other ports work though.

I’ve done some analysis while going through the issue with Framework support. It seems like the dock refuses to run two displays while it is connected at 20Gbps Thunderbolt speeds. My other laptops which connect at 40Gbps work fine with it, and the Framework works with other docks as specified in this thread. It seems like other laptops that don’t have the hardware to do 40Gbps Thunderbolt (like some 2018-2019 Thinkpads) have the same monitor problem with this dock.

In this case, the problem is that the Framework should be able to do 40Gbps with this dock but simply doesn’t. The Framework can do 40 with other docks, just not this one. If you want to check the current bandwidth of your dock, run boltctl in Linux. There doesn’t appear to be an easy way to check it in Windows.

Support has said that there is nothing we can do about this problem. I’m speculating that it’s something in firmware and there just aren’t enough of these docks around to warrant an investigation. So I had to buy a different dock.

1 Like

To all people having problems with the Dell WD19TB (might apply to other DELL models as well):

Early revisions of the Firmware on Dell TB Docking stations were really, really buggy and quirky, to the point that they often seemed to be unusable or defective even when run with Windows drivers.

I guess a lot of the pretty cheap-to-have Dell Docks on eBay, which were quite expensive initially, are there because they have been sent back in loads due to constant malfunction.

The key to fixing those non-functioning Dell Docks is often to get hold of a Windoze Box, install the “Dell Command” Application and update them to their latest firmware. After that, try them again and be amazed :slight_smile:

Oh, also (sorry, I can’t seem to edit posts yet), I am willing to bet that Intel 12th gen motherboards won’t have this problem. They’ll have a different firmware with different bugs, but probably not this one. This is entirely theorycraft and not at all rooted in any facts that I have access to.

Unable to edit the Wiki post at the moment, but I’ve just tried the CableMatters 107044 with my 11-gen running Fedora 36. Everything tested works out of the box. Tested:

  • 4k@60Hz monitor over DisplayPort (single)
  • Lots of the USB A ports

To share some details, I was fortunate to purchase an AOC 49" LED MONITOR (model AG493UCX) today.

While I have unboxed and assembled the unit, I connected the monitor with the included USB-C cable to my framework laptop. After making an adjustment within the display settings (picture attached AOC-49-Monitor.png), the resolution is reported as 3840 x 1080 @ 120 Hz.

The Framework laptop is using POP!_OS 22.04 LTS with no special drivers (outside the default installation); image attached - Installed_OS-hardware.png.

–Additional testing results below using the same hardware I had disclosed (within this topic/thread as well as the other Expansion Cards that I have purchased).----

Using the StarTech TB3DK2DPPD docking station, I can connect the AOC monitor to the Framework laptop reaching 120 Hz. @apol1o - this monitor is an ultrawide model.

Here is how I preform my testing (but feel free to provide an suggestions):
I was able to reach 5120x1440 via 100.00 Hz with the StarTech dock by connecting the monitor’s provided DisplayPort cable to the dock, then connect the dock to the Framework laptop via the Belkin cable USB-C. As a side note, the options for refresh rate at 5120x1440 were 59.98 Hz, 70.30 Hz, 75.00 Hz, and 100.00 Hz. Note: Connecting the USB-C cable to either Thunderbolt™ 3 USB-C (24-pin) (40Gbps) on the dock achieved the same results. Also this dock does support 5K or 2 4K monitors (1 via DP and 1 via TB3 USB-C port with up to 40 Gbps of throughput)
To reach 120 Hz, I had to change the resolution to 3840x1080. Thereafter any lesser resolution provides the refresh rate choices as 59.98 Hz or 120 Hz.

When I connect the monitor using the DisplayPort Expansion Card (to the laptop), the max resolution is 5120x1440 @ 120.00 Hz (with other options 59.98 Hz, 70.30 Hz, 75.00 Hz, or 100.00 Hz). Technically I can use the Framework Expansion cards to connect both the DisplayPort and USB-C port resulting in the laptop thinking there are two AOC monitors. I will not use the configuration.

When I use the majority of the monitor’s provided cables for DisplayPort, USB upstream cable, and USB-C, the dock will only provide the 5K resolution @ 100.00 Hz. Once I remove the DisplayPort cable from the dock, the monitor will detect the USB-C connection via TB3 at the same resolutions as I reported (3840x1440 @ 120.00 Hz max).

I am happy using the 5K resolution at 100.00 Hz via the DisplayPort.

This configuration allows peripherals (such as keyboard, mouse, jabra conference speaker, headphones, and Logitech WebCam) to be connected to the monitor, the majority of the cables to be connected to the dock, and a single USB-C cable connected to the docking station.

I hope this post was helpful.

P.S.
I have not tested the OWC USB-C Travel Dock E to see if I can get any resolution at 120 Hz.

1 Like

Does anyone know of a Thunderbolt 4 dock with 10GbE?

Just confirmed today that the Lenovo Universal USB-C dock 90W works well with Fedora 36.

-Power delivery works
-HDMI out works
Edit: HDMI has this kind of weird stuttering that happens every now and then. Not sure what the problem is. I tried using the USB-C cable that comes with the dock and it seems stable so far? I was using a Startech thunderbolt cable before. I’ll update again if I see it again.

-Not sure about displayport outputs, don’t have any cables but will try later.
-USB works
-Ethernet works
-Audio works

https://www.lenovo.com/us/en/p/accessories-and-software/docking/docking_usb-docks-(universal-cable-docks)/40ay0090us

@ hCJ0t6BQ8

I have not found any dock that would openly support 10GbE. I would imagine the 10 GbE network port would increase the total cost as well.

Instead, I purchased the Sonnet Solo 10G Thunderbolt 3 to SFP+ 10 Gigabit Ethernet Adapter.
# 10 Gigabit Ethernet Adapter

Depending on the type of network cable for 10 GbE, there is going to be a heat issue overall. I chose to use Optical cables with SFP+ connections because I already have SFP+ Switches (and other servers using this network infrastructure). From the information I gathered Optical cables with SPF+ does not have the heat issues that an ethernet cable with RJ45 ends.

This unit supports Thunderbolt 3 or 4 cables. My Framework laptop has two Thunderbolt 3 cables connected to a StarTech Dock and the Sonnet Solo.

The device was recognized using POP!_OS 22.04; no require to install other drivers.

1 Like

Very weird, can’t edit my post.

But i’ve been using the Lenovo Universal usb-c dock 90W with Displayport and it works 100%. No flickering issues at all.

It’s just because you are new I think, the system hasn’t given you permission to do that yet

1 Like

Fixed, try it now. :slightly_smiling_face:

1 Like